• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

把机构买卖改成飞狐可用的

常见公式 第一股票指标公式网 3周前 (11-02) 10次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

求助,请老师把机构买卖改成飞狐可用的,谢谢!

{机构买卖}
A1:=SUM(IF(CLOSE>REF(CLOSE,1),VOL/CAPITAL*100,IF(CLOSE<REF(CLOSE,1),-VOL/CAPITAL*100,0)),0);
成交额:=V*C/100,NODRAW;{万元}
A2:=SUM((IF(((成交额/8>20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A3:=SUM((IF(((成交额/8>20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A4:=SUM((IF(((成交额/8<20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A5:=SUM((IF(((成交额/8<20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A6:=((A2+A3)+A4)+A5;
A7:=IF((ISLASTBAR),((100*A2)/A6),0);
A8:=IF((ISLASTBAR),((100*A3)/A6),0);
A9:=IF((ISLASTBAR),((100*A4)/A6),0);
A10:=IF((ISLASTBAR),((100*A5)/A6),0);
增减仓%:A1;
机构买盘:(A2),LINETHICK6,COLORRED;
机构卖盘:(A3),LINETHICK6,COLORFFFF55;
机构进出:机构买盘-机构卖盘,NODRAW;
散户买盘:(A4),COLOR5555FF;{细红线}
散户卖盘:(A5),COLOR55FF55;{细绿线}
强势:((100*A2)/A6>50);
STICKLINE(强势,机构买盘*1.02,机构买盘*1.1,1,0),COLORYELLOW;
拉升:((100*A2)/A6-(100*A3)/A6)>18 AND (100*A2)/A6-(100*A5)/A6>18;
STICKLINE(拉升,机构买盘*1.1,机构买盘*1.2,1,0),COLORFF00FF;
DRAWTEXT(ISLASTBAR=1,机构买盘*0.95,’●机构买盘’),LINETHICK2,COLORRED;
DRAWTEXT(ISLASTBAR=1,机构卖盘*0.95,’○机构卖盘’),LINETHICK2,COLORFFFF55;
DRAWTEXT(机构进出>0 AND REF(机构进出,1)<=0,机构买盘*1.02,’●机买’),COLORRED;
DRAWTEXT(机构进出<0 AND REF(机构进出,1)>=0,机构买盘*0.98,’○机卖’),COLORFFFF55;

 
解答如下:
A1:=SUM(IF(CLOSE>REF(CLOSE,1),VOL/CAPITAL*100,IF(CLOSE<REF(CLOSE,1),-VOL/CAPITAL*100,0)),0);
成交:=V*C/100;{万元}
A2:=SUM((IF(((成交/8>20) AND (CLOSE>(REF(CLOSE,1)))),成交,0)),0);
A3:=SUM((IF(((成交/8>20) AND (CLOSE<(REF(CLOSE,1)))),成交,0)),0);
A4:=SUM((IF(((成交/8<20) AND (CLOSE>(REF(CLOSE,1)))),成交,0)),0);
A5:=SUM((IF(((成交/8<20) AND (CLOSE<(REF(CLOSE,1)))),成交,0)),0);
A6:=((A2+A3)+A4)+A5;
A7:=IF((ISLASTBAR),((100*A2)/A6),0);
A8:=IF((ISLASTBAR),((100*A3)/A6),0);
A9:=IF((ISLASTBAR),((100*A4)/A6),0);
A10:=IF((ISLASTBAR),((100*A5)/A6),0);
增减仓%:A1;
机构买盘:(A2),LINETHICK6,COLORRED;
机构卖盘:(A3),LINETHICK6,COLORFFFF55;
机构进出:机构买盘-机构卖盘,linethick;
散户买盘:(A4),COLOR5555FF;{细红线}
散户卖盘:(A5),COLOR55FF55;{细绿线}
强势:((100*A2)/A6>50);
STICKLINE(强势,机构买盘*1.02,机构买盘*1.1,1,0),COLORYELLOW;
拉升:((100*A2)/A6-(100*A3)/A6)>18 AND (100*A2)/A6-(100*A5)/A6>18;
STICKLINE(拉升,机构买盘*1.1,机构买盘*1.2,1,0),COLORFF00FF;
DRAWTEXT(ISLASTBAR=1,机构买盘*0.95,’●机构买盘’),LINETHICK2,COLORRED;
DRAWTEXT(ISLASTBAR=1,机构卖盘*0.95,’○机构卖盘’),LINETHICK2,COLORFFFF55;
DRAWTEXT(机构进出>0 AND REF(机构进出,1)<=0,机构买盘*1.02,’●机买’),COLORRED;
DRAWTEXT(机构进出<0 AND REF(机构进出,1)>=0,机构买盘*0.98,’○机卖’),COLORFFFF55;

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址