• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

(黄色柱子出现)选股公式

常见公式 第一股票指标公式网 3周前 (11-03) 5次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

VAR31:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR32:=REF(VAR31,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR33:=REF(VAR32,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR34:=REF(VAR33,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

 

VAR35:=REF(VAR34,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR36:=REF(VAR35,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR37:=REF(VAR36,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR38:=REF(VAR37,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR39:=REF(VAR38,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR39,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);

VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR110:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR111:=REF(VAR110,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR112:=REF(VAR111,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
DIFF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIFF,9),COLORFFFF00;
VAR113:=REF(VAR112,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR114:=REF(VAR113,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR115:=REF(VAR114,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
D:((((LLV(MACD,8)>0) AND (MACD>REF(MACD,1))) AND (REF(MACD,1)<REF(MACD,2))) AND (REF(MACD,2)<REF(MACD,3))) AND (REF(MACD,3)<REF(MACD,4))AND (REF(MACD,4)>REF(MACD,5))AND (REF(MACD,5)>REF(MACD,6));
VAR116:=REF(VAR115,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR117:=REF(VAR116,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR118:=REF(VAR117,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
MACD:=(DIFF-DEA)*2;
VAR119:=REF(VARD OR VARE OR VARF OR VAR110 OR VAR111 OR VAR112 OR VAR113 OR
VAR114 OR VAR115 OR VAR116 OR VAR117 OR VAR118,1) AND VAR31;
VAR1A:=REF(VAR31 OR VAR32 OR VAR33 OR VAR34 OR VAR35 OR VAR36 OR VAR37 OR
VAR38 OR VAR39 OR VARA OR VARB OR VARC,1) AND VARD;

A:STICKLINE(MACD>=0 AND MACD>=REF(MACD,1) AND REF(MACD,1)<0 AND MACD>=0.01,0,MACD,10,0) ,COLORRED ;

E2回抽:STICKLINE((((LLV(MACD,3)>0) AND (MACD>REF(MACD,1))) AND (REF(MACD,1)<REF(MACD,2))) AND (REF(MACD,2)<REF(MACD,3))AND MACD>=0.15,6,MACD,5,0),COLORYELLOW; ;
===============================================

以上是一个指标公式,觉得挺好的,希望帮忙做个选股公式啊–就是黄色柱子出现时。要是能做成盘中预警的也可以。

 
解答如下:
DIFF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=(DIFF-DEA)*2;
E2回抽:(((LLV(MACD,3)>0) AND (MACD>REF(MACD,1))) AND (REF(MACD,1)<REF(MACD,2))) AND (REF(MACD,2)<REF(MACD,3))AND MACD>=0.15;
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址