• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

历史“买点周期”公式和历史“选股公式”

常见公式 第一股票指标公式网 3周前 (11-03) 8次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

求助:历史“买点周期”公式和历史“选股公式”
买点:快:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
慢:=SMA(快,3,1);
BB:=IF(BARSLAST(CROSS(慢,快))>=3 AND CROSS(快,慢) AND 慢<30,20,0);
买点:=IF(BB,40,0);
求助: 1、最近的一个买点周期为:买点周期:BARSLAST(买点>0);(买点出现的第一天其周期为“买点周期+1”)
上一个买点周期为:上买点周期:REF(买点周期,买点周期+1);

那么,第3、第4、第5、…….第N个“N买点周期”该如何用公式表述呢?我用了参数N:缺省1 最小1 最大999,但是不行。

2、买点出现的收盘价标示和画线为:
画线:=IF(FILTER(买点>0,3),REF(C,买点周期),0);
drawsl(画线>0,画线,0,0,3),LINEDOT,COLORCYAN;
上买点周期:=REF(买点周期,买点周期+1);
DRAWNUMBER(买点>0 AND C>=REF(C,上买点周期),H*1.03,C,2),COLORWHITE;
DRAWNUMBER(买点>0 AND C<REF(C,上买点周期),H*1.03,C,2),COLORGREEN;

那么,历史阶段中出现的相邻的3个买点的收盘价呈依次降价排列时,比如第N+3买点收盘价为N3C:20,第N+2买点收盘价为N2C:19,第N+1买点收盘价为N1C:18,如何写能满足下列条件的选股公式(设均线M10:MA(C,10)):
TJ:N3C>N2C AND N2C>N1C AND M10>=N1C AND M10<N3C AND COUNT(M10<N1C,(N+1)买点的周期数)=0 AND CROSS(M10,REF(M10,1));(N3C的值大于N2C的值,N2C的值大于N1C的值,M10在N+1买点周期内保持大于等于N1C的值,且小于N3C的值)
XG:TJ;(能在任意历史阶段选股)

 

 

 
解答如下:
问题1

快:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
慢:=SMA(快,3,1);
买点:BARSLAST(CROSS(慢,快))>=3 AND CROSS(快,慢) AND 慢<30;
N买点周期:SUMBARS(买点,N);

wt2::需要循环,通达信做不到
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址