• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

将(二次金叉)公式改成同花顺指标

常见公式 第一股票指标公式网 3个月前 (11-03) 11次浏览 已收录 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

DIF1:=EMA(CLOSE,12) – EMA(CLOSE,26);
DEA1:=EMA(DIF1,9);
MACD1:=2*(DIF1-DEA1);
MACD2:=EMA(MACD1,3);
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,1,0),COLORRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,1,0),COLORF00FF0;
STICKLINE(MACD1<MACD2,0,MACD1,1,0),COLORCYAN;
STICKLINE(MACD1>=0 OR MACD1<=0,0,0,50,1),COLORWHITE;
DIFF:DIF1,COLOR33FF33;
DEA:DEA1,COLORYELLOW;
MACD:MACD1,linethick0,COLORMAGENTA;
partline(dif1,dif1>=dea1,rgb(255,0,0)),linethick2;
强:if(dif1>dea1,dif1,0),linethick0,colorred;
低叉:= CROSS(DIFF,DEA) AND DIFF<(-0.1);
STICKLINE(低叉,0,-0.3,1,0),COLOR00FFFF;
DRAWTEXT(低叉,-0.3,’ 低叉’),COLOR00FFFF;
JCCOUNT:= COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二叉:= CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二叉,0,-0.15,1,0),COLORFF00FF;
DRAWICON(二叉,DEA*1.04,1),COLOR0000FF;
DRAWTEXT(二叉,-0.15,’ 二叉’),COLORFF00FF;
A1:= BARSLAST(REF(CROSS(DIFF,DEA),1));
底背:= REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
STICKLINE(底背,0,0.15,1,0),COLOR00FF00;
DRAWLINE(A1=0,DEA,底背,DEA,0),LINETHICK3,COLORWHITE;
DRAWTEXT(底背,0.15,’ 底背’),COLOR00FF00;
A2:= BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背:= REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
DRAWLINE(A2=0,DEA,顶背,DEA,0),LINETHICK3,COLORBLUE;
 
解答如下:
{不必改。直接复制就可以}
DIF1:=EMA(CLOSE,12) – EMA(CLOSE,26);
DEA1:=EMA(DIF1,9);
MACD1:=2*(DIF1-DEA1);
MACD2:=EMA(MACD1,3);
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,1,0),COLORRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,1,0),COLORF00FF0;
STICKLINE(MACD1<MACD2,0,MACD1,1,0),COLORCYAN;
STICKLINE(MACD1>=0 OR MACD1<=0,0,0,50,1),COLORWHITE;
DIFF:DIF1,COLOR33FF33;
DEA:DEA1,COLORYELLOW;
MACD:MACD1,linethick0,COLORMAGENTA;
partline(dif1,dif1>=dea1,rgb(255,0,0)),linethick2;
强:if(dif1>dea1,dif1,0),linethick0,colorred;
低叉:= CROSS(DIFF,DEA) AND DIFF<(-0.1);
STICKLINE(低叉,0,-0.3,1,0),COLOR00FFFF;
DRAWTEXT(低叉,-0.3,’ 低叉’),COLOR00FFFF;
JCCOUNT:= COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二叉:= CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二叉,0,-0.15,1,0),COLORFF00FF;
DRAWICON(二叉,DEA*1.04,1),COLOR0000FF;
DRAWTEXT(二叉,-0.15,’ 二叉’),COLORFF00FF;
A1:= BARSLAST(REF(CROSS(DIFF,DEA),1));
底背:= REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
STICKLINE(底背,0,0.15,1,0),COLOR00FF00;
DRAWLINE(A1=0,DEA,底背,DEA,0),LINETHICK3,COLORWHITE;
DRAWTEXT(底背,0.15,’ 底背’),COLOR00FF00;
A2:= BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背:= REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
DRAWLINE(A2=0,DEA,顶背,DEA,0),LINETHICK3,COLORBLUE;
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址