• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

把MACD公式的DIFF向上改成选股公式

常见公式 第一股票指标公式网 3周前 (11-04) 9次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

请老师把MACD公式的DIFF向上改成选股公式,只要DIFF是向上股都可以选出来【也就是diff的今天的值大于昨天的值】
先谢谢老师
DIF:(EMA(CLOSE,9)-EMA(CLOSE,26))*10000,COLORRED;
DEA:EMA(DIF,12);
MACD:(DIF-DEA)*2,COLORSTICK;
STICKLINE(MACD>=0,MACD,0,4,1),COLORF00FF0;
STICKLINE(MACD<0,MACD,0,4,1),COLORWHITE;
STICKLINE(MACD<REF(MACD,1)and MACD>0,0,MACD,4,0 ),COLOR00aaff;
STICKLINE(MACD<REF(MACD,1)and MACD>0,0,MACD,3.3,0 ),COLOR00bbff;
STICKLINE(MACD<REF(MACD,1)and MACD>0,0,MACD,2.2,0 ),COLOR00ccff;
STICKLINE(MACD<REF(MACD,1)and MACD>0,0,MACD,1.65,0 ),COLOR00ddff;
STICKLINE(MACD<REF(MACD,1)and MACD>0,0,MACD,1.1,0 ),COLOR00eeff;
STICKLINE(MACD<REF(MACD,1)and MACD>0,0,MACD,0.55,0 ),COLOR00ffff;
STICKLINE(MACD>=REF(MACD,1)and MACD>0,0,MACD,4 ,0 ),COLOR0000aa;
STICKLINE(MACD>=REF(MACD,1)and MACD>0,0,MACD,3.3 ,0 ),COLOR0011bb;
STICKLINE(MACD>=REF(MACD,1)and MACD>0,0,MACD,2.2,0 ),COLOr0022cc;
STICKLINE(MACD>=REF(MACD,1)and MACD>0,0,MACD,1.65 ,0 ),COLOR0033dd;
STICKLINE(MACD>=REF(MACD,1)and MACD>0,0,MACD,1.1 ,0 ),COLOR0044ee;
STICKLINE(MACD>=REF(MACD,1)and MACD>0,0,MACD,0.55 ,0 ),COLOR0055ff;
STICKLINE(MACD>REF(MACD,1)and MACD<0,0,MACD,4,0 ),COLOraa00bb;
STICKLINE(MACD>REF(MACD,1)and MACD<0,0,MACD,3.3 ,0 ),COLORbb11bb;
STICKLINE(MACD>REF(MACD,1)and MACD<0,0,MACD,2.2,0 ),COLOrcc22bb;
STICKLINE(MACD>REF(MACD,1)and MACD<0,0,MACD,1.65,0 ),COLORdd33bb;
STICKLINE(MACD>REF(MACD,1)and MACD<0,0,MACD,1.1,0 ),COLORee44bb;
STICKLINE(MACD>REF(MACD,1)and MACD<0,0,MACD,0.55 ,0 ),COLORff55bb;
STICKLINE(MACD<=REF(MACD,1)and MACD<0,0,MACD,4,0 ),COLOrffaa00;
STICKLINE(MACD<=REF(MACD,1)and MACD<0,0,MACD,3.3 ,0 ),COLORffbb11;
STICKLINE(MACD<=REF(MACD,1)and MACD<0,0,MACD,2.2,0 ),COLOrffcc22;
STICKLINE(MACD<=REF(MACD,1)and MACD<0,0,MACD,1.65 ,0 ),COLORffdd33;
STICKLINE(MACD<=REF(MACD,1)and MACD<0,0,MACD,1.1 ,0 ),COLORffee44;
STICKLINE(MACD<=REF(MACD,1)and MACD<0,0,MACD,0.55 ,0 ),COLORffff55;

RSVK:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
KK:=SMA(RSVK,3,1);
DK:=SMA(KK,3,1);
JK:=3*KK-2*DK;
顶:(JK<120 AND JK>98 AND JK>REF(JK,1))*6000,COLORYELLOW,linethick0;;
A1:=(CLOSE/MA(CLOSE,3)>=(1+0.07) AND CLOSE=HHV(CLOSE,3) AND MA(VOL,2)/MA(VOL,40)>=3 AND
MA(VOL,2)=HHV(MA(VOL,2),3) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1));
A9:=MA(CLOSE,30);
A10:=(CLOSE-A9)/A9*100;
A11:=MA(A10,3);
A15:=BARSLAST(CROSS(-10,A11)=1);

RR8:=MA(CLOSE,27);
RR9:=(CLOSE-RR8)/RR8*100;
RRA:=MA(RR9,2);
RRB:=BARSLAST(CROSS(-10,RRA)=1);
RRD:=RRA<-10 AND RRB>3;
黄金坑:IF(RRD,-4000,0),COLORYELLOW,LINETHICK2;

PARTLINE(dif>=REF(dif,1),dif),colorred,linethick2;
PARTLINE(dif<REF(dif,1),dif),colorgreen,linethick2;

 

STICKLINE(MACD>=0,MACD,0,4,1),COLORF00FF0;
STICKLINE(MACD<0,MACD,0,4,1),COLORWHITE;
STICKLINE(MACD<REF(MACD,1)and MACD>0,0,MACD,4,0 ),COLOR00aaff;
STICKLINE(MACD<REF(MACD,1)and MACD>0,0,MACD,3.3,0 ),COLOR00bbff;
STICKLINE(MACD<REF(MACD,1)and MACD>0,0,MACD,2.2,0 ),COLOR00ccff;
STICKLINE(MACD<REF(MACD,1)and MACD>0,0,MACD,1.65,0 ),COLOR00ddff;
STICKLINE(MACD<REF(MACD,1)and MACD>0,0,MACD,1.1,0 ),COLOR00eeff;
STICKLINE(MACD<REF(MACD,1)and MACD>0,0,MACD,0.55,0 ),COLOR00ffff;
STICKLINE(MACD>=REF(MACD,1)and MACD>0,0,MACD,4 ,0 ),COLOR0000aa;
STICKLINE(MACD>=REF(MACD,1)and MACD>0,0,MACD,3.3 ,0 ),COLOR0011bb;
STICKLINE(MACD>=REF(MACD,1)and MACD>0,0,MACD,2.2,0 ),COLOr0022cc;
STICKLINE(MACD>=REF(MACD,1)and MACD>0,0,MACD,1.65 ,0 ),COLOR0033dd;
STICKLINE(MACD>=REF(MACD,1)and MACD>0,0,MACD,1.1 ,0 ),COLOR0044ee;
STICKLINE(MACD>=REF(MACD,1)and MACD>0,0,MACD,0.55 ,0 ),COLOR0055ff;
STICKLINE(MACD>REF(MACD,1)and MACD<0,0,MACD,4,0 ),COLOraa00bb;
STICKLINE(MACD>REF(MACD,1)and MACD<0,0,MACD,3.3 ,0 ),COLORbb11bb;
STICKLINE(MACD>REF(MACD,1)and MACD<0,0,MACD,2.2,0 ),COLOrcc22bb;
STICKLINE(MACD>REF(MACD,1)and MACD<0,0,MACD,1.65,0 ),COLORdd33bb;
STICKLINE(MACD>REF(MACD,1)and MACD<0,0,MACD,1.1,0 ),COLORee44bb;
STICKLINE(MACD>REF(MACD,1)and MACD<0,0,MACD,0.55 ,0 ),COLORff55bb;
STICKLINE(MACD<=REF(MACD,1)and MACD<0,0,MACD,4,0 ),COLOrffaa00;
STICKLINE(MACD<=REF(MACD,1)and MACD<0,0,MACD,3.3 ,0 ),COLORffbb11;
STICKLINE(MACD<=REF(MACD,1)and MACD<0,0,MACD,2.2,0 ),COLOrffcc22;
STICKLINE(MACD<=REF(MACD,1)and MACD<0,0,MACD,1.65 ,0 ),COLORffdd33;
STICKLINE(MACD<=REF(MACD,1)and MACD<0,0,MACD,1.1 ,0 ),COLORffee44;
STICKLINE(MACD<=REF(MACD,1)and MACD<0,0,MACD,0.55 ,0 ),COLORffff55;
PARTLINE(dif>=REF(dif,1),dif),colorred,linethick2;
PARTLINE(dif<REF(dif,1),dif),colorgreen,linethick2;

 
解答如下:
DIF:=(EMA(CLOSE,9)-EMA(CLOSE,26));
DIF>REF(DIF,1);
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址