• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

三组合选股公式

常见公式 第一股票指标公式网 3个月前 (11-04) 9次浏览 已收录 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

请帮忙根据下列源码,在下图所示的地方写个选股公式,谢谢

VAR1:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),25);
VAR2:=HIGH-REF(HIGH,1);
VAR3:=REF(LOW,1)-LOW;
VAR4:=SUM(IF(VAR2>0 AND VAR2>VAR3,VAR2,0),25);
VAR5:=SUM(IF(VAR3>0 AND VAR3>VAR2,VAR3,0),25);
VAR6:=VAR4*100/VAR1;
VAR7:=VAR5*100/VAR1;
VAR8:=MA(ABS(VAR7-VAR6)/(VAR7+VAR6)*100,15);
VAR9:=(VAR8+REF(VAR8,15))/2;
A:=(VAR7>VAR6 AND VAR7>25 AND VAR6<25);
B:=ZIG(1,13)*100,colorred;
G:=MA(B,2);
D:CROSS(B,G)*100,COLORFF00FF,LINETHICK1;
W:CROSS(G,B)*100,colorf0f000,LINETHICK1;

Var1:=(HHV(HIGH,5)-LLV(LOW,5));
Var2:=(HHV(HIGH,9)-CLOSE);
Var3:=(CLOSE-LLV(LOW,9));
Var4:=Var2/Var1*100-70 ;
Var5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
Var6:=(2*C+H+L)/4;
Var7:=SMA((Var3/Var1*100),3,1);
Var8:=LLV(LOW,34);
Var9:=SMA(Var7,3,1)-SMA(Var4,9,1);
Var10:= IF(Var9>100,Var9-100,0);
VarA:=HHV(HIGH,34);
趋势: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA
(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),colorff20aa,linethick2;
见底信号:FORCAST(EMA((10*CLOSE+7*OPEN+HIGH+LOW)/19,5),6),coloryellow,linethick1;

防线B:EMA((Var6-Var8)/(VarA-Var8)*100,8),COLOR3366ff;
B1:EMA(防线B,5);
STICKLINE(防线B>0 AND 防线B-B1<0,13,4,2,0),COLOR00FF00;
STICKLINE(防线B-B1>0,防线B,B1,8,1),linethick1,colorred;
STICKLINE(防线B>0 AND 防线B-B1>=0,98,100,6,0),colorred;
STICKLINE(防线B>0 AND 防线B-B1<0,98,100,6,0),COLOR00FF00;
STICKLINE(防线B>0 AND 防线B-B1>=0,49,50,6,0),colorred;
STICKLINE(防线B>0 AND 防线B-B1<0,49,50,6,0),COLOR3366ff;
STICKLINE(防线B>0 AND 防线B-B1>=0,13,4,2,0),colorred;
STICKLINE(防线B-B1<0,防线B,B1,6,1),colorgreen ;

 

Var1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
Var2:=LLV(LOW,21);
Var3:=HHV(HIGH,21);
SK: EMA((Var1-Var2)/(Var3-Var2)*100,5);
SD: EMA(0.667*REF(SK,1)+0.333*SK,4);
Var4:=IF(CROSS(SD,SK) AND SK>=60,60,76);
Var5:=IF(CROSS(SK,20) OR CROSS(SK,SD) AND SK>20,20,5);
买进: Var5;
卖出: Var4;
高抛: 80, POINTDOT;
低吸: 20, POINTDOT;
强弱: 50, POINTDOT;
Var6:=LLV(LOW,55);
Var7:=HHV(HIGH,34);
Var8:=EMA((Var1-Var6)/(Var7-Var6)*100,3);
Var9:=(SK+Var8)/2;
VarA:=EMA(0.667*REF(Var8,1)+0.333*SK,2);
VarB:=EMA(Var9,5);
VarC:=EMA(0.667*REF(VarB,1)+0.333*VarB,2);
IF(VarB>=40,20,0);


 

解答如下:
{ZIG之字转向未来函数,小心使用}

B:=ZIG(1,13)*100;
G:=MA(B,2);
D:CROSS(B,G)*100;
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址