• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

终极DMI指标改成飞狐的

常见公式 第一股票指标公式网 3周前 (11-04) 8次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

TH:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI: DMP*100/TR,COLORFFFFFF,LINETHICK2;
MDI: DMM*100/TR,COLOR00FFFF,LINETHICK2;
ADX: EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M),LINETHICK1;
ADXR:EXPMEMA(ADX,M),COLOR00FF00,LINETHICK1;

底:1.5,COLOR0BFFFF,POINTDOT,COLOR00FF00;
好:50,COLOR80FFFF,POINTDOT;
高:95,COLOR0BFFFF,POINTDOT;
DRAWICON(CROSS(PDI,MDI),MDI,1);

DRAWICON(CROSS(1.5,MDI),MDI,15);
DRAWICON(CROSS(MDI,PDI),PDI,2);
DRAWICON(CROSS(ADX,95),95,11);
T1:=CROSS("DMI.PDI"(3,2),"DMI.MDI"(3,2)) AND CROSS("DMI.ADX"(3,2),"DMI.ADXR"(3,2))
AND
CROSS("DMI.PDI"(5,3),"DMI.MDI"(5,3)) AND CROSS("DMI.ADX"(5,3),"DMI.ADXR"(5,3));
STICKLINE(T1,0,80,1,1),COLOR0000FF;


解答如下:
p:=14;m:=6;
TR1 := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),P);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:= SUM(IF(HD>0 AND HD>LD,HD,0),P);
DMM:= SUM(IF(LD>0 AND LD>HD,LD,0),P);
PDI: DMP*100/TR1,COLORFFFFFF,LINETHICK2;
MDI: DMM*100/TR1,COLOR00FFFF,LINETHICK2;
ADX: MA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:(ADX+REF(ADX,M))/2;

底:1.5,COLOR0BFFFF,POINTDOT,COLOR00FF00;
好:50,COLOR80FFFF,POINTDOT;
高:95,COLOR0BFFFF,POINTDOT;
DRAWICON(CROSS(PDI,MDI),MDI,1);

DRAWICON(CROSS(1.5,MDI),MDI,15);
DRAWICON(CROSS(MDI,PDI),PDI,2);
DRAWICON(CROSS(ADX,95),95,11);
T1:=CROSS("DMI.PDI"(3,2),"DMI.MDI"(3,2)) AND CROSS("DMI.ADX"(3,2),"DMI.ADXR"(3,2))
AND
CROSS("DMI.PDI"(5,3),"DMI.MDI"(5,3)) AND CROSS("DMI.ADX"(5,3),"DMI.ADXR"(5,3));
STICKLINE(T1,0,80,1,1),COLOR0000FF
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址