• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

(MACD)公式改写成飞狐的

常见公式 第一股票指标公式网 1个月前 (11-04) 8次浏览 已收录 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

DIFF :(EMA(CLOSE,12)-EMA(CLOSE,26))*100/EMA(CLOSE,26),COLORWHITE,LINETHICK3;
DEA : EMA(DIFF,9),COLORRED,LINETHICK1;
DIF:IF(DIFF<REF(DIFF,1),DIFF,DRAWNULL),COLORGREEN,LINETHICK3;
ADEA:IF(DEA<REF(DEA,1),DEA,DRAWNULL),COLORGREEN,LINETHICK2;
MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK3;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0,0),COLORRED;
STICKLINE(MACD<REF(MACD,1)AND MACD<0,0,MACD,0,0)COLORFFFF00;
STICKLINE(MACD>REF(MACD,1)AND MACD,0,MACD,0,0),COLORFFFF00;
STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,0,0),COLORRED;

向上:=IF(DIF>=REF(DIF,1),DIF,DRAWNULL),LINETHICK2,COLORRED;
向下:=IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLORGREEN,LINETHICK2;
DRAWICON(CROSS(DIFF,DEA) AND DIFF>REF(DIFF,1) AND DEA<0,DEA,1);
DRAWICON(CROSS(DEA,DIF) AND DIF<REF(DIF,1) AND DEA>0,DEA,2);
 

 
解答如下:
DIFF :(EMA(CLOSE,12)-EMA(CLOSE,26))*100/EMA(CLOSE,26),COLORWHITE,LINETHICK3;
DEA : EMA(DIFF,9),COLORRED,LINETHICK1;
DIF:PARTLINE(DIFF<REF(DIFF,1),DIFF),COLORGREEN,LINETHICK3;
ADEA:PARTLINE(DEA<REF(DEA,1),DEA),COLORGREEN,LINETHICK2;
MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK3;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0,0),COLORRED;
STICKLINE(MACD<REF(MACD,1)AND MACD<0,0,MACD,0,0)COLORFFFF00;
STICKLINE(MACD>REF(MACD,1)AND MACD,0,MACD,0,0),COLORFFFF00;
STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,0,0),COLORRED;
DRAWICON(CROSS(DIFF,DEA) AND DIFF>REF(DIFF,1) AND DEA<0,DEA,1);
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址