• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

自动计算相邻两段的下跌幅度之比

常见公式 第一股票指标公式网 3个月前 (11-04) 7次浏览 已收录 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

代码:

INPUT:空间周期(226,0,9999999),底顶定位(9,0,100);
测量时间:=DATACOUNT-SYSPARAM(1)+1,LINETHICK0;
DRAWTEXTEX(DATACOUNT<>SYSPARAM(1),1,10,160,’测量时间:’+ NUMTOSTR(测量时间,0)),Coloryellow;

AA:=ZIG(4,底顶定位);
PARTLINE(AA ,AA),,LINEdot,color888888;
tj:=AA>REF(AA,1) and AA>REFX(AA,1);
tj1:=AA<REF(AA,1) and AA<REFX(AA,1);
高点值:=PEAK(4,底顶定位,1);
低点值:=TROUGH(4,底顶定位,1);
MM0:=(高点值-低点值);
MM1:=(高点值-低点值);
xzz:=BARSLAST(datacount-BARPOS=空间周期);
DRAWNUMBER(TJ AND xzz>=0,高点值*1.003,MM0,2),ALIGN1,pxup16,coloryellow;
DRAWNUMBER(TJ1 AND xzz>=0,低点值*0.997,MM1,2),ALIGN1,pxdn8,color00ffcc;

1、请老师帮忙完善一下程序代码,实现自动计算;

 

2、要是能直接做个选股公式,满足:图上两段下跌幅度之比在0.618——0.667,更好。


解答如下:
相邻两段的下跌必须后底比前底低,前底也是新低
其他条件你自己改
INPUT:空间周期(226,0,9999999),底顶定位(9,0,100);
测量时间:=DATACOUNT-SYSPARAM(1)+1,LINETHICK0;
DRAWTEXTEX(DATACOUNT<>SYSPARAM(1),1,10,160,’测量时间:’+ NUMTOSTR(测量时间,0)),Coloryellow;

AA:=ZIG(4,底顶定位);
PARTLINE(AA ,AA),,LINEdot,color888888;
tj:=AA>REF(AA,1) and AA>REFX(AA,1);
tj1:=AA<REF(AA,1) and AA<REFX(AA,1);
高点值:=PEAK(4,底顶定位,1);
低点值:=TROUGH(4,底顶定位,1);
MM0:=(高点值-低点值);
MM1:=(高点值-低点值);
FD:MM0/MM1,linethick0;
xzz:=BARSLAST(datacount-BARPOS=空间周期);
DRAWNUMBER(TJ AND xzz>=0,高点值*1.003,MM0,2),ALIGN1,pxup16,coloryellow;
DRAWNUMBER(TJ1 AND xzz>=0,低点值*0.997,MM1,2),ALIGN1,pxdn8,color00ffcc;
D0:=BARSLAST(低点值<>REF(低点值,1));
D1:=REF(低点值-REF(低点值,1),D0);
D2:=REF(D1,D0+1);
D3:=D0=0 AND D2<0 AND D1<0;{}
D4:=REF(MM0,D0);
下跌幅度比:D3*D4/REF(D4,1),LINETHICK0;

 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址