• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

RSI突破公式改为大智慧

常见公式 第一股票指标公式网 2个月前 (11-04) 11次浏览 已收录 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

能否将这个RSI突破公式(tdx)改为大智慧版?
LC:=REF(CLOSE,1);
RSI:SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
压力:=HHV(MA(RSI,3),10),COLORRED;
支撑:=LLV(MA(RSI,3),10),COLORYELLOW;

DRAWLINE(RSI=HHV(RSI,60),HHV(RSI,3),RSI=HHV(RSI,30) AND RSI<HHV(RSI,45),HHV(RSI,3),1),COLORYELLOW;
DRAWLINE(RSI>=HHV(RSI,30),RSI,RSI<=LLV(RSI,10),HHV(RSI,6),1),COLORFFCCCC;
AB:DRAWLINE(RSI>=HHV(RSI,10),RSI,RSI<=LLV(RSI,3),HHV(RSI,3),1),COLORYELLOW;
DRAWLINE(RSI<=LLV(RSI,120),RSI,HHV(RSI,6)<=HHV(RSI,10),LLV(RSI,6),1),COLORBLUE;
VA11:=RSI>=HHV(RSI,20);
CRSI:="RSI.RSI3#WEEK",COLOR77EE00;
HRSI:=HHV("RSI.RSI1#WEEK",2);
金叉RSI:=STICKLINE(CROSS("RSI.RSI2#WEEK","RSI.RSI3#WEEK"),88,12,0.6,0);
VARA:=REF(CLOSE,1);
VARE:=SMA(MAX(CLOSE-VARA,0),6,1)/SMA(ABS(CLOSE-VARA),6,1)*100;
ARSI下:=STICKLINE(HRSI<=CRSI,HRSI,CRSI,0.1,1),COLOR00CC00,LINETHICK1;
VAR1:=(CLOSE*2+HIGH+LOW)/4;
SK:=EMA(VAR1,13)-EMA(VAR1,73);
SD:=EMA(SK,2);
XG:=((CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 )
OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)) OR 金叉RSI);
STICKLINE(XG,88,12,0.6,0),COLOR0000FF;
DRAWTEXT(XG,38,’突破’),COLOR00FFBB;

 
解答如下:
LC:=REF(CLOSE,1);
RSI:SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
压力:=HHV(MA(RSI,3),10);
支撑:=LLV(MA(RSI,3),10);

DRAWLINE(RSI=HHV(RSI,60),HHV(RSI,3),RSI=HHV(RSI,30) AND RSI<HHV(RSI,45),HHV(RSI,3),1),COLORYELLOW;
DRAWLINE(RSI>=HHV(RSI,30),RSI,RSI<=LLV(RSI,10),HHV(RSI,6),1),COLORRED;
AB:DRAWLINE(RSI>=HHV(RSI,10),RSI,RSI<=LLV(RSI,3),HHV(RSI,3),1),COLORYELLOW;
DRAWLINE(RSI<=LLV(RSI,120),RSI,HHV(RSI,6)<=HHV(RSI,10),LLV(RSI,6),1),COLORBLUE;
VA11:=RSI>=HHV(RSI,20);
CRSI:="RSI.RSI3#WEEK";
HRSI:=HHV("RSI.RSI1#WEEK",2);
金叉RSI:=STICKLINE(CROSS("RSI.RSI2#WEEK","RSI.RSI3#WEEK"),88,12,0.6,0);
VARA:=REF(CLOSE,1);
VARE:=SMA(MAX(CLOSE-VARA,0),6,1)/SMA(ABS(CLOSE-VARA),6,1)*100;
ARSI下:=STICKLINE(HRSI<=CRSI,HRSI,CRSI,0.1,1);
VAR1:=(CLOSE*2+HIGH+LOW)/4;
SK:=EMA(VAR1,13)-EMA(VAR1,73);
SD:=EMA(SK,2);
XG:=((CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 )
OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)) OR 金叉RSI);
STICKLINE(XG,88,12,0.6,0),COLOR0000FF;
DRAWTEXT(XG,38,’突破’),COLOR00FFBB;
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址