• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

自己拼了个主图但不知那里出错了显示的买入提示不对

常见公式 第一股票指标公式网 3周前 (11-05) 6次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

请老师帮忙看看自己拼了个主图但不知那里出错了显示的买入提示不对,请老师参照钻石底再做个卖出的提示信号谢谢 如果能优化一下就更好了 。

参数:n 5 300 26 p 0.1 10 2 p1 0 300 75 p2 0 300 120 p3 0 300 250

MID : MA(CLOSE,N)COLORRED,LINETHICK2;
UPPER: MID + P*STD(CLOSE,N),COLORGREEN,POINTDOT;
LOWER: MID – P*STD(CLOSE,N),COLORGREEN,POINTDOT;

MA1:MA(CLOSE,P1),COLORMAGENTA,CIRCLEDOT;
MA2:MA(CLOSE,P2),COLORBLUE;
MA3:MA(CLOSE,P3)COLORRED;

趋势:="KDJ.J"(27,5,3);
不赚都难:=趋势<=15;
MA75:=MA(C,75);
回踩不破:=REF(C,1)>REF(MA75,1) AND L>=MA75 AND C>=MA75;

DIF:=EMA(CLOSE,6)-EMA(CLOSE,8);
DEA:=EMA(DIF,3);
MACD:=(DIF-DEA)*2;
绿柱缩:=REF(MACD,1)<REF(MACD,2);

红箭头:=回踩不破 AND 不赚都难 AND 绿柱缩 ;
DRAWICON(红箭头,L/1.005,111);

DIF1:=EMA(CLOSE,6)-EMA(CLOSE,8);
DEA1:=EMA(DIF,3);
MACD1:=(DIF-DEA)*2;
绿柱一天缩短1:=MACD>REF(MACD,1) AND REF(MACD,1)<REF(REF(MACD,1),1) AND MACD<0;

 

MA75A:=MA(C,75);
MA120A:=MA(C,120);
AA1:=CROSS(MA75A,MA120A)AND MA75A>REF(MA75A,1);
回踩不破1:=REF(C,1)>REF(MA75A,1) AND L>=MA75A AND C>=MA75A AND COUNT(CROSS(MA(C,75),MA(C,120)),39)>=1;

趋势1:="KDJ.J"(27,5,3);
不赚都难1:=趋势<=15;
红箭头1:= 不赚都难1 AND 绿柱一天缩短1 AND 回踩不破1 ;
DRAWTEXT(红箭头1,LOW,’▲75上穿120′),COLORRED;

趋势2:="KDJ.J"(27,5,3);
不赚都难2:=趋势2<=15;
DIFF2:=EMA(CLOSE,12) – EMA(CLOSE,26);
DEA2:=EMA(DIFF2,9);
MACD2:=2*(DIFF2-DEA2);

DIF3:=EMA(CLOSE,6)-EMA(CLOSE,8);
DEA3:=EMA(DIF3,3);
MACD3:=(DIF3-DEA3)*2;
绿柱一天缩短3:=MACD>REF(MACD,1) AND REF(MACD,1)<REF(REF(MACD,1),1) AND MACD<0;

线背离:=L=LLV(L,30)AND DEA2>LLV(DEA2,30)*1.2,COLORYELLOW;
DRAWTEXT(线背离,LOW,’钻石底’ AND 不赚都难2 AND 绿柱一天缩短3),COLORYELLOW;

 

VAR1MZ:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
VAR2MZ:=((REF(VAR1MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR3MZ:=((REF(VAR2MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR4MZ:=((REF(VAR3MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR5MZ:=((REF(VAR4MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR6MZ:=((REF(VAR5MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR7MZ:=((REF(VAR6MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR8MZ:=((REF(VAR7MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR9MZ:=((REF(VAR8MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARAMZ:=((REF(VAR9MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARBMZ:=((REF(VARAMZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARCMZ:=((REF(VARBMZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
{红K}
STICKLINE((((((((((((VAR1MZ OR VAR2MZ) OR VAR3MZ) OR VAR4MZ) OR VAR5MZ) OR VAR6MZ) OR VAR7MZ) OR VAR8MZ) OR VAR9MZ) OR VARAMZ) OR VARBMZ) OR VARCMZ),C,O,3,0),COLOR000099;
STICKLINE((((((((((((VAR1MZ OR VAR2MZ) OR VAR3MZ) OR VAR4MZ) OR VAR5MZ) OR VAR6MZ) OR VAR7MZ) OR VAR8MZ) OR VAR9MZ) OR VARAMZ) OR VARBMZ) OR VARCMZ),C,O,2,0),COLOR0000BB;
STICKLINE((((((((((((VAR1MZ OR VAR2MZ) OR VAR3MZ) OR VAR4MZ) OR VAR5MZ) OR VAR6MZ) OR VAR7MZ) OR VAR8MZ) OR VAR9MZ) OR VARAMZ) OR VARBMZ) OR VARCMZ),C,O,1,0),COLOR0000DD;
VARDMZ:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
VAREMZ:=((REF(VARDMZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARFMZ:=((REF(VAREMZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR10MZ:=((REF(VARFMZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR11MZ:=((REF(VAR10MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR12MZ:=((REF(VAR11MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR13MZ:=((REF(VAR12MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR14MZ:=((REF(VAR13MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR15MZ:=((REF(VAR14MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR16MZ:=((REF(VAR15MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR17MZ:=((REF(VAR16MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR18MZ:=((REF(VAR17MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
{绿K}
STICKLINE((((((((((((VARDMZ OR VAREMZ) OR VARFMZ) OR VAR10MZ) OR VAR11MZ) OR VAR12MZ) OR VAR13MZ) OR VAR14MZ) OR VAR15MZ) OR VAR16MZ) OR VAR17MZ) OR VAR18MZ),C,O,3 ,0 ),COLOR00BB00;
STICKLINE((((((((((((VARDMZ OR VAREMZ) OR VARFMZ) OR VAR10MZ) OR VAR11MZ) OR VAR12MZ) OR VAR13MZ) OR VAR14MZ) OR VAR15MZ) OR VAR16MZ) OR VAR17MZ) OR VAR18MZ),C,O,2 ,0 ),COLOR00DD00;
STICKLINE((((((((((((VARDMZ OR VAREMZ) OR VARFMZ) OR VAR10MZ) OR VAR11MZ) OR VAR12MZ) OR VAR13MZ) OR VAR14MZ) OR VAR15MZ) OR VAR16MZ) OR VAR17MZ) OR VAR18MZ),C,O,1,0 ),COLOR00FF00;
VAR19MZ:=(REF((((((((((((VARDMZ OR VAREMZ) OR VARFMZ) OR VAR10MZ) OR VAR11MZ) OR VAR12MZ) OR VAR13MZ) OR VAR14MZ) OR VAR15MZ) OR VAR16MZ) OR VAR17MZ) OR VAR18MZ),1) AND VAR1MZ);
VAR1AMZ:=(REF((((((((((((VAR1MZ OR VAR2MZ) OR VAR3MZ) OR VAR4MZ) OR VAR5MZ) OR VAR6MZ) OR VAR7MZ) OR VAR8MZ) OR VAR9MZ) OR VARAMZ) OR VARBMZ) OR VARCMZ),1) AND VARDMZ);
{粉红}
CAX:=MAX(REF(CLOSE,2),REF(CLOSE,1));
STICKLINE(VAR19MZ,CAX,O,3 ,0 ),COLORBB11BB;
STICKLINE(VAR19MZ,CAX,O,2 ,0 ),COLORDD44DD;
STICKLINE(VAR19MZ,CAX,O,1 ,0 ),COLORFF66FF;
{黄色}
CIN:=MIN(REF(CLOSE,2),REF(CLOSE,1));
STICKLINE(VAR1AMZ,CIN,O,3,0),COLOR00AAFF;
STICKLINE(VAR1AMZ,CIN,O,2,0),COLOR00CCFF;
STICKLINE(VAR1AMZ,CIN,O,1,0),COLOR00EEFF;

 
解答如下:
N := 26; P :=2; P1:= 75; P2:= 120; P3 :=250;
MID : MA(CLOSE,N)COLORRED,LINETHICK2;
UPPER: MID + P*STD(CLOSE,N),COLORGREEN,POINTDOT;
LOWER: MID – P*STD(CLOSE,N),COLORGREEN,POINTDOT;
MA1:MA(CLOSE,P1),COLORMAGENTA,CIRCLEDOT;
MA2:MA(CLOSE,P2),COLORBLUE;
MA3:MA(CLOSE,P3)COLORRED;

趋势:="KDJ.J"(27,5,3);
不赚都难:=趋势<=15;
MA75:=MA(C,75);
回踩不破:=REF(C,1)>REF(MA75,1) AND L>=MA75 AND C>=MA75;

DIF:=EMA(CLOSE,6)-EMA(CLOSE,8);
DEA:=EMA(DIF,3);
MACD:=(DIF-DEA)*2;
绿柱缩:=REF(MACD,1)<REF(MACD,2);

红箭头:=回踩不破 AND 不赚都难 AND 绿柱缩 ;
DRAWICON(红箭头,L/1.005,1);

DIF1:=EMA(CLOSE,6)-EMA(CLOSE,8);
DEA1:=EMA(DIF,3);
MACD1:=(DIF-DEA)*2;
绿柱一天缩短1:=MACD>REF(MACD,1) AND REF(MACD,1)<REF(REF(MACD,1),1) AND MACD<0;

 

MA75A:=MA(C,75);
MA120A:=MA(C,120);
AA1:=CROSS(MA75A,MA120A)AND MA75A>REF(MA75A,1);
回踩不破1:=REF(C,1)>REF(MA75A,1) AND L>=MA75A AND C>=MA75A AND COUNT(CROSS(MA(C,75),MA(C,120)),39)>=1;

趋势1:="KDJ.J"(27,5,3);
不赚都难1:=趋势<=15;
红箭头1:= 不赚都难1 AND 绿柱一天缩短1 AND 回踩不破1 ;
DRAWTEXT(红箭头1,LOW,’▲75上穿120′),COLORRED;

趋势2:="KDJ.J"(27,5,3);
不赚都难2:=趋势2<=15;
DIFF2:=EMA(CLOSE,12) – EMA(CLOSE,26);
DEA2:=EMA(DIFF2,9);
MACD2:=2*(DIFF2-DEA2);

DIF3:=EMA(CLOSE,6)-EMA(CLOSE,8);
DEA3:=EMA(DIF3,3);
MACD3:=(DIF3-DEA3)*2;
绿柱一天缩短3:=MACD>REF(MACD,1) AND REF(MACD,1)<REF(REF(MACD,1),1) AND MACD<0;

线背离:=L=LLV(L,30)AND DEA2>LLV(DEA2,30)*1.2,COLORYELLOW;
DRAWTEXT(线背离 AND 不赚都难2 AND 绿柱一天缩短3,LOW,’钻石底’ ),COLORYELLOW;

 

VAR1MZ:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
VAR2MZ:=((REF(VAR1MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR3MZ:=((REF(VAR2MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR4MZ:=((REF(VAR3MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR5MZ:=((REF(VAR4MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR6MZ:=((REF(VAR5MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR7MZ:=((REF(VAR6MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR8MZ:=((REF(VAR7MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR9MZ:=((REF(VAR8MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARAMZ:=((REF(VAR9MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARBMZ:=((REF(VARAMZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARCMZ:=((REF(VARBMZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
{红K}
STICKLINE((((((((((((VAR1MZ OR VAR2MZ) OR VAR3MZ) OR VAR4MZ) OR VAR5MZ) OR VAR6MZ) OR VAR7MZ) OR VAR8MZ) OR VAR9MZ) OR VARAMZ) OR VARBMZ) OR VARCMZ),C,O,3,0),COLOR000099;
STICKLINE((((((((((((VAR1MZ OR VAR2MZ) OR VAR3MZ) OR VAR4MZ) OR VAR5MZ) OR VAR6MZ) OR VAR7MZ) OR VAR8MZ) OR VAR9MZ) OR VARAMZ) OR VARBMZ) OR VARCMZ),C,O,2,0),COLOR0000BB;
STICKLINE((((((((((((VAR1MZ OR VAR2MZ) OR VAR3MZ) OR VAR4MZ) OR VAR5MZ) OR VAR6MZ) OR VAR7MZ) OR VAR8MZ) OR VAR9MZ) OR VARAMZ) OR VARBMZ) OR VARCMZ),C,O,1,0),COLOR0000DD;
VARDMZ:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
VAREMZ:=((REF(VARDMZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARFMZ:=((REF(VAREMZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR10MZ:=((REF(VARFMZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR11MZ:=((REF(VAR10MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR12MZ:=((REF(VAR11MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR13MZ:=((REF(VAR12MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR14MZ:=((REF(VAR13MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR15MZ:=((REF(VAR14MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR16MZ:=((REF(VAR15MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR17MZ:=((REF(VAR16MZ,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR18MZ:=((REF(VAR17MZ,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
{绿K}
STICKLINE((((((((((((VARDMZ OR VAREMZ) OR VARFMZ) OR VAR10MZ) OR VAR11MZ) OR VAR12MZ) OR VAR13MZ) OR VAR14MZ) OR VAR15MZ) OR VAR16MZ) OR VAR17MZ) OR VAR18MZ),C,O,3 ,0 ),COLOR00BB00;
STICKLINE((((((((((((VARDMZ OR VAREMZ) OR VARFMZ) OR VAR10MZ) OR VAR11MZ) OR VAR12MZ) OR VAR13MZ) OR VAR14MZ) OR VAR15MZ) OR VAR16MZ) OR VAR17MZ) OR VAR18MZ),C,O,2 ,0 ),COLOR00DD00;
STICKLINE((((((((((((VARDMZ OR VAREMZ) OR VARFMZ) OR VAR10MZ) OR VAR11MZ) OR VAR12MZ) OR VAR13MZ) OR VAR14MZ) OR VAR15MZ) OR VAR16MZ) OR VAR17MZ) OR VAR18MZ),C,O,1,0 ),COLOR00FF00;
VAR19MZ:=(REF((((((((((((VARDMZ OR VAREMZ) OR VARFMZ) OR VAR10MZ) OR VAR11MZ) OR VAR12MZ) OR VAR13MZ) OR VAR14MZ) OR VAR15MZ) OR VAR16MZ) OR VAR17MZ) OR VAR18MZ),1) AND VAR1MZ);
VAR1AMZ:=(REF((((((((((((VAR1MZ OR VAR2MZ) OR VAR3MZ) OR VAR4MZ) OR VAR5MZ) OR VAR6MZ) OR VAR7MZ) OR VAR8MZ) OR VAR9MZ) OR VARAMZ) OR VARBMZ) OR VARCMZ),1) AND VARDMZ);
{粉红}
CAX:=MAX(REF(CLOSE,2),REF(CLOSE,1));
STICKLINE(VAR19MZ,CAX,O,3 ,0 ),COLORBB11BB;
STICKLINE(VAR19MZ,CAX,O,2 ,0 ),COLORDD44DD;
STICKLINE(VAR19MZ,CAX,O,1 ,0 ),COLORFF66FF;
{黄色}
CIN:=MIN(REF(CLOSE,2),REF(CLOSE,1));
STICKLINE(VAR1AMZ,CIN,O,3,0),COLOR00AAFF;
STICKLINE(VAR1AMZ,CIN,O,2,0),COLOR00CCFF;
STICKLINE(VAR1AMZ,CIN,O,1,0),COLOR00EEFF;
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址