• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

把不亏操盘主图中的“起”做个选股公式

常见公式 第一股票指标公式网 3周前 (11-05) 6次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

请老师帮我把不亏操盘主图公式中的“起”做个选股公式,谢谢!
源码:HHJSJDA:=(3*CLOSE+OPEN+LOW+HIGH)/6;
E13:(20*HHJsjda+19*REF(HHJsjda,1)+18*REF(HHJsjda,2)+17*REF(HHJsjda,3)+16*REF(HHJsjda,4)+15*REF(HHJsjda,5)+14*REF(HHJsjda,6)
+13*REF(HHJsjda,7)+12*REF(HHJsjda,8)+11*REF(HHJsjda,9)+10*REF(HHJsjda,10)+9*REF(HHJsjda,11)+8*REF(HHJsjda,12)
+7*REF(HHJsjda,13)+6*REF(HHJsjda,14)+5*REF(HHJsjda,15)+4*REF(HHJsjda,16)+3*REF(HHJsjda,17)+2*REF(HHJsjda,18)+
REF(HHJsjda,20))/210,colorred;
马线:MA(E13,5),colorgreen;
水平面:MA(CLOSE,60),COLORYELLOW,CROSSDOT;
Var1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
A1:=(EMA(Var1,3)+EMA(Var1,6)+EMA(Var1,12)+EMA(Var1,24))/4;
A2: EMA(A1,2);
A3: EMA(A2,2);
A4: EMA(A3,2);
A5: EMA(A4,2);
A6: EMA(A5,2);
A7: EMA(A6,2);
DRAWTEXTABS(10,10,STKLABEL+’ ‘+STKNAME+’ ‘+BKNAME),COLOR00FFFF;
YC:=REF(CLOSE,1);
止损价位:(YC*1.0035*97+0.2)/99.65,COLORRED,LINETHICK0;
DRAWTEXTABS(CLOSE,25,’★ ======================’),COLORRED;
DRAWTEXTABS(CLOSE,41,’操 ‘),COLORRED;
DRAWTEXTABS(CLOSE,57,’盘 ‘),COLORRED;
DRAWTEXTABS(CLOSE,73,’铁’),COLORRED;
DRAWTEXTABS(CLOSE,89,’律’),COLORRED;
DRAWTEXTABS(CLOSE,105,’★ ======================’),COLORRED;
DRAWTEXTABS(CLOSE,41,’ 买入条件 E13 CCI’),colorYellow;
DRAWTEXTABS(CLOSE,57,’ 买入时间 2:30以后’ ),colorYellow;
DRAWTEXTABS(CLOSE,73,’ 止损价位 ‘+NUMTOSTR(止损价位)+’元’),colorYellow;
DRAWTEXTABS(CLOSE,89,’ 线上:工作 线下:休息’),color00FFFF;
E:=(HIGH+LOW+OPEN+2*CLOSE)/5;
明日阻力:=2*E-LOW;
明日支撑:=2*E-HIGH;
明日突破:=E+(HIGH-LOW);
明日反转:=E-(HIGH-LOW);
今日阻力:=REF(明日阻力 , 1);
今日支撑:=REF(明日支撑 , 1);
DRAWTEXTABS(200,25,’今日阻力=:’+NUMTOSTR(今日阻力)),ColorFFFF00;
DRAWTEXTABS(200,41,’今日支撑=:’+NUMTOSTR(今日支撑)),Colorred;
DRAWTEXTABS(200,57,’明日突破=:’+NUMTOSTR(明日突破)),ColorFF00FF;
DRAWTEXTABS(200,73,’明日阻力=:’+NUMTOSTR(明日阻力)),ColorFFFF00;
DRAWTEXTABS(200,89,’明日支撑=:’+NUMTOSTR(明日支撑)),COLORRED;
DRAWTEXTABS(200,105,’明日反转=:’+NUMTOSTR(明日反转)),COLORYellow;
A:=HHV(HIGH,13)=HIGH AND HIGH>REF(HIGH,1);A1:=FILTER(A,12);
B:=LLV(LOW,13)=LOW AND LOW<REF(LOW,1);B1:=FILTER(B,12);
TS1:=BARSLAST(A1);
箱顶:REF(HIGH,TS1) ,COLORFF00FF, LINETHICK0;
STICKLINE(1,箱顶,箱顶,7,0),COLORFF00FF;
TS2:=BARSLAST(B1);
箱底:REF(LOW,TS2) ,COLORFFbb80, LINETHICK0;
STICKLINE(1,箱底,箱底,7,0),COLORFFbb80;
箱高:100*(箱顶-箱底)/箱底,LINETHICK0;
均价:=(3*C+H+L+O)/6;
VAR1:=(8*均价+7*REF(均价,1)+6*REF(均价,2)+5*REF(均价,3)+
4*REF(均价,4)+3*REF(均价,5)+2*REF(均价,6)+REF(均价,8))/36;
VAR2:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
SZ1:=REF(VAR1,1)=REF(VAR2,1) AND VAR1>VAR2 AND CLOSE>VAR1;
SZ2:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>REF(VAR2,1)
AND H/VAR1<1.1 AND L>VAR2 AND CLOSE>VAR1;
SZ3:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>=REF(VAR2,1) AND H/VAR1>1.1;
SZ4:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>REF(VAR2,1)
AND CLOSE>VAR2 AND CLOSE<VAR1;
SZ5:=(VAR1>VAR2 AND VAR2>REF(VAR2,1) AND VAR1<>REF(VAR1,1)
AND CLOSE<VAR2) OR (VAR1>VAR2 AND VAR1<REF(VAR1,1)
AND VAR2<REF(VAR2,1) AND CLOSE<VAR2);;
SZ6:=REF(VAR1,1)>REF(VAR2,1) AND VAR1=VAR2 AND CLOSE<VAR2;
DRAWTEXTABS(5,5,'[/url]’),linethick1,COLOR00EEff;
XD1:=VAR1=VAR2 AND CLOSE<VAR2 OR (VAR1<REF(VAR1,1) AND VAR2<REF(VAR2,1)
AND REF(VAR1,1)=REF(VAR2,1) AND CLOSE<VAR2);
XD2:=VAR1=VAR2 AND CLOSE>VAR1;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和度:=IF(SAT>1,1,SAT)*100;
IF BARSTATUS=2 AND SZ1 THEN BEGIN
DRAWTEXTABS(350,25,’调整结束短线介入’),COLORRED;
END
ELSE
IF BARSTATUS=2 AND SZ2 THEN BEGIN
DRAWTEXTABS(350,25,’上升通道走势良好’),COLORRED;
END
ELSE
IF BARSTATUS=2 AND SZ3 THEN BEGIN
DRAWTEXTABS(350,25,’股价偏离注意调整’),COLORRED;
END
ELSE
IF BARSTATUS=2 AND SZ4 THEN BEGIN
DRAWTEXTABS(350,25,’上升通道调整洗盘’),COLORGREEN;
END
ELSE
IF BARSTATUS=2 AND SZ5 THEN BEGIN
DRAWTEXTABS(350,25,’转向特征注意离场’),COLORGREEN;
END
ELSE
IF BARSTATUS=2 AND SZ6 THEN BEGIN
DRAWTEXTABS(350,25,’通道改变坚决离场’),COLORGREEN;
END
ELSE
IF BARSTATUS=2 AND XD1 THEN BEGIN
DRAWTEXTABS(350,25,’下跌通道只宜观望’),COLORGREEN;
END
ELSE
IF BARSTATUS=2 AND XD2 THEN BEGIN
DRAWTEXTABS(350,25,’短期底部准备进入’),COLORYELLOW;
END;
{单阳不破}
阳涨幅:=4;
阳倍量:=2;
单阳:=C>O*(1+阳涨幅/100) AND VOL>REF(VOL,1)*阳倍量;
DRAWTEXT(单阳,L*0.98,’起’),COLOR00FFFF;
高不破价:=REF(C,BARSLAST(单阳));
中不破价:=REF((C+L)/2,BARSLAST(单阳));
低不破价:=REF(L,BARSLAST(单阳));
单阳不破:=BARSLAST(单阳)<11 AND (LLV(L,BARSLAST(单阳))>低不破价 OR LLV(L,BARSLAST(单阳))=低不破价);
STICKLINE(单阳不破,低不破价-低不破价*0.003,低不破价,11,0),COLORRED;
DRAWTEXT(BARSLAST(单阳)=1 AND 单阳不破,低不破价*0.98,’1′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=2 AND 单阳不破,低不破价*0.98,’2′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=3 AND 单阳不破,低不破价*0.98,’3′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=4 AND 单阳不破,低不破价*0.98,’4′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=5 AND 单阳不破,低不破价*0.98,’5′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=6 AND 单阳不破,低不破价*0.98,’6′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=7 AND 单阳不破,低不破价*0.98,’7′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=8 AND 单阳不破,低不破价*0.98,’8′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=9 AND 单阳不破,低不破价*0.98,’9′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=10 AND 单阳不破,低不破价*0.98,’10’),COLORGREEN;
两天:=LLV(L,BARSLAST(单阳))>低不破价 OR LLV(L,BARSLAST(单阳))=低不破价;
一般:=LLV(L,BARSLAST(单阳)-2)>低不破价 OR LLV(L,BARSLAST(单阳)-2)=低不破价;
较强:=LLV(L,BARSLAST(单阳)-2)>中不破价 OR LLV(L,BARSLAST(单阳)-2)=中不破价;
最强:=LLV(L,BARSLAST(单阳)-3)>高不破价 OR LLV(L,BARSLAST(单阳)-2)=高不破价;
天数:BARSLAST(单阳),linethick0;
ma20:=ma(c,20);
ma60:=ma(c,60);
ma30:=ma(c,30);
BIAS:=(C-MA20)/MA20*100;
SHOPEN:=OPEN;
SHHIGH:=HIGH;
SHLOW:=LOW;
SHCLOSE:=CLOSE;
SHAMOUNT:=AMOUNT;
SHVOL:=VOL;
J12:=(HIGH – ((HIGH – LOW) / 3));
J23:=(LOW + ((HIGH – LOW) / 3));
t1:=(((IF((CLOSE = OPEN),1,0) + IF((CLOSE >= J12),1,0)) + IF((CLOSE <= J23),1,0)) > 1);
t2:=((((CLOSE > J23) AND (CLOSE < J12)) AND (OPEN > J23)) AND (OPEN < J12));
t3:=((CLOSE >= J12) AND (OPEN <= J23));
t4:=(((OPEN <= J12) AND (OPEN >= J23)) AND (CLOSE > J12));
t5:=(((OPEN <= J23) AND (CLOSE <= J12)) AND (CLOSE >= J23));
t6:=((CLOSE <= J23) AND (OPEN >= J12));
t7:=(((OPEN <= J12) AND (OPEN >= J23)) AND (CLOSE < J23));
t8:=(((OPEN >= J12) AND (CLOSE <= J12)) AND (CLOSE >= J23));
t9:=(((SHAMOUNT / SHVOL) / 100) > REF(HIGH,1));
t10:=(((SHAMOUNT / SHVOL) / 100) < REF(LOW,1));
if DISPSTATUS=2 then begin;
var1000:=’.’;
if t1>0 then var1000:=var1000+’☆极端行情,在未来的几日内有85%的机会变更方向。’;
if t2>0 then var1000:=var1000+’☆中性行情,多空双方都未能取得当日行情主动性的控制权’;
if t3>0 then var1000:=var1000+’☆爬升行情,整个交易期间都有买方主导。’;
if t4>0 then var1000:=var1000+’☆爬升行情,信息较少,但收盘期间是买方主导,其他未知。’;
if t5>0 then var1000:=var1000+’☆爬升行情,买方把收盘价拉升到开盘价之上,卖方却也主导一段行情,但不知道是谁主导最后的行情。’;
if t6>0 then var1000:=var1000+’☆漂流行情,整个交易期间都有卖方主导。’;
if t7>0 then var1000:=var1000+’☆漂流行情,信息最少,但收盘期间是卖方主导,其他未知。’;
if t8>0 then var1000:=var1000+’☆漂流行情,卖方把收盘价压至到开盘价之下,买方却也主导一段行情,但不知道是谁主导最后的行情。’;
if t9>0 then var1000:=var1000+’☆上涨趋势。’;
if t10>0 then var1000:=var1000+’☆下跌趋势。’;
if MA20>=MA60 AND CROSS(MA30,MA60) then var1000:=var1000+’☆形成季托,待股价回落到20天均线或40天均线时介入,20天均价为:’+MA20+’ 。’;
if BIAS>9.5 AND (C-REF(C,1))/REF(C,1)*100<9.8 then var1000:=var1000+’☆短线涨幅过大,有整理股友提问要求。’;
if MA20>=MA60 AND H>=MA20 AND L<=MIN(MA30,MA60) AND C>O AND C>REF(C,1) then var1000:=var1000+’☆芙蓉出水,趋势向好。’;
if BIAS<-18 AND (C-REF(C,1))/REF(C,1)*100>-9.8 then var1000:=var1000+’☆股价严重超跌,有爆发股友提问要求。’;
if BIAS<-7 AND ALL(CLOSE<OPEN,5) then var1000:=var1000+’☆连收五阴,超跌有反弹股友提问要求。’;
if ABS(HIGH-REF(HIGH,1))/HIGH<0.001 then var1000:=var1000+’☆平顶,-该高点有一定阻力。’;
if ABS(LOW-REF(LOW,1))/LOW<0.001 and abs(ref(low,1)-ref(low,2))/ref(low,1)<=0.00 then var1000:=var1000+’☆平底,该低点有一定支撑。’;
if CLOSE=OPEN AND HIGH<>close and low<>close and HIGH/LOW > 1.03 then var1000:=var1000+’☆ 长十字,多空激争 前途未明。’;
if OPEN/CLOSE > 1.05 AND HIGH/LOW < OPEN/CLOSE+0.018 then var1000:=var1000+’☆ 大阴烛,今日空方有绝对优势。’;
if REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98 then var1000:=var1000+’☆双飞乌鸦,多头力竭,行情走软。’;
if (MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667 then var1000:=var1000+’☆长下影,下档支撑强或空方试探进攻。’;
if (HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667 then var1000:=var1000+’☆长上影,上档阻力大或多方试探进攻。’;
if CLOSE=OPEN AND CLOSE=LOW AND CLOSE<>HIGH then var1000:=var1000+’☆垂死十字,在顶部时重要 表强力多头开始疲软。’;
if HIGH=CLOSE AND HIGH<>LOW then var1000:=var1000+’☆光头阳线,今日尾盘多方气盛,行情可能延续到明天。’;
if (HIGH<REF(LOW,1) OR LOW>REF(HIGH,1)) then var1000:=var1000+’☆跳空缺口,当日未补,有与跳空同向进行,上涨欲望强烈,三日内为回补观察期。’;
if LOW=CLOSE AND HIGH<>LOW then var1000:=var1000+’☆赤脚阴线,尾盘空方胜。 注意股价下跌延续至次日。’;
if CLOSE=OPEN AND HIGH<>close and low<>close and high <>close then var1000:=var1000+’☆十字星,警告信号。原趋势停顿或反转,依上下影线长度判后市。’;
if CLOSE/OPEN>1.05 AND HIGH/LOW < CLOSE/OPEN+0.018 then var1000:=var1000+’☆大阳烛,上升行情中意味行情剧烈向上攀升;下跌行情中意味行情剧烈向上反弹。’;
IF REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1)AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2) THEN
var1000:=var1000+’☆早晨十字,如同晨星。 从看空平衡到看涨转强;左右跳空曰弃婴 。’;
IF REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4) THEN var1000:=var1000+’☆上升三部曲,空方卖压被吸纳。 趋势易顺势走涨。’;
IF (ref(high,2) -ref(o,2))/ref(high,2)<=0.0003 AND (c-low)/o<=0.0003 AND ref(c,2)<ref(o,2) AND ref(c,2)>ref(o,1) AND ref(c,1)>o AND ref(c,1)<ref(o,1) AND ref(high,1)-ref(o,1)>0 AND ref(low,1)-ref(c,1)<0 AND high-o>0 AND ref(c,2)-ref(low,2)>0 THEN var1000:=var1000+’☆三胎乌鸦,多头走势被扭转。黑K价愈深量愈大,跳空愈大,反转信号愈强。’;
IF ((REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002) OR (REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002)) THEN
var1000:=var1000+’☆友好反攻,阴(阳)线结合,极线多方跳低(高)后反弹有企稳迹象 。’;
IF close<>open and MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE > MA(CLOSE,5) THEN
var1000:=var1000+’☆射击之星,如伴大量上遇阻力,有短期见顶可能,股价转疲。’;
IF REF(CLOSE,1)-REF(OPEN,1)<0 AND CLOSE-OPEN>0 AND OPEN-REF(CLOSE,1)<0 AND CLOSE<REF(OPEN,1) AND CLOSE>REF(CLOSE,1) AND CLOSE>(REF(CLOSE,1)+REF(OPEN,1))/2 THEN
var1000:=var1000+’☆贯穿线,多头力道的反扑或是空单回补力道。长黑之后开低收在前天1/2之上,为多头反转信号。’;
IF ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND MAX(CLOSE,OPEN) < MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN) > MIN(REF(CLOSE,1),REF(OPEN,1)) THEN
var1000:=var1000+’☆身怀六甲,阴(阳)怀阳(阴),怪异的走势,显示该股行情可能转向。 若量由大转缩,下跌趋势更明确。’;
IF (ref(c,1)-ref(o,1)<0 AND c-o>0 AND c>ref(o,1) AND o<ref(c,1)) THEN
var1000:=var1000+’☆多头阳线吞噬,红包黑。反转趋势需量能配合量。 ‘;
IF ((ref(c,2)-ref(o,2)>0 AND (ABS(ref(c,2)-ref(o,2)))/(ABS(ref(c,3)-ref(o,3)))>2.4 AND ABS(c-o)>3 AND ABS(ref(c,2)-ref(o,2))>(ABS(ref(c,1)-ref(o,1))) AND ref(c,1)-ref(o,1)>0 AND c-o<0 AND ref(o,1) >ref(c,2) AND o<ref(o,1) AND c<ref(c,2) AND c>ref(o,2)) OR (ref(c,2)-ref(o,2)>0 AND (ABS(ref(c,2)-ref(o,2)))/(ABS(ref(c,3)-ref(o,3)))>2.4 AND ABS(c-o)>3 AND (ABS(ref(c,2)-ref(o,2)))>(ABS(ref(c,1)-ref(o,1))) AND ref(c,1)-ref(o,1)<0 AND c-o<0 AND ref(c,1) >ref(c,2) AND c<ref(c,2) AND c>ref(o,2) AND o<ref(c,1))) THEN
var1000:=var1000+’☆夜星,从看多平衡到看空转弱,转空。 ‘;
IF ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND CLOSE=OPEN AND CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1),REF(OPEN,1)) THEN
var1000:=var1000+’☆十字胎,似身怀六甲,转向可能性更大,量缩观望为宜 。’;
IF ref(c,1)<ref(o,1) AND c-o>0 AND c>ref(H,1) AND o<ref(L,1) and ref(O,1)>ref(max(O,C),2) and ref(C,1)>ref(min(O,C),2) and ref(max(O,C),2)>ref(max(O,C),3) THEN
var1000:=var1000+’☆ 双人殉情 ,在上升趋势中最后之空头吞噬,也就是所谓的不见长红不回头。 ‘;
IF (ref(c,1)-ref(o,1)>0 AND c-o<0 AND c<ref(o,1) AND o>ref(c,1)) THEN
var1000:=var1000+’☆阴线吞噬,黑包红,向空反转。 ‘;
IF REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1) THEN var1000:=var1000+’☆曙光,与乌云盖顶相反,行情将演化为V型反转或止跌横盘趋势 。’;
IF (ref(c,1)-ref(o,1)<0 AND c-o>0 AND c<ref(o,1) AND o>ref(c,1)) THEN
var1000:=var1000+’☆多头孕育线,阴育阳。多头反转可能。’;
IF (ref(c,1)-ref(o,1)>0 AND (ABS(ref(c,1)-ref(o,1)))/(ABS(ref(c,2)-ref(o,2)))>2.4 AND c-o<0 AND c>ref(o,1) AND ref(c,1)-o>2) THEN
var1000:=var1000+’☆空头孕育线,阳育阴。看空 。’;
IF (ref(c,1)-ref(o,1)<0 AND c-o<0 AND c>ref(c,1) AND o<ref(o,1) AND o-c <6) THEN
var1000:=var1000+’☆空头孕育线,阴育阴。看空。’;
IF REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE<REF(CLOSE,1) THEN
var1000:=var1000+’☆三只乌鸦,强烈转空趋势。三黑K价越深量越大越易下跌。’;
IF REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,4) THEN
var1000:=var1000+’☆下跌三部曲,多方弱势不堪一击,趋势易顺势走跌。’;
IF REF(CLOSE,4)/REF(OPEN,4)>1.02 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(close,4)<=REF(close,3) AND REF(high,2)<REF(high,3) AND REF(LOW,2)>=REF(open,4) AND REF(high,1)<REF(close,4) AND REF(low,1)>REF(open,4) AND CLOSE/OPEN>1.01 AND open>=REF(open,1) AND CLOSE>=REF(HIGH,3) THEN
var1000:=var1000+’☆连续型态之执垫,比上升三法更具多头意义。’;
IF ref(O,1)/ref(C,1) > 1.05 AND ref(H,1)/ref(L,1) < ref(O,1)/ref(C,1)+0.018 and C>O and O<ref(L,1) and C=ref(L,1) THEN
var1000:=var1000+’☆颈上线,下降趋势。若第二天大量,维持原趋势可能星大增。’;
IF (ref(c,1)-ref(o,1)>0 AND (ABS(ref(c,1)-ref(o,1)))/(ABS(ref(c,2)-ref(o,2)))>2.5 AND c-o<0 AND c>ref(o,1) AND c<(REF(CLOSE,1)+REF(OPEN,1))/2 AND o>ref(c,1)) THEN
var1000:=var1000+’☆乌云罩顶,上涨遇重大阻力。空头聚力。’;
IF (ref(c,1)-ref(o,1)>0 AND c-o<0 AND c<ref(o,1) AND o>ref(c,1)) THEN
var1000:=var1000+’☆最后吞噬,在下降趋势中为一黑一红组合;多头吞噬,在上升趋势中为一红一黑组合,空头吞噬。’;
IF ref(open,1)<>ref(close,1) and REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2) THEN
var1000:=var1000+’☆晨星,多方势盛 变盘信号’;
IF MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE < MA(CLOSE,5) THEN var1000:=var1000+’☆ 倒转槌头 -高位抛压 低位多空争执’;
IF HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE < MA(CLOSE,5) THEN var1000:=var1000+’☆槌头,下影线有多头意义。在下降趋势之后看涨。注意反弹卖压 。’;
IF HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE > MA(CLOSE,5) THEN var1000:=var1000+’☆吊颈线,高档看跌。’;
IF ((REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1)) OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1))) THEN
var1000:=var1000+’☆ 穿头破脚 -若第一根K为阴(阳) 表强劲上涨(下跌)力量。’;
IF ref(open,1)<>ref(close,1) and REF(CLOSE,2)/REF(OPEN,2) > 1.03 AND REF(OPEN,1) > REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2) THEN
var1000:=var1000+’☆黄昏之星,空方势盛。反转信号,跳空成弃婴。’;
IF REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND REF(OPEN,1)>=REF(CLOSE,1) AND (REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN AND (CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100 THEN var1000:=var1000+’☆二阳夹一阴,必须从后续的走势来研判。’;
IF OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0 THEN
var1000:=var1000+’☆ 分离 -两日开盘相同 一阴一阳 变盘前彻底整理。’;
IF ((O>C and open>MA(C,5) and Open>MA(C,10) and O>MA(C,20) and Close<MA(C,5) and Close<MA(C,10) and Close<MA(C,20)) OR (O<C and open<MA(C,5) and Open<MA(C,10) and O<MA(C,20) and Close>MA(C,5) and Close>MA(C,10) and Close>MA(C,20))) THEN var1000:=var1000+’☆断头铡刀(出水芙蓉) -一根大阴(阳)线切断了三根均线 如果改变了其后均线的排列为空头(多头)排列 后势看空(多) 。’;
end;
TIPTEXT(DISPSTATUS=2,0,var1000);
 

解答如下:
阳涨幅:=4;
阳倍量:=2;
C>O*(1+阳涨幅/100) AND VOL>REF(VOL,1)*阳倍量;
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址