• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

分时横盘突破改成同花顺可用

常见公式 第一股票指标公式网 3周前 (11-06) 7次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

tt:=BARSCOUNT(C);
CC:=CLOSE;
zz:=SUM(AMOUNT,tt)/SUM(VOL*100,tt);
zz1:=BETWEEN(C/zz,1.05,0.95);
均线:IF(zz1=0,MA(C,TT),zz),COLOR00FFFF,LINETHICK2;
上均:均线 + AVEDEV(C,tt)*2,COLOR00FF00;
下均:均线 – AVEDEV(C,tt)*2,COLORFF6600;
时长:=if(HOUR>=13 AND HOUR<15 ,1,0);
涨幅:=(close/DYNAINFO(3))>=1.03;
跌幅:=(close/DYNAINFO(3))<=0.97;
涨跌幅:=涨幅 OR 跌幅;
yy:=SMA(vol,30,1);
放量:=(yy-LLV(Llv(yy,1),30))/(HHV(Hhv(yy,1),30)-LLV(Llv(yy,1),30))>0;
横盘:=((HHV(CLOSE,TT)-LLV(CLOSE,TT))/CLOSE)<=0.05;
横涨:=涨跌幅=0 and 横盘 and 时长 and 放量 and CROSS(CC,上均)and DYNAINFO(22)<DYNAINFO(23) ;
横跌:=涨跌幅=0 and 横盘 and 时长 and 放量 and CROSS(下均,CC) ;
PP:= FILTER(横涨,100) ;
UU:= FILTER(横跌,50) ;
DRAWTEXT(PP,上均,’★上突’),colorff00ff;
DRAWTEXT(UU,下均,’★下破’),COLOR00FFFF;
VERTLINE( PP,3),COLORWHITE,LINETHICK2;
VERTLINE( UU,3),COLOR00FF00,LINETHICK2;
 
解答如下:
tt:=FORMATTIME(1);
CC:=NEW;
Vv:=MAX(0,SBUSAMEDAY(&VOL));
zz:=SUM(AMOUNT,tt)/SUM(VOL*100,tt);
zz1:=BETWEEN(C/zz,1.05,0.95);
均线:IF(zz1=0,MA(NEW,TT),zz),COLOR00FFFF,LINETHICK2;
上均:均线 + AVEDEV(NEW,tt)*2,COLOR00FF00;
下均:均线 – AVEDEV(NEW,tt)*2,COLORFF6600;
时长:=IF(tt>=120 AND tt<210,1,0);
涨幅:=(NEW/PRE)>=1.03;
跌幅:=(NEW/PRE)<=0.97;
涨跌幅:=涨幅 OR 跌幅;
yy:=SMA(Vv,30,1);
放量:=(yy-LLV(LLV(yy,1),30))/(HHV(HHV(yy,1),30)-LLV(LLV(yy,1),30))>0;
横盘:=((HHV(NEW,TT)-LLV(NEW,TT))/NEW)<=0.05;
横涨:=涨跌幅=0 AND 横盘 AND 时长 AND 放量 AND CROSS(CC,上均) AND INVOL<OUTVOL;
横跌:=涨跌幅=0 AND 横盘 AND 时长 AND 放量 AND CROSS(下均,CC) ;
PP:= FILTER(横涨,100) ;
UU:= FILTER(横跌,50) ;
DRAWTEXT(PP,上均,’★上突’),colorff00ff;
DRAWTEXT(UU,下均,’★下破’),COLOR00FFFF;
VERLINE( PP,3),colorwhite,LINETHICK2;
VERLINE( UU,3),COLOR00FF00,LINETHICK2;
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址