• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

把断裂的红飘带改编成选股公式

常见公式 第一股票指标公式网 3周前 (11-06) 14次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

把断裂的红飘带改编成选股公式,条件是红飘带断裂后又重新出现,见附图。
源码: E3:EMA(C,3),COLOR61DC16;
E5:EMA(C,5),COLOR61DC16;
E8:EMA(C,8),COLOR61DC16;
E10:=EMA(C,10),COLOR61DC16;
E12:EMA(C,12),COLOR61DC16;
E15:EMA(C,15),COLOR61DC16;
E30:EMA(C,30),COLORD1875A;
E35:EMA(C,35),COLORD1875A;
E40:EMA(C,40),COLORD1875A;
E45:EMA(C,45),COLORD1875A;
E50:EMA(C,50),COLORD1875A;
E60:EMA(C,60),COLORD1875A,POINTDOT;
E120:EMA(C,120),COLORRED,DOTLINE;

STICKLINE(C/REF(C,1)>1.095,C,O,2,0),COLORYELLOW;

IF(E3>REF(E3,1),E3,DRAWNULL),COLORYELLOW;
IF(E5>REF(E5,1),E5,DRAWNULL),COLORYELLOW;
{IF(E8>REF(E8,1),E8,DRAWNULL),COLORYELLOW;}
IF(E10>REF(E10,1),E10,DRAWNULL),COLORYELLOW;
IF(E12>REF(E12,1),E12,DRAWNULL),COLORYELLOW;
IF(E15>REF(E15,1),E15,DRAWNULL),COLORYELLOW;
IF(E30>REF(E30,1),E30,DRAWNULL),COLORFF00FF;
IF(E35>REF(E35,1),E35,DRAWNULL),COLORFF00FF;
IF(E40>REF(E40,1),E40,DRAWNULL),COLORFF00FF;
IF(E45>REF(E45,1),E45,DRAWNULL),COLORFF00FF;
IF(E50>REF(E50,1),E50,DRAWNULL),COLORFF00FF;
IF(E60>REF(E60,1),E60,DRAWNULL),COLORFF00FF;
{STICKLINE(C>O,C,O,1,0),COLORRED;
STICKLINE(C>O,H,L,0,0),COLORRED;
STICKLINE(C<=O,C,O,1,0),COLORFFFF52;
STICKLINE(C<=O,H,L,0,0),COLORFFFF52;};

 

 

解答如下:
E30:=EMA(C,30);
E35:=EMA(C,35);
E40:=EMA(C,40);
E45:=EMA(C,45);
E50:=EMA(C,50);
E60:=EMA(C,60);
A0:=IF(E30>REF(E30,1),E30,DRAWNULL);
A1:=IF(E35>REF(E35,1),E35,DRAWNULL);
A2:=IF(E40>REF(E40,1),E40,DRAWNULL);
A3:=IF(E45>REF(E45,1),E45,DRAWNULL);
A4:=IF(E50>REF(E50,1),E50,DRAWNULL);
A5:=IF(E60>REF(E60,1),E60,DRAWNULL);
BB:=CROSS(A0,0)+CROSS(A1,0)+CROSS(A2,0)+CROSS(A3,0)+CROSS(A4,0)+CROSS(A5,0);
BB>=5;
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址