• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

“区间成本”麻烦改成TDX使用

常见公式 第一股票指标公式网 3个月前 (11-06) 7次浏览 已收录 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

input:N(1,1,9999),M(1,1,9999);
A1:=BARSTATUS=2 ;
C1:=BACKSET(a1,n);
D1:=FILTER(C1,n-1);
VERTLINE( d1,1 );
A2:=BARSTATUS=2 ;
C2:=BACKSET(a2,m);
D2:=FILTER(C2,m-1);
VERTLINE( d2,1 );
周期:abs(n-m) + 1,linethick0;
结束点:=if(n>m,d2,d1);
成交额:=if(结束点,sum(amount,周期),0);
成交量:=if(结束点,sum(vol,周期),0);
区间均价:=if(CATEGORY=1, 成交额/成交量/100,ref(ma(c,abs(n-m)+1),min(m,n)-1));
区间换手和:=成交量/CAPITAL*100;
N1:=IF(DATATYPE=10,1.05,IF(DATATYPE=9,1.02,1.01));
N2:=IF(DATATYPE=10,0.95,IF(DATATYPE=9,0.98,0.99));
区间换手:REF(区间换手和,BARSLAST(结束点)),linethick0;
区间成本:REF(区间均价,BARSLAST(结束点));
上界:REF(区间均价*n1,BARSLAST(结束点)),DOTLINE;
下界:REF(区间均价*n2,BARSLAST(结束点)),DOTLINE;
DRAWTEXTABS(588,20,’成本区间:’+NUMTOSTRN(下界,2)+’ – ‘ +NUMTOSTRN(区间成本,2)
+’ – ‘ + NUMTOSTRN(上界,2)),LAYER0,ColorFFC000;
DRAWTEXTABS(588,40,’区间换手:’+NUMTOSTRN(区间换手,2)),LAYER0,ColorFFC000;

解答如下:
AA:=起点;
BB:=终点;
CYC:=IF(CAPITAL=0,(SUM(C,AA)-SUM(C,BB))/(AA-BB),(SUM(AMOUNT,AA)-SUM(AMOUNT,BB))/(SUM(VOL,AA)-SUM(VOL,BB))/100);
区间成本:CONST(CYC),NODRAW;
区间换手:(SUM(VOL,AA)-SUM(VOL,BB))/CAPITAL*100,NODRAW;
计算周期:AA-BB,NODRAW;
HH:=REFDATE(HHV(H,起点),DATE);
LL:=REFDATE(LLV(L,起点),DATE);
N1:=IF(PERIOD=7,1.05,IF(PERIOD=6,1.02,1.01));
N2:=IF(PERIOD=7,0.95,IF(PERIOD=6,0.98,0.99));
STICKLINE(CURRBARSCOUNT<=终点,区间成本*N1,区间成本*N2,5,0),COLOR808080;
STICKLINE(CURRBARSCOUNT<=终点,区间成本,区间成本,5,0),COLORWHITE;
STICKLINE(CURRBARSCOUNT=起点,HH,LL,0,-1),COLORYELLOW;
STICKLINE(CURRBARSCOUNT=终点,HH,LL,0,-1),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=起点,LL,’起点’),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=终点,LL,’终点’),COLORWHITE;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

 

 

以上是正文
参数设置 起点 0 9999 1
终点 0 9999 0

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址