• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

把“多空分界”公式改成条件选股,要求粉色信号出现时满足选入条

常见公式 第一股票指标公式网 3个月前 (11-06) 12次浏览 已收录 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

以下是公式源码,麻烦老师以“超跌紫色信号出现”为条件(图中红圈标出部分),制作条件选股公式,多谢 !
如果不行,麻烦老师是否可以将此公式改为通达信?再次感谢 !

空方防守价:=EMA(HIGH,4);
多方防守价:=EMA(LOW,5);
B1:=IF(CROSS(CLOSE,空方防守价),1,IF(CROSS(多方防守价,CLOSE),-1,0));
B2:=REF(B1,BARSLAST(B1));
B3:=IF(B2=1,多方防守价,IF(B2=-1,空方防守价,0));
分界点:B3,LINETHICK0,colorFF00FF;
MA1:=B3;
C1:=(ABS(CLOSE-MA1))/CLOSE;
J:=(HHV(C1,160)+LLV(C1,160))/1.7;
CC:=IF(C1<=J-J/2,1,IF(C1<=J-J/3 AND C1>J-J/2,2,IF(C1<=J+J/3 AND C1>J-J/3,3,IF(C1<=2*J AND C1>J+J/3,4,IF(C1>2*J,5,0)))));
STICKLINE(CLOSE>MA1,0,CC,10,0),colorFFFFFF;
STICKLINE(CLOSE>MA1,0,CC,8,0),colorFF;
STICKLINE(CLOSE>MA1 AND CC>3,3,CC,10,0),colorFFFF00;
STICKLINE(CLOSE<MA1,0,-CC,10,0),colorFFFFFF;
STICKLINE(CLOSE<MA1,0,-CC,8,0),colorFF3333;
STICKLINE(CLOSE<MA1 AND CC>3,-3,-CC,10,0),colorFF00FF;
DRAWTEXT(CLOSE>=MA1 AND ISLASTBAR=1,1,’ ←多↑’),colorFF;
DRAWTEXT(CLOSE<MA1 AND ISLASTBAR=1,-1,’ ←空↓’),colorFF00;
PARTLINE(1,0);
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR8:=LLV(LOW,34);
VARB:=HHV(HIGH,34);
BB:=EMA((VAR6-VAR8)/(VARB-VAR8)*100,9);
趋势:EMA(0.667*REF(BB,1)+0.333*BB,2),LINETHICK0,colorFFFF00;
Q:=(2*CLOSE+HIGH+LOW)/4;
A1:=LLV(LOW,24);
A2:=HHV(HIGH,24);
A:=EMA((Q-A1)/(A2-A1)*100,13);
B:=EMA(0.667*REF(A,1)+0.333*A,3);
力道:A-B,LINETHICK0,colorFFFF;

解答如下:
{选股}
空方防守价:=EMA(HIGH,4);
多方防守价:=EMA(LOW,5);
B1:=IF(CROSS(CLOSE,空方防守价),1,IF(CROSS(多方防守价,CLOSE),-1,0));
B2:=REF(B1,BARSLAST(B1));
B3:=IF(B2=1,多方防守价,IF(B2=-1,空方防守价,0));
MA1:=B3;
C1:=(ABS(CLOSE-MA1))/CLOSE;
J:=(HHV(C1,160)+LLV(C1,160))/1.7;
CC:=IF(C1<=J-J/2,1,IF(C1<=J-J/3 AND C1>J-J/2,2,IF(C1<=J+J/3 AND C1>J-J/3,3,IF(C1<=2*J AND C1>J+J/3,4,IF(C1>2*J,5,0)))));
XG:CLOSE<MA1 AND CC>3;
 

 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址