• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

将‘动态买卖’中文字向上移动

常见公式 第一股票指标公式网 4周前 (11-06) 10次浏览 已收录 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

请老师将‘涨停王’文字向上移动,使之在附图中能够清晰看到

VAR0:=VOL/CLOSE/2;
VAR1:=SUM(IF(VAR0 > 100 AND CLOSE > REF(CLOSE,1),VAR0,0),0);
VAR2:=SUM(IF(VAR0 > 100 AND CLOSE < REF(CLOSE,1),VAR0,0),0);
VAR3:=SUM(IF(VAR0 < 100 AND CLOSE > REF(CLOSE,1),VAR0,0),0);
VAR4:=SUM(IF(VAR0 < 100 AND CLOSE < REF(CLOSE,1),VAR0,0),0);
VAR5:=VAR1 + VAR2 + VAR3 + VAR4;
VAR6:=IF(BARSTATUS=2,100 * VAR1/VAR5,0);
VAR7:=IF(BARSTATUS=2,100 * VAR2/VAR5,0);
VAR8:=IF(BARSTATUS=2,100 * VAR3/VAR5,0);
VAR9:=IF(BARSTATUS=2,100 * VAR4/VAR5,0);
机构买盘:VAR1,LINETHICK3,COLORFF55FF;
机构卖盘:VAR2,LINETHICK3,COLORFFFF55;
散户买盘:VAR3,COLOR5555FF;
散户卖盘:VAR4,COLOR55FF55;

机构买卖差:VAR1-VAR2;

DRAWTEXTREL(1003,870,’机构买盘’),LINETHICK2,COLORFF55FF;
DRAWTEXTREL(1003,570,’机构卖盘’),LINETHICK2,COLORFFFF55;
DRAWTEXTREL(1003,320,’散户买盘’),LINETHICK2,COLOR5555FF;
DRAWTEXTREL(1003,50,’散户卖盘’),LINETHICK2,COLOR55FF55;
IF BARSTATUS=2 THEN BEGIN
DRAWTEXTREL(1020,750,” + FLOOR(VAR6) + ‘%’),LINETHICK2,COLORFF55FF;
END

IF BARSTATUS=2 THEN BEGIN
LOOP0:=FLOOR(VAR7);
VAR10:=” + LOOP0;
VAR11:=VAR10 + ‘%’;
DRAWTEXTREL(1020,460,VAR11),LINETHICK2,COLORFFFF55;
END

IF BARSTATUS=2 THEN BEGIN
LOOP1:=FLOOR(VAR8);
VAR12:=” + LOOP1;
VAR13:=VAR12 + ‘%’;
DRAWTEXTREL(1020,200,VAR13),LINETHICK2,COLOR5555FF;
END
IF BARSTATUS=2 THEN BEGIN
LOOP2:=FLOOR(VAR9);
VAR14:=” + LOOP2;
VAR15:=VAR14 + ‘%’;
DRAWTEXTREL(1020,-50,VAR15),LINETHICK2,COLOR55FF55;
END;

量比:sum(vol,0)*240/dynainfo(38)/barscount(c),linethick0;
机构买:CROSS(机构买盘,机构卖盘) and 量比>0.5,linethick0;
VERTLINE(机构买,1),colorgreen;
DRAWTEXT(机构买,l,’涨停王’),colorred;
 


解答如下:
VAR0:=VOL/CLOSE/2;
VAR1:=SUM(IF(VAR0 > 100 AND CLOSE > REF(CLOSE,1),VAR0,0),0);
VAR2:=SUM(IF(VAR0 > 100 AND CLOSE < REF(CLOSE,1),VAR0,0),0);
VAR3:=SUM(IF(VAR0 < 100 AND CLOSE > REF(CLOSE,1),VAR0,0),0);
VAR4:=SUM(IF(VAR0 < 100 AND CLOSE < REF(CLOSE,1),VAR0,0),0);
VAR5:=VAR1 + VAR2 + VAR3 + VAR4;
VAR6:=IF(BARSTATUS=2,100 * VAR1/VAR5,0);
VAR7:=IF(BARSTATUS=2,100 * VAR2/VAR5,0);
VAR8:=IF(BARSTATUS=2,100 * VAR3/VAR5,0);
VAR9:=IF(BARSTATUS=2,100 * VAR4/VAR5,0);
机构买盘:VAR1,LINETHICK3,COLORFF55FF;
机构卖盘:VAR2,LINETHICK3,COLORFFFF55;
散户买盘:VAR3,COLOR5555FF;
散户卖盘:VAR4,COLOR55FF55;

机构买卖差:VAR1-VAR2;

DRAWTEXTREL(1003,870,’机构买盘’),LINETHICK2,COLORFF55FF;
DRAWTEXTREL(1003,570,’机构卖盘’),LINETHICK2,COLORFFFF55;
DRAWTEXTREL(1003,320,’散户买盘’),LINETHICK2,COLOR5555FF;
DRAWTEXTREL(1003,50,’散户卖盘’),LINETHICK2,COLOR55FF55;
IF BARSTATUS=2 THEN BEGIN
DRAWTEXTREL(1020,750,” + FLOOR(VAR6) + ‘%’),LINETHICK2,COLORFF55FF;
END

IF BARSTATUS=2 THEN BEGIN
LOOP0:=FLOOR(VAR7);
VAR10:=” + LOOP0;
VAR11:=VAR10 + ‘%’;
DRAWTEXTREL(1020,460,VAR11),LINETHICK2,COLORFFFF55;
END

IF BARSTATUS=2 THEN BEGIN
LOOP1:=FLOOR(VAR8);
VAR12:=” + LOOP1;
VAR13:=VAR12 + ‘%’;
DRAWTEXTREL(1020,200,VAR13),LINETHICK2,COLOR5555FF;
END
IF BARSTATUS=2 THEN BEGIN
LOOP2:=FLOOR(VAR9);
VAR14:=” + LOOP2;
VAR15:=VAR14 + ‘%’;
DRAWTEXTREL(1020,-50,VAR15),LINETHICK2,COLOR55FF55;
END;

量比:sum(vol,0)*240/dynainfo(38)/barscount(c),linethick0;
机构买:CROSS(机构买盘,机构卖盘) and 量比>0.5,linethick0;
VERTLINE(机构买,1),colorgreen;
DRAWTEXT(机构买,l*20,’涨停王’),colorred;
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址