• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

出现"全仓"信号的选股公式

常见公式 第一股票指标公式网 4周前 (11-06) 10次浏览 已收录 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

公式如下:流通盘:FINANCE(7),LINETHICK0;
DRAWTEXT((SYSPARAM(2) = BARPOS),CLOSE,’ 忠 告 :好公式不是万能的,但没有公式却是万万不能的。 白色 满仓 黄色 加仓 祝 赚钱多多 ‘),ALIGN5,color80FFFF;
MA20:=MA(CLOSE,20);
MA120:=MA(CLOSE,120);
MA30:=MA(CLOSE,37);
MAP:=MA(CLOSE,8);
AA5:=MA(CLOSE,21);
AA10:MA(CLOSE,8),Color00EAFF;
AA12:MA(CLOSE,12),colorFF;
BB10:=((ATAN((AA10 – REF(AA10,1))) * 3.1416) * 10);
BB12:=((ATAN((AA12 – REF(AA12,1))) * 3.1416) * 10);
MA13:=MA(CLOSE,13);
VAR1:=((((OPEN + LOW) + HIGH) + CLOSE) / 4);
中期大底:LLV(LOW,30),colorCDFFBB;
短期底部:=LLV(HIGH,30);
短期底部:=LLV(HIGH,36);
短底:=EMA(VAR1,5);
支撑:=HHV(短底,60);
压力1:HHV(LOW,20),colorFAABEC;
压力:=SMA(LOW,5,1);
中线:=MA(CLOSE,3);
DRAWTEXT(FILTER(((((HIGH > 支撑) AND (CLOSE < 支撑)) AND ((CLOSE / OPEN) > (0 – 1.06))) AND (CLOSE < OPEN)),5),(HIGH + 0.02),’←逃’),ColorFF0000;
中轨道:=(MA(HIGH,15) * 1.05);
天:=(MA(LOW,15) * 0.985);
人:=(MA(LOW,15) * 0.96);
地:=(((HIGH + LOW) + CLOSE) / 3);
B1:=HHV(地,(4 * 15));
B6:=LLV(地,(4 * 15));
B7:=(B1 – B6);
B8:=(MA(((地 – B6) / B7),2) * 80);
VAR1:=(((CLOSE – LLV(LOW,100)) / (HHV(HIGH,100) – LLV(LOW,100))) * 200);
顶底线:=SMA(VAR1,3,1);
VAR2:=SMA(顶底线,3,1);
VAR3:=((3 * 顶底线) – (2 * VAR2));
VAR4:=LLV(LOW,5);
VAR5:=HHV(HIGH,5);
VAR6:=(EMA((((CLOSE – VAR4) / (VAR5 – VAR4)) * 100),4) * 2);
VAR7:=EMA(((0.667 * REF(VAR6,1)) + (0.333 * VAR6)),2);
VAR8:=((3 * VAR6) – (2 * VAR7));
VAR9:=(POW(MA(CLOSE,5),2) + MA(CLOSE,5));
VARA:=(POW(MA(LOW,5),2) + MA(LOW,5));
VARB:=(POW(MA(HIGH,5),2) + MA(HIGH,5));
VARC:=(((((VAR9 – LLV(VARA,64)) / (HHV(VARB,64) – LLV(VARA,64))) * 150) + 65) – 10);
VARD:=((SMA(VARC,3,1) * 1.5) – 100);
VARE:=SMA(VARD,3,1);
VARF:=((3 * VARD) – (2 * VARE));
VAR10:=(((HIGH + LOW) + (CLOSE * 2)) / 4);
VAR11:=EMA(VAR10,13);
VAR12:=STD(VAR10,13);
VAR13:=(((VAR10 – VAR11) * 100) / VAR12);
VAR14:=EMA(VAR13,5);
VAR15:=EMA(VAR14,13);
VAR16:=((EMA(VAR14,13) + 200) – 100);
VAR17:=EMA(VAR16,10);
VAR18:=((3 * VAR16) – (2 * VAR17));
VAR19:=(((顶底线 + VAR6) + VARD) + VAR16);
VAR1A:=(((VAR2 + VAR7) + VARE) + VAR17);
VAR1B:=(((VAR3 + VAR8) + VARF) + VAR18);
VAR1C:=(((HIGH + LOW) + CLOSE) / 3);
VAR1D:=((AMOUNT / VOL) / 100);
VAR1E:=((SUM(AMOUNT,5) / SUM(VOL,5)) / 100);
VAR1F:=((VAR1C – MA(VAR1C,34)) / (0.015 * AVEDEV(VAR1C,34)));
VAR20:=DMA(((AMOUNT / VOL) / 100),(VOL / CAPITAL));
VAR21:=((((HIGH + LOW) + CLOSE) + VAR1C) / 4);
VAR22:=EMA(VAR21,24);
VAR23:=STD(VAR21,24);
VAR24:=(((VAR21 – VAR22) / VAR23) * 100);
VAR25:=((VAR1C – MA(VAR1C,24)) / (0.015 * AVEDEV(VAR1C,24)));
VAR26:=EMA(VAR24,5);
VAR27:=((VAR1D – MA(VAR1D,21)) / (0.015 * AVEDEV(VAR1D,21)));
VAR28:=((VAR1E – MA(VAR1E,90)) / (0.015 * AVEDEV(VAR1E,90)));
VAR29:=(((((((VAR28 + VAR27) + VAR26) + VAR25) + VAR1F) / 5) + 165) / 4);
VAR2A:=(((((VAR19 + VAR1A) + (VAR1B * 30)) / 32) / 5) – 15);
VAR2B:=(((VAR29 + VAR2A) / 2) / 1.1);
VAR2C:=VAR2B;
短线:=MA(VAR2C,26);
MID:=(短线 + (2 * STD(VAR2C,26)));
UPPER:=(短线 – (2 * STD(VAR2C,26)));
LOWER:=IF((VAR2C > 短线),短线,VAR2C);
XY:=MA(CLOSE,5);
MA5:=MA(CLOSE,80);
短期底部:(LLV(HIGH,30) * 0.93),colorFF;
MA80:=LLV(HIGH,30);
短期底部2:=SMA(CLOSE,2,1);
趋势:=(MA(LOW,10) * 0.96);
趋:=(EMA(OPEN,107) * 0.897);
超跌位2:=MA(CLOSE,15);
GF:=MA(CLOSE,10);
MAN:=(SMA(HIGH,21,2) * 1.05);
上1:=(HHV(短底,60) * 0.92);
压力2:=(SMA(HIGH,21,2) * 1.035);
阻挡线:=(SMA(LOW,21,2) * 0.96);
下档线:=(((CLOSE – LLV(LOW,13)) / (HHV(HIGH,13) – LLV(LOW,13))) * 100);
RSV:=SMA(下档线,3,1);
K:=SMA(RSV,3,1);
D:=((3 * RSV) – (2 * K));
J:=(((CLOSE – MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
VAR2P:=(((CLOSE – MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
VAR3P:=(((CLOSE – MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
VAR4P:=(((J + (2 * VAR2P)) + (3 * VAR3P)) / 6);
VAR5P:=MA(VAR4P,3);
VAR6P:=(((CLOSE – LLV(LOW,34)) / (HHV(HIGH,34) – LLV(LOW,34))) * 100);
RSV12:=SMA(VAR6P,3,1);
K12:=SMA(RSV12,3,1);
D12:=((3 * RSV12) – (2 * K12));
J12:=(((CLOSE – LLV(LOW,55)) / (HHV(HIGH,55) – LLV(LOW,55))) * 100);
RSV24:=SMA(J12,3,1);
K24:=SMA(RSV24,3,1);
D24:=((3 * RSV24) – (2 * K24));
J24:=IF(CROSS(D,D24),LOW,REF(LOW,BARSLAST(CROSS(D,D24))));
压力位:IF(CROSS(D24,D),HIGH,REF(HIGH,BARSLAST(CROSS(D24,D)))),colorFFFFFF;
支撑位:=IF((CLOSE >= MA(CLOSE,20)),80,50);
U2L:=IF((CLOSE >= MA(CLOSE,20)),50,20);
L2L:=IF(((D < 支撑位) AND (REF(D,1) >= 支撑位)),HHV(REF(HIGH,1),(BARSLAST(((D >= 支撑位) AND (REF(D,1) < 支撑位))) – 1)),REF(HHV(REF(HIGH,1),(BARSLAST(((D >= 支撑位) AND (REF(D,1) < 支撑位))) – 1)),BARSLAST(((D < 支撑位) AND REF(D,1)))));
RH1:=IF((HIGH > L2L),LOW,REF(LOW,BARSLAST((HIGH > L2L))));
RH4:=IF((HIGH > L2L),D,REF(D,BARSLAST((HIGH > L2L))));
RH42:=IF((((HIGH > RH1) AND (D < RH4)) AND (D < D24)),HIGH,REF(HIGH,BARSLAST((((HIGH > RH1) AND (D < RH4)) AND (D < D24)))));
RH5:=IF(((D > U2L) AND (REF(D,1) <= U2L)),LLV(REF(LOW,1),(BARSLAST(((D <= U2L) AND (REF(D,1) > U2L))) – 1)),REF(LLV(REF(LOW,1),(BARSLAST(((D <= U2L) AND (REF(D,1) > U2L))) – 1)),BARSLAST(((D > U2L) AND REF(D,1)))));
RL1:=IF((LOW < RH5),HIGH,REF(HIGH,BARSLAST((LOW < RH5))));
RL4:=IF((LOW < RH5),D,REF(D,BARSLAST((LOW < RH5))));
RL42:=IF((((LOW < RL1) AND (D > RL4)) AND (D > D24)),LOW,REF(LOW,BARSLAST((((LOW < RL1) AND (D > RL4)) AND (D > D24)))));
长期底部:LLV(HIGH,30),colorFF00;
DRAWTEXT(FILTER(((((RL42 = J24) AND (CLOSE > OPEN)) AND (CLOSE > 长期底部)) AND (LOW <= J24)),20),(LOW – 0.12),’←底入’),ColorFF00FF;
RL5:=(SMA(HIGH,5,2) * 1.05);
上:=(SMA(LOW,5,2) * 0.96);
下:=SMA(LOW,2,1);
DRAWTEXT(FILTER((((((LOW <= 压力位) AND (WINNER(CLOSE) <= 0.07)) AND (CLOSE >= 压力位)) AND (CLOSE < 上1)) AND ((CLOSE / OPEN) > 1.02)),3),LOW,’追’),Color0000FF;
中:=(((((3 * CLOSE) + HIGH) + LOW) + OPEN) / 6);
X1:=EMA(中,10);
X2:=REF(X1,1);
X3:=((REF(HIGH,1) + REF(LOW,1)) / 2);
X4:=(MA(CLOSE,21) + (2 * STD(CLOSE,21)));
X5:=REF(CLOSE,1);
X6:=((SMA(MAX((CLOSE – X5),0),7,1) / SMA(ABS((CLOSE – X5)),7,1)) * 100);
X7:=CROSS(79,X6);
X8:=FILTER(X7,4);
X9:=MA(CLOSE,115);
VAR1:=EMA(CLOSE,8);
顶底线:=EMA(VAR1,20);
VAR2:=CROSS(VAR1,顶底线);
VAR3:=(VAR1 < MA(CLOSE,20));
VAR4:=(((HHV(HIGH,36) – CLOSE) / (HHV(HIGH,36) – LLV(LOW,36))) * 100);
VAR5:=SMA(VAR4,5,1);
VAR6:=SMA(VAR5,8,1);
VAR7:=(CROSS(VAR5,VAR6) AND (VAR6 < 5));
VAR8:=((CLOSE > (LLV(CLOSE,60) + (0.3 * LLV(CLOSE,60)))) AND VAR7);
VAR9:=IF((CLOSE > 1000),VAR7,VAR8);
VARF:=CROSS(X1,X2);
MA115:=VARF;
低买:=(VAR2 AND VAR3);
起步:=VAR9;
DRAWTEXT(X8,(HIGH * 1.03),’←出’),Color02FF00;
DRAWTEXT((起步 > 0),(HIGH * 1.04),’←逃’),ColorADFF00;

逃遁:=(SMA(HIGH, 21,2) * 1.05);
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,9,0),colorFF5B00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,8,0),colorFF6C00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,7,0),colorFF7B00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,6,0),colorFF9C00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,5,0),colorFFBE00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,3.5,0),colorFFCC00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,1.5,0),colorFFFF00;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,9,0),color70084;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,8,0),colorA3;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,7,0),colorB7;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,6,0),colorCD;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,5,0),colorE9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,3,0),color754E9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1.5,0),color76EF3;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),color77BF3;
STICKLINE((CLOSE > OPEN),OPEN,LOW,1,0),color726CA;
STICKLINE((CLOSE > OPEN),CLOSE,HIGH,1,0),color726CA;
STICKLINE((OPEN > CLOSE),CLOSE,LOW,1,0),colorDE9100;
STICKLINE((OPEN > CLOSE),OPEN,HIGH,1,0),colorDE9100;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < 逃遁)) AND ((CLOSE – REF(CLOSE,2)) > 0)),CLOSE,OPEN,9,0),color90FF;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < 逃遁)) AND ((CLOSE – REF(CLOSE,2)) > 0)),CLOSE,OPEN,8,0),color9FFF;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < 逃遁)) AND ((CLOSE – REF(CLOSE,2)) > 0)),CLOSE,OPEN,4,0),colorB5FF;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < 逃遁)) AND ((CLOSE – REF(CLOSE,2)) > 0)),CLOSE,OPEN,2,0),colorE4FF;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < 逃遁)) AND ((CLOSE – REF(CLOSE,2)) > 0)),OPEN,LOW,0.7,0),colorFFFF;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < 逃遁)) AND ((CLOSE – REF(CLOSE,2)) > 0)),CLOSE,HIGH,0.7,0),colorFFFF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 逃遁)) AND (CLOSE < 逃遁)),OPEN,LOW,0.7,0),colorFF76FF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 逃遁)) AND (CLOSE < 逃遁)),CLOSE,HIGH,0.7,0),colorFF76FF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 逃遁)) AND (CLOSE < 逃遁)),CLOSE,OPEN,9,0),colorFF00FF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 逃遁)) AND (CLOSE < 逃遁)),CLOSE,OPEN,6,0),colorFF62FF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 逃遁)) AND (CLOSE < 逃遁)),CLOSE,OPEN,4,0),colorFF76FF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 逃遁)) AND (CLOSE < 逃遁)),CLOSE,OPEN,2,0),colorFFA8FF;
{见她就笑}
b:=BARSCOUNT(CLOSE)=SYSPARAM(2);
d:=BARSLAST(b);
hh:=HHV(HIGH,d);
RH:=HIGH-LOW;
R:=DYNAINFO(13)*100;
gj:=IF(CLOSE=INDEXC,(INDEXC+INDEXH+INDEXL+INDEXO)/4,AMOUNT/(VOL+0.01)/100);
明日阻力:=LOW+(gj-LOW)+(CLOSE-LOW);
明日支撑:=LOW+(CLOSE-gj);
今日阻力:=REF(明日阻力 , 1);
今日支撑:=REF(明日支撑 , 1);
DRAWTEXT(BARSTATUS=2 and VOL>REF(VOL,1) and MA(VOL,5)>REF(MA(VOL,5),1),hh,’今日成交量大于昨日,且有继续增大趋势’+’ ‘),Color9529E0,pxdn90,align4,align2;
DRAWTEXT(BARSTATUS=2 and VOL<REF(VOL,1) and MA(VOL,5)>REF(MA(VOL,5),1),hh,’今日成交量小于昨日,但有放大迹象’+’ ‘),Color8285FF,pxdn90,align4,align2;
DRAWTEXT(BARSTATUS=2 and VOL>REF(VOL,1)and MA(VOL,5)<REF(MA(VOL,5),1),hh,’今日成交量大于昨日, 但有缩小迹象’+’ ‘),Color7DFF00,pxdn90,align4,align2;
DRAWTEXT(BARSTATUS=2 and VOL<REF(VOL,1)and MA(VOL,5)<REF(MA(VOL,5),1),hh,’今日成交量小于昨日,且有缩小迹象’+’ ‘),Color7DFF00,pxdn90,align4,align2;
OK:=EMA(OPEN,55);
CG:=EMA(CLOSE,55);
PDU:=IF(OK>REF(OK,1) AND CG>REF(CG,1),1,0);
Z1:=MA(CLOSE,13);
ZX:=REF(Z1,18/2+1);
LIFE:=(EMA(CLOSE,55)+EMA(CLOSE,90))/2;
VAR1:=(2*CLOSE+HIGH+LOW)/4;
SNOOK:=EMA(VAR1,99)*0.91;
A1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
MA5:=BARSLAST(A1>3);
MA21:=IF(MA5>0,1,0);

BY21:=MA(CLOSE,5);
AA:MA(CLOSE,21),LINETHICK1,Color00FF00;
CC:IF(BY21>AA,AA,BY21),LINETHICK1,COLOR808080;

选股:=CROSS(CLOSE,ZX) AND CLOSE>ZX AND MA21=0 ,LINETHICK0;
RB:=BARSCOUNT(CLOSE)=ISLASTBAR;
RD:=BARSLAST(RB);
K2:=HHV(HIGH,55);
K1:=LLV(LOW,55);
T1:=CLOSE>ZX AND CLOSE>=LIFE;
T2:=CLOSE>ZX AND CLOSE>SNOOK AND CLOSE<LIFE;
T3:=CLOSE>ZX AND CLOSE<=SNOOK;
T4:=CLOSE<=ZX;
T5:=CC>REF(CC,1) AND CC=AA ;
T6:=CC>REF(CC,1) AND CC=AA AND PDU=1;
T7:=CC>REF(CC,1) AND CC=AA AND PDU=1;
T8:=CLOSE>ZX AND MA21=0 ;
EEE:=T1+T2+T3+T4+T5+T6+T7+T8 ;
E:=(K2-K1)/(EEE+8) ;
选股:CROSS(CLOSE,ZX);

var31:=HHVBARS(ZIG(3, 19)>REF(ZIG(3,19),1)
and REF(ZIG(3,19), 1)<REF(ZIG(3,19), 2),0);
DRAWTEXT(var31=2,LOW*0.95,’3天进’),coloryellow;
DRAWTEXT(var31=4,HIGH*1.06,’5天出’),coloryellow;
DRAWTEXT(var31=7,LOW*0.95,’8天进’),coloryellow;
DRAWTEXT(var31=12,HIGH*1.06,’13天出’),coloryellow;
DRAWTEXT(var31=20,LOW*0.95,’21天进’),coloryellow;
DRAWTEXT(var31=33,HIGH*1.06,’34天出’),coloryellow;
DRAWTEXT(var31=54,LOW*0.95,’55天进’),coloryellow;
DRAWTEXT(var31=88,HIGH*1.06,’89天出’),coloryellow;
DRAWTEXT(var31=143,LOW*0.95,’144天进’),coloryellow;
DRAWTEXT(var31=232,HIGH*1.06,’233天出’),coloryellow;
DRAWTEXT(var31=376,LOW*0.95,’377天进’),coloryellow;

{信号部分—参考}
买点:=FILTER((TROUGHBARS(3,15,1)<4)=1,3);
卖点:=FILTER((PEAKBARS(3,15,1)<4)=1,3);
{短波–未来}
F:=100*(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
p1:=IF(CLOSE<REF(OPEN,1) AND f<0,1,0);
p3:=IF(CLOSE>REF(OPEN,1) AND f>0,1,0);
p2:=IF(CLOSE<REF(OPEN,2) AND f<0,1,0);
p4:=IF(CLOSE>REF(OPEN,2) AND f>0,1,0);
买D5:=P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1;
卖D6:=P3=0 AND REF(P3,1)=1 AND P4=0 AND REF(P4,1)=1;
FZ:=PEAK(3,5,1);
FW:=PEAKBARS(3,5,1);
GZ:=TROUGH(3,5,1);
GW:=TROUGHBARS(3,5,1);
AS:=ZIG(3,3);
涨AL:=CROSS(AS,REF(AS,1));
跌AG:=CROSS(REF(AS,1),AS);
Ss1:=IF(FW>GW,FW,0);
Ss2:=IF(FW<GW,GW,0);
Ss3:=BARSLAST(Ss1);
Ss4:=BARSLAST(Ss2);
{信号部分—参考}
STICKLINE(卖点,HIGH,(OPEN+CLOSE)/2,0,0),Color00FF00;{未来卖点}
STICKLINE(卖点,CLOSE,(OPEN+CLOSE)/2,5,0),Color00FF00;{未来卖点}
{短波–未来}
STICKLINE(买D5 and 涨AL,LOW,(OPEN+CLOSE)/2,0,0),ColorFFFFFF; {未来买}
STICKLINE(买D5 and 涨AL,OPEN,(OPEN+CLOSE)/2,5,0),ColorFFFFFF; {未来买}

aa1:=AMOUNT/VOL;
bb1:=LOW<aa1*0.9;
cc1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>1.2;
dd1:=LOW<MA(CLOSE,5)*0.921;
ee1:=VOL<MA(VOL,5)*1.5;
老鼠仓:bb1 and cc1 and dd1 and ee1,linethick0,ColorFFFFFF;
STICKLINE(老鼠仓,OPEN,CLOSE,6,1),linethick1,ColorFFFFFF;
A:=((CLOSE)/(REF(CLOSE,1)) >= 1.045) or (OPEN = LOW) and (HIGH = CLOSE) or ((CLOSE)/(OPEN) >= 1.07);
SJ1:=BARSLAST((A = 1));
A1:=((CLOSE)/(REF(CLOSE,1)) >= 1.095) or ((CLOSE)/(OPEN) >= 1.1);
涨停:STICKLINE((A1 = 1),OPEN,CLOSE,4,0),Color6093A1;
SJ2:=BARSLAST((A1 = 1));
{以下是两条趋势线原码}
A1:=REF(HIGH,3)=HHV(HIGH,2*3+1); B1:=FILTER(A1,3); C1:=BACKSET(B1,3+1); D1:=FILTER(C1,3);{高点}
A2:=REF(LOW,3)=LLV(LOW,2*3+1); B2:=FILTER(A2,3); C2:=BACKSET(B2,3+1); D2:=FILTER(C2,3);{低点}
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2; E2:=(HIGH+LOW)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
L1:=(D2 AND NOT(D1 AND E1<E2)); H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); LD:=I1>REF(I1,1);{过滤后低点}
L2:=LD OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1; F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
G2:=F2>REF(F2,1); I2:=BACKSET(G2,2); HD:=I2>REF(I2,1);{过滤后高点}
UU:=BACKSET(ISLASTBAR,BARSLAST(LD)+1);
VV:=UU>REF(UU,1);
WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);
XX:=WW>REF(WW,1);
UU2:=BACKSET(ISLASTBAR,BARSLAST(HD)+1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);
XX2:=WW2>REF(WW2,1);
前低:REF(LOW,BARSLAST(VV)),COLOR99FF66,POINTDOT,LINETHICK4;
前高:REF(HIGH,BARSLAST(VV2)),ColorEA5EFF,POINTDOT,LINETHICK4;
yy:=REF(YEAR,BARSCOUNT(CLOSE)-1),linethick0;
mm:=REF(MONTH,BARSCOUNT(CLOSE)-1),linethick0;
dd:=REF(DAY,BARSCOUNT(CLOSE)-1),linethick0;
DRAWTEXTEX(1,1,10,430,’ \n \n(上市日期:’+NUMTOSTR(yy,0)+’年’+NUMTOSTR(mm,0)+’月’+NUMTOSTR(dd,0)+’日’),COLOR00ffff,LINETHICK2;
DRAWTEXTEX(1,1,10,500,’ \n \n上市后总交易天数:’+NUMTOSTR(BARSCOUNT(CLOSE),0)+’天)’),COLOR00ffff,LINETHICK2;

{明日K線}
MRZY:=ROUND((((REF(HIGH,1)-REF(LOW,1))*8/10)+CLOSE)*100)/100;
MRZS:=ROUND((CLOSE-((REF(HIGH,1)-REF(LOW,1))*8/20))*100)/100;//止贏止損
STICKLINE(CLOSE>OPEN AND ISLASTBAR,MRZY,MRZS,8,1),COLORMAGENTA,SHIFT2;
STICKLINE(CLOSE<=OPEN AND ISLASTBAR,MRZY,MRZS,8,1),Color00FF4F,SHIFT2;

DRAWTEXT(FILTER(((((LLV(LOW,0) AND ((MA30 – REF(MA30,1)) > 0)) AND (LOW <= 短期底部)) AND (WINNER(CLOSE) < 0.05)) AND ((CLOSE / OPEN) > 0.13)),7),(LOW – 0.09),’●底入’),colorB2FF;
阻挡:=(SMA(LOW,21,2) * 0.94);

DRAWTEXT(FILTER(((((((((CLOSE / OPEN) > 1.03) AND ((超跌位2 – REF(超跌位2,1)) > 0)) AND ((CLOSE – REF(CLOSE,1)) > 0)) AND (HIGH < 压力1)) AND (CLOSE < 压力1)) AND ((压力2 – REF(压力2,1)) > 0)) AND (CLOSE < MAN)),3),LOW,’←出击’),colorD4DEE9;
DRAWTEXT((((((低买 > 0) AND ((X1 – REF(X1,1)) > 0)) AND (HIGH < 压力位)) AND (HIGH < X9)) AND ((X2 – REF(X2,1)) > 0)),LOW,’←黑马’),colorFF00;
DRAWTEXT((((((CROSS(VAR2C,短线) AND ((CLOSE – REF(HIGH,1)) > 0)) AND ((中线 – REF(中线,1)) > 0)) AND (HIGH <= 压力1)) AND (CLOSE < MA20)) AND (LOW <= 中线)),(LOW – 0.06),’←关注’),colorFF00;
DRAWTEXT((((CROSS(VAR2C,UPPER) AND (HIGH < 压力1)) AND ((XY – REF(XY,1)) > 0)) AND (HIGH < 支撑)),LOW,’☆买入’),colorFFFFFF;
DRAWTEXT(FILTER(((((((LOW <= 天) AND (CLOSE >= MA20)) AND (HIGH < 压力1)) AND ((天 – REF(天,1)) > 0)) AND (CLOSE < 压力1)) AND ((MA20 – REF(MA20,1)) > 0)),6),(LOW – 0.12),’←全仓’),colorFFFFFF;
DRAWTEXT(FILTER((((((MA115 AND (CLOSE < 压力位)) AND ((人 – REF(人,1)) > 0)) AND ((X1 – REF(X1,1)) > 0)) AND (HIGH < 上1)) AND ((CLOSE / OPEN) > 1.03)),5),LOW,’●买入’),color93EE7D;
DRAWTEXT(((((LOW <= 上) AND (HIGH >= 短期底部)) AND (CLOSE >= 长期底部)) AND ((CLOSE / OPEN) > 1.03)),(LOW – 0.08),’★抄底’),colorFF;
DRAWTEXT(FILTER((((((LOW <= 阻挡线) AND ((MA20 – REF(MA20,1)) > 0)) AND (OPEN <= 上1)) AND (HIGH > 上1)) AND (CLOSE > 阻挡线)),5),LOW,’←涨10%’),colorFFFFFF;
DRAWTEXT(((CROSS(压力,阻挡) AND (WINNER(CLOSE) <= 0.17)) AND ((X1 – REF(X1,1)) > 0)),(LOW – 0.08),’◆买入’),colorFFFF;
DRAWTEXT(FILTER((((((B8 <= 1) AND (LOW <= 阻挡)) AND (CLOSE > OPEN)) AND (LOW <= 中期大底)) AND (CLOSE >= 长期底部)),3),(LOW – 0.08),’←短入’),colorA100FF;
DRAWTEXT((((CROSS(D,0) AND (HIGH < 压力位)) AND (VAR5P <= (0 – 7))) AND (CLOSE < XY)),(LOW – 0.11),’←半仓’),colorFFFF;
DRAWTEXT(FILTER((((CROSS(趋势,趋) AND (HIGH < MA5)) AND (HIGH < 压力1)) AND LLV(LOW,0)),10),LOW,’←入’),colorFFFF;
DRAWTEXT(FILTER(((CROSS(中线,人) AND (LOW <= 人)) AND (CLOSE >= 人)),4),(LOW – 0.06),’←买’),colorFF00;
DRAWTEXT(((CROSS(阻挡,长期底部) AND (BB10 > 1)) AND (HIGH < 支撑)),LOW,’←出击’),colorFF00;
DRAWTEXT(FILTER((((((((MA20 – REF(MA20,1)) > 0) AND (HIGH < 支撑)) AND ((AA10 – REF(AA10,1)) > 0)) AND (HIGH < 压力1)) AND (VOL >= REF(VOL,1))) AND CROSS(CLOSE,MA20)),57),LOW,’突破生命线’),colorFF;
DRAWTEXT(FILTER(((((LOW <= MA80) AND (CLOSE > MA80)) AND (CLOSE > OPEN)) AND (短期底部2 <= MA80)),8),LOW,’←底入’),colorFFFF;
DRAWTEXT(((CROSS(MA20,压力位) AND (LOW <= MA20)) AND ((MA20 – REF(MA20,1)) > 0.02)),(LOW – 0.03),’●买入’),colorFFF0FF;
DRAWTEXT((((((((CROSS(CLOSE,MA20) AND (HIGH < 压力位)) AND (OPEN < MA20)) AND (HIGH < 支撑)) AND ((MAN – REF(MAN,1)) > 0)) AND ((X1 – REF(X1,1)) > 0)) AND (D < 63)) AND ((MA20 – REF(MA20,1)) > 0)),(LOW – 0.05),’●大牛’),ColorFF57C0;
DRAWTEXT(CROSS(中期大底,短期底部),(LOW – 0.02),’○买入’);
{1、本公式的特色指标是区间彩带,只有当区间彩带成斜率45度时(彩带里面才能填充红色)发出的买入信号的准确率最高,当区间彩带小于45度斜率时(区间彩带里的填充红色则自动消失)虽然股价继续上扬,但是量价已经产生背离(既:顶背离现象)这时应当逐步减仓,其他信号的发出要根据大市进行操作。
2、公式中没有发出买卖信号的地方可以参照顶底压力支撑线进行适当的买卖操作;并且可以参照压力与支撑线,判断可能上升和下跌的空间。

Varr1:=移动平均(最大值(收盘价-向前引用(收盘价,1),0),6,1)/移动平均(绝对值(收盘价-向前引用(收盘价,1)),6,1)*100;
画图标(交叉函数(82,Varr1),最高价+0.108,2);画垂直线(交叉函数(82,varr1)),点状线;
画斜线(交叉函数(82,varr1),最高值(最高价,1),0,8,1),colormagenta,点状线;
b1:=(系统参数(4)-系统参数(5))/(系统参数(3)-系统参数(2));
画斜线(数据位置=系统参数(1),最低价,378*b1/100,0,0),COLORwhite,点状线;
画斜线(数据位置=系统参数(1),最低价,188*b1/100,0,0),COLORwhite,点状线;
画斜线(数据位置=系统参数(1),最低价,141*b1/100,0,0),COLORwhite,点状线;
画斜线(数据位置=系统参数(1),最低价,95*b1/100,0,0),COLORwhite,点状线;
画斜线(数据位置=系统参数(1),最低价,48*b1/100,0,0),COLORgreen,;
画斜线(数据位置=系统参数(1),最低价,24.5*b1/100,0,0),COLORwhite,点状线;
画斜线(数据位置=系统参数(1),最低价,16.5*b1/100,0,0),COLORwhite,点状线;
画斜线(数据位置=系统参数(1),最低价,13*b1/100,0,0),COLORwhite,点状线;
画斜线(数据位置=系统参数(1),最低价,7*b1/100,0,0),COLORwhite,点状线;

 

解答如下:

MA20:=MA(CLOSE,20);
压力1:=HHV(LOW,20);
天:=(MA(LOW,15) * 0.985);
全仓:FILTER(((((((LOW <= 天) AND (CLOSE >= MA20)) AND (HIGH < 压力1)) AND ((天 – REF(天,1)) > 0)) AND (CLOSE < 压力1)) AND ((MA20 – REF(MA20,1)) > 0)),6);
 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址