• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

同一附图里,不同周期显示不同的信号

常见公式 第一股票指标公式网 3个月前 (11-06) 11次浏览 已收录 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

源码如下,股友提问要求:在30分钟周期显示背离信号,在日线周期显示死叉关注信号。
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);D:=SMA(K,3,1);J:=3*K-2*D;
底背离:=C=LLV(C,13) AND J>REF(LLV(J,13),1);
DRAWTEXT(底背离,0,’㊣’),COLOR000050,ALIGN4,PXDN20;
顶背离:=C=HHV(C,13) AND J<REF(HHV(J,13),1) AND C>REF(C,1);
DRAWTEXT(顶背离,0,’※’),COLOR550000,ALIGN5,PXUP20;
DXMS:=CROSS(D,K);
死叉关注:DXMS,LINETHICK,COLORDD;)
 
解答如下:
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);D:=SMA(K,3,1);J:=3*K-2*D;
底背离:=C=LLV(C,13) AND J>REF(LLV(J,13),1);
顶背离:=C=HHV(C,13) AND J<REF(HHV(J,13),1) AND C>REF(C,1);
DXMS:=CROSS(D,K);

if datatype=4 then begin
DRAWTEXT(底背离,0,’㊣’),COLOR000050,ALIGN4,PXDN20;
DRAWTEXT(顶背离,0,’※’),COLOR550000,ALIGN5,PXUP20;
end else
if datatype=6 then begin
死叉关注:DXMS,COLORreD;
end;

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址