• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

把雄起指标中的雄起做成选股

常见公式 第一股票指标公式网 4周前 (11-07) 14次浏览 已收录 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

源码为:

input:LONG(26,1,100),SHORT(12,1,100),M(9,1,100),p1(19,1,100),p2(120,1,250);
DIF:EMA(CLOSE,SHORT) – EMA(CLOSE,LONG);
DEA:=EMA(DIF,M);
MACD:=2*(DIF-DEA);
MACD2:2*(DEA-DIF),COLORFF89B2,DOTLINE;
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA30:=MA(CLOSE,30);
MA60:=MA(CLOSE,60);
MA65:=MA(CLOSE,65);
MA250:=MA(CLOSE,250);
突破线:=MIN(MA60*1.1,MA250*1.3);
差幅:=C/MIN(MA60*1.1,MA250*1.3)-1;
均线流:=(MA5>MA65 AND MA10>MA65 AND MA30>MA65 AND MA5<MA30)*0.3;
PL1:=(CLOSE – MA60) / MA60 < 0.1;
PL2:=(CLOSE – MA250) / MA250 < 0.3;
偏离率:(PL1 = 1 AND PL2 = 1) * 0.2,STICK,COLORFF00FF,LINETHICK2;
MACD超跌:=COUNT((DIF<DEA),10)=10;
MACD1:MACD超跌 * "MACD.MACD"(LONG,SHORT,M)*(-1),COLOR009900,LINETHICK2;
目标:IF(均线流=0.3 AND MACD超跌 AND 偏离率=0.2 ,0.8,0),COLOR7070FF,LINETHICK2;
MBSJ:=BARSLAST(目标 = 0.8);
放量上涨:=V/REF(V,1) >= 1.1 AND C/REF(C,1) >= 1.01;
SZSJ:=BARSLAST(放量上涨 = 1);
MACD雄起:=CROSS(DIF,DEA);
JCSJ:=BARSLAST(MACD雄起 = 1);
关注:(MACD雄起 AND REF(MACD1,1) < 0)*-0.1,COLOR00FF00;
启动:(MBSJ <= 20 AND SZSJ <= 1 AND JCSJ <= 1) * 1,COLORFFFF00,LINETHICK2;
突破:(偏离率 = 0 AND REF(COUNT(偏离率 = 0.2,10) = 10,1) = 1) * -0.1,COLORRED;
STICKLINE(偏离率 = 0.2,0,0.2,1,0),colorFF00FF;
DRAWTEXT(关注=-0.1,-0.01,’关●注’),color00ff00;
DRAWTEXT(启动,0.8,’★买’),colorFFFF00;
DRAWTEXT(突破=-0.1,-0.01,’突●破’),colorred;
N15HIGH:=REF(HIGH,15);
N1LOW:=REF(LOW,1);
FF:=(((N15HIGH – N1LOW) / N1LOW) > 0.15);
DRAWICON((((((CROSS(MA(CLOSE,P1),MA(CLOSE,P2)) > 0) AND (((N15HIGH – N1LOW) / N1LOW) <

0.15)) AND (OPEN >= MA(CLOSE,P1))) AND (CLOSE >= MA(CLOSE,P1))) AND (LOW <= MA

(CLOSE,P1))),0.5,1);
DRAWTEXT((((((CROSS(MA(CLOSE,P1),MA(CLOSE,P2)) > 0) AND (((N15HIGH – N1LOW) / N1LOW) <

0.15)) AND (OPEN >= MA(CLOSE,P1))) AND (CLOSE >= MA(CLOSE,P1))) AND (LOW <= MA

(CLOSE,P1))),0.5,’★^回头望月’),color0099CC;
低位雄起:CROSS(DIF,DEA) AND DIF<-0.1,colorwhite;
STICKLINE(低位雄起,0,0.08,6,0),COLORwhite;
DRAWTEXT(低位雄起,低位雄起-1.5,’ 低位雄起’),COLORWHITE;
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
雄起:CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,coloryellow;
STICKLINE(雄起,0,0.06,6,0),ColorFF00FF;
DRAWICON(雄起,dea*1.04,1) ;
DRAWTEXT(雄起,0.5,’ 雄起’),ColorYELLOW;
 


解答如下:
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
XG:CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址