• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

把主动买盘指标在红,黄线突破0轴线(上翘)写预警指标

常见公式 第一股票指标公式网 8个月前 (11-07) 229次浏览 已收录 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

把主动买盘指标在红,黄线突破0轴线(上翘)写个预警预警指标.

0,COLORWHITE;
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买盘:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主动卖盘:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AA*(HIGH-LOW),0-VOL/2));
主买:=主动买盘/CAPITAL;
主卖:=-主动卖盘/CAPITAL;
M1:=MA(主买,M);
M2:=MA(主卖,M);
买:100*MA(M1,N),COLORRED;
卖:100*MA(M2,N),COLORGREEN;
差:买-卖,COLORYELLOW;
差D:=MA(差,2);
关注:(1+BARSLAST(CROSS(差,差D)))*(差>差D),NODRAW;
 


解答如下:
M、N—取值未定义,帮你定义如下:
—————————–
M:=10;N:=5;
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买盘:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主动卖盘:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AA*(HIGH-LOW),0-VOL/2));
主买:=主动买盘/CAPITAL;
主卖:=-主动卖盘/CAPITAL;
M1:=MA(主买,M);
M2:=MA(主卖,M);
买:=100*MA(M1,N);
卖:=100*MA(M2,N);
差:=买-卖;
CROSS(差,0) AND 差>REF(差,1);

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址