• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式等股票软件指标公式源码

财务主图=价值投资(源码+图)大智慧、分析家、通达信、同花顺+选股+排序

同花顺公式 第一股票指标公式网 2年前 (2019-10-18) 220次浏览 已收录 0个评论 扫描二维码

财务主图=价值投资(源码+图)大智慧分析家通达信同花顺+选股+排序介绍

分析家公式
年认同价:=ma(c,240);
价格中枢:=(SUM(年认同价,0)/BARPOS);
G:价格中枢*1.2,LINETHICK4,color009900;
G2:价格中枢*1.618,POINTDOT,Colorwhite;
G3:价格中枢*1.382,POINTDOT,Colorwhite;
G1:价格中枢*0.8,LINETHICK4,color009900;
FILLRGN(G1,G,G1>0),color5f5f5f;
毛利润率:=FINANCE(21)/FINANCE(20);
成长价值:年认同价*(1+毛利润率),Coloryellow,linethick1;
收益价值:年认同价+FINANCE(33),Colorred,linethick1;
价格中枢,LINETHICK1,COLORFFBB00;
a:=(3*c+l+o+h)/6;
X:=(20*a+19*ref(a,1)+18*ref(a,2)+17*ref(a,3)+16*ref(a,4)+15*ref(a,5)+
14*ref(a,6)+13*ref(a,7)+12*ref(a,8)+11*ref(a,9)+10*ref(a,10)+9*ref(a,11)+8*ref(a,12)
+7*ref(a,13)+6*ref(a,14)+5*ref(a,15)+4*ref(a,16)+3*ref(a,17)+2*ref(a,18)+
ref(a,20))/210;
回调认同:eMA(X,13),colorFF00FF;
PARTLINE(回调认同,回调认同<ref(回调认同,1)),COLORGREEN,LINETHICK1;
STICKLINE(close>=open,open,close,8,1),colorred;
STICKLINE(open>close,close,open,8,0 ),colorgreen;
STICKLINE(close>=open,close,HIGH,0.5 ,0 ),colorred;
STICKLINE(close>=open,open,low,0.5 ,0),colorred;
STICKLINE(open>close,close,low,0.5 ,0 ),colorgreen;
STICKLINE(open>close,open,HIGH,0.5 ,0 ),colorgreen;
aa:=CLOSE/REF(CLOSE,1)>=1.09;
STICKLINE(aa,open,close,8,0),coloryellow;
STICKLINE(aa,low,HIGH,0.5 ,0 ),coloryellow;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
卖:=CROSS(84,RSI);
DRAWTEXT(卖,(HIGH * 1.02),’●’),colorwhite;
M17:EMA(CLOSE,17),colorblue;
ab:=sma(ema((c-ref(c,1))/ref(c,1),5)*100,3,1)*10;
买:=cross(ab,0);
STICKLINE(买,open,close,8,0),colormagenta;
STICKLINE(买,low,HIGH,0.5 ,0 ),colormagenta;
QH:=REF(H,2);
QL:=REF(L,2);
QO:=REF(O,2);
QC:=REF(C,2);
ZO:=REF(O,1);
ZC:=REF(C,1);
JYZHK:= ABS(QO-QC)/QO<0.02 AND ZO/ZC>1.02 AND ABS(O-C)/O<0.02 AND C>MA(C,30);
JYZHV:=V<REF(V,1) ;
JYZH:=JYZHK AND JYZHV;
DRAWTEXT(JYZH,LOW/1.01,’★’),COLORRED;
c2:=EMA(a,6);
c3:=EMA(a,5);
c4:=CROSS(c2,c3);
DRAWTEXT(c4,LOW/1.01,’▲’),COLORRED;

飞狐公式
年认同价:=ma(c,240);
价格中枢:=(SUM(年认同价,0)/BARPOS);
G:价格中枢*1.2,LINETHICK4,color009900;
G2:价格中枢*1.618,POINTDOT,Colorwhite;
G3:价格中枢*1.382,POINTDOT,Colorwhite;
G1:价格中枢*0.8,LINETHICK4,color009900;
FILLRGN(G1>0,G1,G),color5f5f5f;
毛利润率:=FINANCE(21)/FINANCE(20);
成长价值:年认同价*(1+毛利润率),Coloryellow,linethick1;
收益价值:年认同价+FINANCE(33),Colorred,linethick1;
价格中枢,LINETHICK1,COLORFFBB00;
a:=(3*c+l+o+h)/6;
X:=(20*a+19*ref(a,1)+18*ref(a,2)+17*ref(a,3)+16*ref(a,4)+15*ref(a,5)+
14*ref(a,6)+13*ref(a,7)+12*ref(a,8)+11*ref(a,9)+10*ref(a,10)+9*ref(a,11)+8*ref(a,12)
+7*ref(a,13)+6*ref(a,14)+5*ref(a,15)+4*ref(a,16)+3*ref(a,17)+2*ref(a,18)+
ref(a,20))/210;
回调认同:eMA(X,13),colorFF00FF;
STICKLINE(close>=open,open,close,8,1),colorred;
STICKLINE(open>close,close,open,8,0 ),colorgreen;
STICKLINE(close>=open,close,HIGH,0.5 ,0 ),colorred;
STICKLINE(close>=open,open,low,0.5 ,0),colorred;
STICKLINE(open>close,close,low,0.5 ,0 ),colorgreen;
STICKLINE(open>close,open,HIGH,0.5 ,0 ),colorgreen;
aa:=CLOSE/REF(CLOSE,1)>=1.09;
STICKLINE(aa,open,close,8,0),coloryellow;
STICKLINE(aa,low,HIGH,0.5 ,0 ),coloryellow;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
卖:=CROSS(84,RSI);
DRAWTEXT(卖,(HIGH * 1.02),’●’),colorwhite;
M17:EMA(CLOSE,17),colorblue;
ab:=sma(ema((c-ref(c,1))/ref(c,1),5)*100,3,1)*10;
买:=cross(ab,0);
STICKLINE(买,open,close,8,0),colormagenta;
STICKLINE(买,low,HIGH,0.5 ,0 ),colormagenta;
QH:=REF(H,2);
QL:=REF(L,2);
QO:=REF(O,2);
QC:=REF(C,2);
ZO:=REF(O,1);
ZC:=REF(C,1);
JYZHK:= ABS(QO-QC)/QO<0.02 AND ZO/ZC>1.02 AND ABS(O-C)/O<0.02 AND C>MA(C,30);
JYZHV:=V<REF(V,1) ;
JYZH:=JYZHK AND JYZHV;
DRAWTEXT(JYZH,LOW/1.01,’★’),COLORRED;
c2:=EMA(a,6);
c3:=EMA(a,5);
c4:=CROSS(c2,c3);
DRAWTEXT(c4,LOW/1.01,’▲’),COLORRED;

通达信
年认同价:=MA(C,240);
价格中枢:=(SUM(年认同价,0)/(BARSSINCE(年认同价>0)+239));
G:=价格中枢*1.2,LINETHICK2,COLOR009900;
G2:价格中枢*1.618,POINTDOT,COLORWHITE;
G3:价格中枢*1.382,POINTDOT,COLORWHITE;
G1:=价格中枢*0.8,LINETHICK2,COLOR009900;
STICKLINE(G1>0,G1,G,4,0),COLOR5F5F5F;{填色修饰}
IF(G1>0,G,DRAWNULL),COLOR00A800,LINETHICK2;{箱体上沿}
IF(G1>0,G1,DRAWNULL),COLOR008000,LINETHICK2;{箱体下沿}
IF(G1>0,价格中枢,DRAWNULL),COLORFFB900,LINETHICK1;{价格中枢}
{K线}
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
毛利润率:=FINANCE(21)/FINANCE(20);
成长价值:年认同价*(1+毛利润率),COLORYELLOW;
收益价值:年认同价+FINANCE(33),COLORRED;
回调认同:EMA(EXPMA(C,20),13),COLORWHITE;
{突破指示}
AA:=CLOSE/REF(C,1)>=1.09;
STICKLINE(AA,O,C,3,0),COLORYELLOW;
STICKLINE(AA,L,H,0,0),COLORYELLOW;
QH:=REF(H,2);
QL:=REF(L,2);
QO:=REF(O,2);
QC:=REF(C,2);
ZO:=REF(O,1);
ZC:=REF(C,1);
JYZHK:= ABS(QO-QC)/QO<0.02 AND ZO/ZC>1.02 AND ABS(O-C)/O<0.02 AND C>MA(C,30);
JYZHV:=V<REF(V,1) ;
JYZH:=JYZHK AND JYZHV;
DRAWTEXT(JYZH,LOW/1.01,’★’),COLORRED;
A:=(3*C+L+O+H)/6;
C2:=EMA(A,6);
C3:=EMA(A,5);
C4:=CROSS(C2,C3);
DRAWTEXT(C4,LOW/1.01,’▲’);

大智慧
年认同价:=MA(C,240);
价格中枢:=(SUM(年认同价,0)/(BARSSINCE(年认同价>0)+239));
G:价格中枢*1.2,LINETHICK2,color009900;
G2:价格中枢*1.618,POINTDOT,Colorwhite;
G3:价格中枢*1.382,POINTDOT,Colorwhite;
G1:价格中枢*0.8,LINETHICK2,color009900;
STICKLINE(G1>0,G1,G,8,0),color5f5f5f;
毛利润率:=FINANCE(21)/FINANCE(20);
成长价值:年认同价*(1+毛利润率),Coloryellow,linethick1;
收益价值:年认同价+FINANCE(33),Colorred,linethick1;
价格中枢,LINETHICK1,COLORFFBB00;
a:=(3*c+l+o+h)/6;
X:=(20*a+19*ref(a,1)+18*ref(a,2)+17*ref(a,3)+16*ref(a,4)+15*ref(a,5)+
14*ref(a,6)+13*ref(a,7)+12*ref(a,8)+11*ref(a,9)+10*ref(a,10)+9*ref(a,11)+8*ref(a,12)
+7*ref(a,13)+6*ref(a,14)+5*ref(a,15)+4*ref(a,16)+3*ref(a,17)+2*ref(a,18)+
ref(a,20))/210;
回调认同:eMA(X,13),colorFF00FF;
STICKLINE(close>=open,open,close,5,1),colorred;
STICKLINE(open>close,close,open,5,0 ),colorffff50;
STICKLINE(close>=open,close,HIGH,0.5 ,0 ),colorred;
STICKLINE(close>=open,open,low,0.5 ,0),colorred;
STICKLINE(open>close,close,low,0.5 ,0 ),colorffff50;
STICKLINE(open>close,open,HIGH,0.5 ,0 ),colorffff50;
aa:=CLOSE/REF(CLOSE,1)>=1.09;
STICKLINE(aa,open,close,5,0),coloryellow;
STICKLINE(aa,low,HIGH,0.5 ,0 ),coloryellow;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
卖:=CROSS(84,RSI);
DRAWTEXT(卖,(HIGH * 1.02),’●’),colorwhite;
M17:EMA(CLOSE,17),colorblue;
ab:=sma(ema((c-ref(c,1))/ref(c,1),5)*100,3,1)*10;
买:=cross(ab,0);
STICKLINE(买,open,close,5,0),colorFF00FF;
STICKLINE(买,low,HIGH,0.5 ,0 ),colorFF00FF;
QH:=REF(H,2);
QL:=REF(L,2);
QO:=REF(O,2);
QC:=REF(C,2);
ZO:=REF(O,1);
ZC:=REF(C,1);
JYZHK:= ABS(QO-QC)/QO<0.02 AND ZO/ZC>1.02 AND ABS(O-C)/O<0.02 AND C>MA(C,30);
JYZHV:=V<REF(V,1) ;
JYZH:=JYZHK AND JYZHV;
DRAWTEXT(JYZH,LOW/1.01,’★’),COLORRED;
c2:=EMA(a,6);
c3:=EMA(a,5);
c4:=CROSS(c2,c3);
DRAWTEXT(c4,LOW/1.01,’▲’),COLORRED;

同花顺
年认同价:=MA(C,240);
价格中枢:=(SUM(年认同价,0)/(BARSSINCE(年认同价>0)+239));
G:价格中枢*1.2,LINETHICK2,COLOR009900;
G2:价格中枢*1.618,POINTDOT,colorwhite;
G3:价格中枢*1.382,POINTDOT,colorwhite;
G1:价格中枢*0.8,LINETHICK2,COLOR009900;
STICKLINE(G1>0,G1,G,8,0),COLOR5F5F5F;
毛利润率:=ZYYWLR/ZYYWSR;
成长价值:年认同价*(1+毛利润率),coloryellow,LINETHICK1;
收益价值:年认同价+MGSY,colorred,LINETHICK1;
价格中枢,LINETHICK1,COLORFFBB00;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
回调认同:EMA(X,13),COLORFF00FF;
STICKLINE(CLOSE>=OPEN,OPEN,CLOSE,3,1),colorred;
STICKLINE(OPEN>CLOSE,CLOSE,OPEN,3,0 ),COLORFFFF50;
STICKLINE(CLOSE>=OPEN,CLOSE,HIGH,0 ,0 ),colorred;
STICKLINE(CLOSE>=OPEN,OPEN,LOW,0 ,0),colorred;
STICKLINE(OPEN>CLOSE,CLOSE,LOW,0 ,0 ),COLORFFFF50;
STICKLINE(OPEN>CLOSE,OPEN,HIGH,0 ,0 ),COLORFFFF50;
AA:=CLOSE/REF(CLOSE,1)>=1.09;
STICKLINE(AA,OPEN,CLOSE,3,0),coloryellow;
STICKLINE(AA,LOW,HIGH,0 ,0 ),coloryellow;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
m:=CROSS(84,RSI);
DRAWTEXT(m,(HIGH * 1.02),’●’),colorwhite;
M17:EMA(CLOSE,17),colorblue;
ab:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
MAi:=CROSS(ab,0);
STICKLINE(MAi,OPEN,CLOSE,5,0),colorFF00FF;
STICKLINE(MAi,LOW,HIGH,0.5 ,0 ),colorFF00FF;
QH:=REF(H,2);
QL:=REF(L,2);
QO:=REF(O,2);
QC:=REF(C,2);
ZO:=REF(O,1);
ZC:=REF(C,1);
JYZHK:= ABS(QO-QC)/QO<0.02 AND ZO/ZC>1.02 AND ABS(O-C)/O<0.02 AND C>MA(C,30);
JYZHV:=V<REF(V,1) ;
JYZH:=JYZHK AND JYZHV;
DRAWTEXT(JYZH,LOW/1.01,’★’),colorred;
c2:=EMA(a,6);
c3:=EMA(a,5);
c4:=CROSS(c2,c3);
DRAWTEXT(c4,LOW/1.01,’▲’),colorred;
选股公式
年认同价:=ma(c,240);
价格中枢:=(SUM(年认同价,0)/(BARSSINCE(年认同价>0)+239));
G:=价格中枢*1.2;
G1:=价格中枢*0.8;
价格增长因子:=FINANCE(21)/FINANCE(20);
成长价值:=年认同价*(1+价格增长因子);
收益价值:=年认同价+FINANCE(33);
c>g1 and c<价格中枢;

回调到"回调认同"选股
a:=(3*c+l+o+h)/6;
X:=(20*a+19*ref(a,1)+18*ref(a,2)+17*ref(a,3)+16*ref(a,4)+15*ref(a,5)+
14*ref(a,6)+13*ref(a,7)+12*ref(a,8)+11*ref(a,9)+10*ref(a,10)+9*ref(a,11)+8*ref(a,12)
+7*ref(a,13)+6*ref(a,14)+5*ref(a,15)+4*ref(a,16)+3*ref(a,17)+2*ref(a,18)+
ref(a,20))/210;
ma5:=eMA(X,5);
ma13:=eMA(X,13);
TJA:=BETWEEN(L-Ma5,0.01,-0.01);
TJB:=BETWEEN(L-Ma13,0.01,-0.01);
选股:TJA OR REF(TJA,1) OR REF(TJA,2) OR REF(TJA,3) OR TJB OR REF(TJB,1) OR REF(TJB,2) OR REF(TJB,2) OR REF(TJB,3);

排序指标
年认同价:=ma(c,240);
毛利润率:=FINANCE(21)/FINANCE(20);
成长价值:=年认同价*(1+毛利润率);
收益价值:=年认同价+FINANCE(33);
aa:=成长价值-收益价值;
aa;

粉红买点
ab:=sma(ema((c-ref(c,1))/ref(c,1),5)*100,3,1)*10;
买:=cross(ab,0);
买;

★选股公式
QH:=REF(H,2);
QL:=REF(L,2);
QO:=REF(O,2);
QC:=REF(C,2);
ZO:=REF(O,1);
ZC:=REF(C,1);
JYZHK:= ABS(QO-QC)/QO<0.02 AND ZO/ZC>1.02 AND ABS(O-C)/O<0.02 AND C>MA(C,30);
JYZHV:=V<REF(V,1) ;
JYZH:=JYZHK AND JYZHV;
JYZH;

▲选股公式
a:=(3*c+l+o+h)/6;
c2:=EMA(a,6);
c3:=EMA(a,5);
c4:=CROSS(c2,c3);
C4;

财务主图=价值投资(源码+图)大智慧、分析家、通达信、同花顺+选股+排序


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (1)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址