• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

大智慧 跳空缺口 封板率指标

大智慧公式 第一股票指标公式网 2个月前 (11-30) 18次浏览 已收录 0个评论 扫描二维码

一、跳空缺口:

{向下跳空缺口}
I1:=0;
flag1:=0;
while I1<BARSLAST(DISPSTATUS=1)-BARSLAST(DISPSTATUS=2)
DO&nBSp;
IF REF(H,I1)<REF(L,I1+1) AND REF(L,I1+1)>HHV(H,I1+1)
THEN BEGIN FLAG1:=1;
S1:=I1;
I1:=BARSLAST(DISPSTATUS=1); 
END
ELSE I1:=I1+1; 
STICKLINE(FLAG1,REF(L,S1+1),HHV(H,S1+1),(s1+1)*20,0),ColorC0C0C0,ALIGN1,LAYER7;
DRAWTEXT(flag1,REF(L,s1+1),NUMTOSTRN(ref(l,s1+1),2)+'-'+NUMTOSTRN(hhV(h,S1+1),2)),ALIGN2,COLORgreen;

{向上跳空缺口}
I:=0;
flag:=0;
while I<BARSLAST(DISPSTATUS=1)-BARSLAST(DISPSTATUS=2)
DO 
IF REF(L,I)>REF(H,I+1) AND REF(H,I+1)<LLV(LOW,I+1)
THEN BEGIN FLAG:=1;
S:=I;
I:=BARSLAST(DISPSTATUS=1); 
END
ELSE I:=I+1; 
STICKLINE(FLAG,REF(h,S+1),LLV(LOW,S+1),20*(s+1),500),ColorC0C0C0,ALIGN1,LAYER7;
DRAWTEXT(FLAG,REF(H,s+1),NUMTOSTRN(ref(h,s+1),2)+'-'+NUMTOSTRN(LLV(LOW,S+1),2)),ALIGN2,COLORred;

==========================================
二、封板率

rd:=REQSE( 'MARKETTREND_MIN_FBL_SH000001','/markettrend/index/min?obj=SH000001&field=ShiJian,ZuiXinJiaDengYuZhangTingJiaShu,ZuiGaoJiaDengYuZhangTingJiaShu&output=pb&sub=1',1002 );

股票数:=stkindi('SH000001','涨跌家数.上涨家数#MIN1')+stkindi('SH000001','涨跌家数.下跌家数#MIN1')+stkindi('SH000001','涨跌家数.平盘家数#MIN1')+stkindi('SZ399001','涨跌家数.上涨家数#MIN1')+stkindi('SZ399001','涨跌家数.下跌家数#MIN1')+stkindi('SZ399001','涨跌家数.平盘家数#MIN1');
封板家数:FINDSE( 'MARKETTREND_MIN_FBL_SH000001','ZuiXinJiaDengYuZhangTingJiaShu'),colorred,linethick0;
触及涨停:FINDSE( 'MARKETTREND_MIN_FBL_SH000001','ZuiGaoJiaDengYuZhangTingJiaShu'),color4169E1,linethick0;
rd2:=REQSE( 'MARKETTREND_MIN_FBL_SZ399001','/markettrend/index/min?obj=SZ399001&field=ShiJian,ZuiXinJiaDengYuZhangTingJiaShu,ZuiGaoJiaDengYuZhangTingJiaShu&output=pb&sub=1',1002 );
打开家数:触及涨停-封板家数,precis0,colorFF5252,linethick0;
封板率:封板家数/触及涨停*100;
partline(封板率,封板率<50,rgb(0,255,0),封板率>=50 and 封板率<60,rgb(255,255,255),封板率>60,rgb(255,0,0));
强弱系数:封板家数/股票数*10000,linethick0;
70,dotline,colorred;
60,dotline,colorwhite;
50,dotline,colorgreen;


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址