• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

大智慧专做反转与反击的九字K线公式

大智慧公式 第一股票指标公式网 2个月前 (11-30) 16次浏览 已收录 0个评论 扫描二维码

专做反转与反击的九字K线公式

 input:n(20,1,999,1),p(25,1,999,1);
MID :  MA(CLOSE,N);
UPPER: MID + P*STD(CLOSE,N)/10;
LOWER: MID – P*STD(CLOSE,N)/10;
K1:=cyc(1);
K2:=cost(90);
DRAWTEXTREL(800 ,0 ,'今日成本'+': '+numtostrn(k1,2));
DRAWTEXTREL(800 ,100 ,'90%获利价'+': '+numtostrn(k2,2));
drawtextrel(800,200,'获利比例:'+numtostrn(winner(close)*100,2)+'%');
drawtextrel(800,50,'换手率:'+numtostrn(vol/capital*100,2)+'%');
cond1:=sum(vol,barslast(close=llv(c,30)))/capital*100>30;
cond2:=FILTER(cond1,20);//wWw.chNmonEy.com
drawtext(cond2,close,'换手30'),COLORYELLOW;
STICKLINE(C/REF(C,1)>=1.090,O,C,5,0),COLORYELLOW;
攻击迫线:=OPEN>REF(HIGH,1) AND CLOSE>REF(HIGH,1) AND LOW>REF(HIGH,1)  AND HIGH>CLOSE AND REF(CLOSE,1)/REF(CLOSE,2)>=1.09 AND V>REF(V,1);
比翼双飞:=REF(C,2)/REF(C,3)>=1.0977 AND REF(O,1)>REF(H,2) AND REF(L,1)>REF(H,2) AND REF(C,1)>REF(O,1) AND C>REF(C,1) AND L>REF(L,1);
七伤拳:=REF((C-REF(C,1))/REF(C,1)>0.09,6) AND COUNT((C-REF(C,1))/REF(C,1)>0.09,6+1)=1 AND  (HHV(H,6)-REF(C,6))/REF(C,6)*100<25 AND (LLV(L,6)-REF(C,6))/REF(C,6)*100>(5*-1);
喜鹊闹梅:=REF((C-REF(C,1))/REF(C,1)>0.09,3) AND L>REF(C,1) AND ABS(HHV(H,3)-REF(C,3))/REF(C,3)<5 AND ABS(LLV(H,3)-REF(C,3))/REF(C,3)<5 AND LLV(LOW,3)>REF(C,3)*0.9;
牛熊不败:=CROSS(C,MA(C,250))  AND V>1.5*REF(MA(V,5),1) AND C/(REF(C,1)-1)>1.3 AND CLOSE/REF(CLOSE,1)>=1.9;
搓揉线:=REF(O,1)=REF(L,1) AND REF(H,1)/REF(C,1)>1.03 AND REF(C,1)>REF(C,2) AND H=C AND C/L>1.03 AND H>REF(C,1);
黑棒佳丽:=O>MA(C,20) AND (O-C)/O*100>0.01 AND VOL/CAPITAL*100 >=3 AND C>REF(C,1) AND REF(C,1)>REF(C,2) AND HIGH/LOW>=1.05;
绝地反击:=O<REF(L,1) AND C>O AND C<REF(C,1) AND  V>REF(V,1) AND REF(C,1)/REF(C,2)<0.95 AND REF(V,1)<REF(V,2);
吞并反转:=REF(CLOSE,2)/REF(CLOSE,1)>=1.05 AND CLOSE/REF(LOW,1)>=1.05 AND CLOSE>REF(HIGH,1);
DRAWTEXT((攻击迫线 = 1),LOW-0.05,'攻'),LINETHICK2,COLORWHITE;
DRAWTEXT((比翼双飞 = 1),LOW-0.05,'比'),LINETHICK2,COLORYELLOW;
DRAWTEXT((七伤拳 = 1),LOW-0.05,'七'),LINETHICK2,COLORBLUE;
DRAWTEXT((喜鹊闹梅 = 1),LOW-0.05,'喜'),LINETHICK2,COLORRED;
DRAWTEXT((牛熊不败 = 1),LOW-0.05,'牛'),LINETHICK2,COLORFF00CC;
DRAWTEXT((搓揉线 = 1),LOW-0.05,'搓'),LINETHICK2,COLORGREEN;
DRAWTEXT((黑棒佳丽 = 1),LOW-0.05,'黑'),LINETHICK2,COLOR9932CD;
DRAWTEXT((绝地反击 = 1),LOW-0.05,'绝'),LINETHICK2,COLORDB9370;
DRAWTEXT((吞并反转 = 1),LOW-0.05,'吞'),LINETHICK2,COLOR856363;
X00:=(h+c+l)/3;{x01  2.3}
X01:0.3593964336454*X00+0.1061556927386*REF(X00,1)+0.1070368227074*REF(X00,2)+0.1097398807261*REF(X00,3)+0.1111111175094*REF(X00,4)
+0.0636145404474*REF(X00,5)+0.0508294752894*REF(X00,6)+0.0384783039502*REF(X00,7)+0.0261325562838*REF(X00,8)+0.0137868764133*REF(X00,9)+0.0082313208594*REF(X00,10)
+0.0041152371848*REF(X00,11)+0.0013717422447*REF(X00,12),COLORWHITE;
X02:0.0784274314242*X00+0.0847329828021*REF(X00,1)+0.1210677292614*REF(X00,2)
+0.1353723993601*REF(X00,3)+0.1241759542746*REF(X00,4)+0.0609562535048*REF(X00,5)+0.0556154665432*REF(X00,6)+0.0678318871764*REF(X00,7)
+0.0845552153040*REF(X00,8)+0.0797204959788*REF(X00,9)+0.0647990696303*REF(X00,10)+0.0321243550474*REF(X00,11)+0.0106207596927*REF(X00,12),COLORGREEN;
流通盘大小:=FINANCE2(37)/1000000*100;
DRAWTEXTABS(20,20,'总股本:'+NUMTOSTR(FINANCE2(35)/10000 )+'亿'+' 流通股:'+ NUMTOSTR(CAPITAL/1000000)+'亿'),COLORACFFFF;
DRAWTEXTABS(20,35,'上市日期:'+STR(FINANCE2(2))+'日'),ColorACFFFF;
每股收益:=FINANCE2(3);
每股市盈率:=DYNAINFO(39);
每股净资产:=FINANCE2(4);
销售毛利率:=FINANCE2(12);
主营收入同比:=FINANCE2(11);  
净利润同比增长:=FINANCE2(10);
每股公积金:=FINANCE2(7);
每股未分配:=FINANCE2(8);
{DRAWTEXTABS(20,40,'基本面优劣提示:'),COLOR505050;}
DRAWTEXTABS(20,50,'每股收益:'+NUMTOSTRN(每股收益,2)+'元'),COLORACFFFF;
DRAWTEXTABS(20,65,'每股市盈率:'+NUMTOSTRN(每股市盈率,1)+'倍'),COLORACFFFF;
DRAWTEXTABS(20,80,'每股净资产:'+NUMTOSTRN(每股净资产,2)+'元'),COLORACFFFF;
DRAWTEXTABS(20,95,'每股公积金:'+NUMTOSTRN(每股公积金,2)+'元'),ColorACFFFF;
DRAWTEXTABS(20,110,'每股未分配:'+NUMTOSTRN(每股未分配,2)+'元'),ColorACFFFF;
DRAWTEXTABS(20,125,'销售毛利率:'+NUMTOSTRN(销售毛利率,2)+'%'),COLORACFFFF;
DRAWTEXTABS(20,140,'主营收入同比增长:'+NUMTOSTRN(主营收入同比,2)+'%'),COLORACFFFF; 
DRAWTEXTABS(20,155,'净利润同比增长:'+NUMTOSTRN(净利润同比增长,2)+'%'),COLORACFFFF; 
{DRAWTEXTABS(20,80,'换手率高低提示:'),COLOR505050;}
DRAWTEXTABS(20,5,'所属板块:'+BKNAME),COLORACFFFF;


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址