• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

瘦石分时量能源码

飞狐公式 第一股票指标公式网 2个月前 (11-30) 10次浏览 已收录 0个评论 扫描二维码

以下是飞狐瘦石分时量能源码

引用:SS分时量能
 瘦石:=IF(C>REF(C,1),VOL,0);
 x:=(REF(HHV(瘦石,OPENMINUTES(TIME)),239)),LINETHICK1,COLORMAGENTA;
 y:=(REF(HHV(瘦石,OPENMINUTES(TIME)),0)),COLORYELLOW,LineThick0;
昨拉升最高值:x[DATACOUNT];
今拉升最高值:y[DATACOUNT];
攻击力度:今拉升最高值/昨拉升最高值,LineThick0;
 STICKLINE(C>REF(C,1),0,V,0,0),COLOR0000FF;
 STICKLINE(C<REF(C,1),0,V,0,0),COLOR00FF00;
 STICKLINE(C=REF(C,1),0,V,0,0),COLORFFFFFF;
飞狐瘦石头量能:
if datatype>=0 then exit;
 ////////****** 计算指标变换所需的公共数据 *******
rc:=DYNAINFO(3);//前收
q:=datacount;
 hh:=DYNAINFO(5);//最高
LL:=DYNAINFO(6);//最低
f:=max(hh-rc,rc-LL);
 ff:=f/rc*100;//最大半振幅
////////////////////////////////////////////////////////////////
 ////////****** ㈠副图1叠加RSI指标线******(共3个步骤完成指标变换)
//副图1变换所需数据
q1:=rc-f*1.02;//分时副图1最高位置
q2:=rc-2*f*1.016;//分时副图1最低位置,同时也是分时副图2最高位置
{有了Q1、Q2、Q3,叠加副图指标也就容易了}
r:="SS分时量能.昨拉升最高值";
rh:=hhv(r,0);
 rL:=LLv(r,0);
 rb:=(q1-q2)/(rh-rL);
 ry:=(q1+q2-rb*(rh+rL))/2;
 r*rb[q]+ry[q],COLORRED;
画斜线(r*rb[q]+ry[q],h,0,1 ,1),COLORBLUE;


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址