• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

飞狐趋势决策系统源码

飞狐公式 第一股票指标公式网 2个月前 (11-30) 16次浏览 已收录 0个评论 扫描二维码

以下是飞狐趋势决策系统源码附图(无源码的请下载附件导入)

DIFF:=(EMA(CLOSE,9) – EMA(CLOSE,12));
DEA:=EMA(DIFF,9),COLORFF00FF,LINETHICK1;
CD:=2*(DIFF-DEA),COLORSTICK,LINETHICK1;
起涨:IF(DIFF<0,0,20),COLORYELLOW,LINETHICK2;
控盘:=(EMA(EMA(CLOSE,9),9)-REF(EMA(EMA(CLOSE,9),9),1))/REF(EMA(EMA(CLOSE,9),9),1)*400;
A10:=CROSS(控盘,0);
低位控盘:IF(A10,70,0),LINETHICK1,COLORYELLOW;
DRAWTEXT(低位控盘,70,'←低位控盘'),COLORFF00FF,LINETHICK2,COLORYELLOW; 
A:=(3*CLOSE+LOW+OPEN+HIGH)/6;
D1:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)
+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/211;
D2:=EMA(D1,2);
D3:=EMA(D2,2);
K1:=EMA(D3,2);
波段买:IF(CROSS(D1,K1),60,0),COLOR0099FF,COLORCYAN;
DRAWTEXT(波段买,60,'←波段买'),COLORCYAN;
BIAS20:=(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100;
Q7:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
持股:=BARSLAST((BARSLAST(BIAS20>0 AND REF(BIAS20,1)>0))>0);
持股天数:BARSLAST((BARSLAST(BIAS20>0 AND REF(BIAS20,1)>0))>0),STICK,COLORCYAN;
STICKLINE(持股天数>0,持股天数+0,0,4,0),COLORCYAN;
VAR11:=EMA(CLOSE,8); 
VAR22:=EMA(VAR11,20);
VAR33:=CROSS(VAR11,VAR22); 
VAR44:=VAR11< EMA(CLOSE,120); 
黑马: IF(VAR33 AND VAR44,50,0), , COLORGREEN;
DRAWTEXT(黑马,50,'←黑马'),COLORFF00FF,LINETHICK2;
QQ:=BARSLAST(CROSS(C,MA(C,9)));
WW:=BARSLAST(CROSS(MA(C,9),C));
N5:=BARSLAST(CROSS(C,MA(C,26)));
N6:=BARSLAST(CROSS(MA(C,26),C));
启动:IF(N5<N6,N5+1,0),COLORRED,LINETHICK2;
K2:=EMA(C,5),COLORFFFF00;
K3:=EMA(C,10),COLORFFFF00;
K5:=EMA(C,30),COLORFFFF00;KK5:=EMA(INDEXC,30),COLORFFFF00;
K6:=2*(K2-K5);K7:=2*(K2-K3);K8:=2*(K7+K6),COLORRED;
STICKLINE(CROSS(K8,0),20,0,4,0) ,COLORRED;
红柱出现:CROSS(K8,0),COLORRED;
HZ:=EMA(CLOSE,13); 
短波:=EMA(HZ,1); 
中波:=EMA(HZ,26); 
均线148天:=EMA(C,148); 
成本:=SUM(AMOUNT,0)/SUM(VOL,0)/100; 
HZ2:=EMA(HZ,8); 
中短波选股:CROSS(短波,HZ2),COLORYELLOW;
STICKLINE(CROSS(短波,HZ2),30,20,4,0) ,COLORYELLOW;
ZJ:=(C+C+L+H)/4;
VAR3:= REF(MA(ZJ,5),1);
A1:=SMA(MAX(C-VAR3,0),9,1)/SMA(ABS(C-VAR3),9,1)*100;
B1:=100*(HHV(H,14)-C)/(HHV(H,14)-LLV(L,14));
显黄试买:STICKLINE(A1-B1>0 ,35,40,4,0),COLORYELLOW;
VAR1:=(HHV(H,13)-LLV(L,13));
VAR2:=(HHV(H,13)-C);
VAR3:=(C-LLV(L,13));
VAR4:=VAR2/VAR1*100-70;
VAR5:=(C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100;
VAR6:=(2*C+H+L)/4;
VAR7:=SMA((VAR3/VAR1*100),3,1);
VAR8:=LLV(L,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:=IF(VAR9>100,VAR9-100,0);
VARA:=HHV(H,34);
防线:=EMA((VAR6-VAR8)/(VARA-VAR8)*100,8);
BB:=EMA(防线,5);
显红试买:STICKLINE(防线>0 AND 防线-BB>=0,30,35,4,0),COLORRED;
加权移平均:=WMA(C,5);
A1:=EMA(加权移平均,3);
A2:=EMA(加权移平均,5) ;
A3:=EMA(加权移平均,7);
A4:=EMA(加权移平均,9);
A5:=EMA(加权移平均,11);
A:=BARSLAST(CROSS(A5,A1));
B:=BARSLAST(CROSS(A1,A5));
AA:=BARSLAST(CROSS(A,B));
BB:=BARSLAST(CROSS(B,A));
STICKLINE(B>A,-1*BB,0,10,0),COLORCYAN;
STICKLINE(C>=A5 AND B>A,-1*BB,0,10,0),COLORBLUE;
STICKLINE(CROSS(REF(A1,1),A1) AND B>A,-1*BB,0,10,0),COLORWHITE;
DRAWTEXTEX(1,1,20,380,' 耐 心 等 待 时 机'),COLORGREEN;
DRAWTEXTEX(1,1,20,150,'决 策 在 人 脑   严 格 执 行 纪 律'),COLORGREEN;


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址