• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

「 量化」macd放量打拐战法图

通达信公式 第一股票指标公式网 2个月前 (11-30) 102次浏览 已收录 0个评论 扫描二维码

量化macd放量打拐战法图

SHORT:=12;LONG:=26;M:=9;C,COLORBLACK;DIFF :=EMA(CLOSE,SHORT) – EMA(CLOSE,LONG);DEA :=EMA(DIFF,M);MACD :=2*(DIFF-DEA);JCSC:=(M-1)/(M+1)*DEA/(1-2/(M+1));{计算出金叉死叉时的DIFF值}DD:=(MACD/2+(DEA*(M-1)/(M+1)))/(1-2/(M+1));{计算出明日MACD=MACD时的DIFF值}DIF拐点:(DIFF*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*EMA(C,SHORT)+(SHORT+1)*(LONG-1)*EMA(C,LONG))/(2*((LONG+1)-(SHORT+1)));{计算今日DIFF=DIFF的对应股价}量化金叉死叉:(JCSC*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*EMA(C,SHORT)+(SHORT+1)*(LONG-1)*EMA(C,LONG))/(2*((LONG+1)-(SHORT+1)));{计算金叉死叉的对应股价}量化变向:(DD*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*EMA(C,SHORT)+(SHORT+1)*(LONG-1)*EMA(C,LONG))/(2*((LONG+1)-(SHORT+1)));{计算MACD柱体变向时的对应股价};IF(DIF拐点>=金叉死叉,DIF拐点,DRAWNULL),COLORRED,LINETHICK2;{171415.com-专业指标公式网 http://www.171415.com}

IF(DIF拐点<金叉死叉,DIF拐点,DRAWNULL),COLORGREEN,LINETHICK2;IF(柱体变向>=金叉死叉,柱体变向,DRAWNULL),COLORRED,LINETHICK2;IF(金叉死叉>=柱体变向,金叉死叉,DRAWNULL),COLORBLUE,LINETHICK2;

量化:http://www.171415.com


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址