• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

通达信比较好用的CCI指标公式

通达信公式 第一股票指标公式网 2周前 (02-23) 7次浏览 已收录 0个评论 扫描二维码

N1:=14;
N:=3;
M:=8;
LC := REF(CLOSE,1);
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),LINETHICK1;
TY:=CCI;
A1:=REF(TY,N)=HHV(TY,2*N+1); B1:=FILTER(A1,N); C1:=BACKSET(B1,N+1); D1:=FILTER(C1,N);{高}
A2:=REF(TY,N)=LLV(TY,2*N+1); B2:=FILTER(A2,N); C2:=BACKSET(B2,N+1); D2:=FILTER(C2,N);{低}
H1:=(D1 AND NOT(D2)) OR BARSTATUS=2 OR BARSCOUNT(C)=1;
L1:=(D2 AND NOT(D1)); H2:=D1 AND NOT(D2);
X1:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); LD:=I1>REF(I1,1);{过滤后低点}
L2:=LD OR BARSTATUS=2 OR BARSCOUNT(C)=1;
X2:=REF(BARSLAST(L2),1)+1; F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
G2:=F2>REF(F2,1); I2:=BACKSET(G2,2); HD:=I2>REF(I2,1);{过滤后高点}
R1:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1); S1:=R1>REF(R1,1); {前一高}
T1:=BACKSET(BARSTATUS=2,BARSLAST(LD)+1); U1:=T1>REF(T1,1); {前一低}
R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2); S2:=R2>REF(R2,1); {前二高}
T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2); U2:=T2>REF(T2,1); {前二低}
T3:=BACKSET(U2,REF(BARSLAST(LD),1)+2); U3:=T3>REF(T3,1); {前三低}
T4:=BACKSET(U3,REF(BARSLAST(LD),1)+2); U4:=T4>REF(T4,1); {前四低}
R3:=BACKSET(S2,REF(BARSLAST(HD),1)+2); S3:=R3>REF(R3,1); {前三高}
R4:=BACKSET(S3,REF(BARSLAST(HD),1)+2); S4:=R4>REF(R4,1); {前四高}
压一:DRAWLINE(S2,TY,S1,TY,1),COLOR007B00,LINETHICK2; {★压力1:}
撑一:DRAWLINE(U2,TY,U1,TY,1),POINTDOT,COLORFF71FF,LINETHICK2;{★支撑1:}
压二:DRAWLINE(S3,TY,S2,TY,1),COLORFFFF09,LINETHICK2; {★压力2:}
撑二:DRAWLINE(U3,TY,U2,TY,1),POINTDOT,COLORYELLOW,LINETHICK2;{★支撑2:}
压三:DRAWLINE(S4,TY,S3,TY,1),COLORFF5959,LINETHICK2;{★压力3:}
撑三:DRAWLINE(U4,TY,U3,TY,1),POINTDOT,COLOR4D87FF,LINETHICK2;{★支撑3:};
{CCI画线}
EM10:EMA(CCI,10),COLOR07ECEE;
EM20:EMA(CCI,20),COLOR00C500;STICKLINE(CROSS(CCI,EM10),-198,-160,2,0),COLOR8000FF;{金叉画线}
STICKLINE(CROSS(EM10,CCI),198,160,2,0),COLOR00FF00;{死叉画线}
STICKLINE(CROSS(EM10,EM20),0+15,0-15,1,0);
STICKLINE(CROSS(EM20,EM10),0+15,0-15,1,0);上影线:H-MAX(O,C),LINETHICK0,COLORFF00FF;
下影线:MIN(O,C)-L,LINETHICK0,COLOR00FF00;
高低:H-L,LINETHICK0,COLORC0C0C0;
实体:C-O,LINETHICK0,COLORFFFFFF;200,COLOR00FF00;
100,COLORWHITE, POINTDOT;
0,COLOR8000FF;
-100,COLORWHITE, POINTDOT;
-200,COLOR00FF00;
{前期高低点——虚线}
QS:=HHV(CCI,13);
RS:=LLV(CCI,13);
VAR1:=BACKSET(REF(QS,2)=HHV(QS,5),3);
VAR2:=CROSS(VAR1,0.9);
VAR3:=BACKSET(REF(RS,2)=LLV(RS,5),3);
VAR4:=CROSS(VAR3,0.9);
压力:REF(QS,BARSLAST(VAR2)),POINTDOT,COLOR00FF00;
STICKLINE(CCI,REF(QS,BARSLAST(VAR2)),REF(QS,BARSLAST(VAR2)),5,0),COLOR00FF00;
支撑:REF(RS,BARSLAST(VAR4)),POINTDOT,COLORFF71FF{COLOR0087FF};
STICKLINE(CCI,REF(RS,BARSLAST(VAR4)),REF(RS,BARSLAST(VAR4)),5,0),COLOR0087FF;
{RSI线变色}
IF(CCI>REF(CCI,1),CCI,DRAWNULL),LINETHICK2;
IF(CCI<REF(CCI,1),CCI,DRAWNULL),LINETHICK2;
{右边▲▼–只是比较与前一日的大小,无判断方面的意义}
LC111:=REF(CLOSE,1);
RS1:=SMA(MAX(CLOSE-LC111,0),M,1)/SMA(ABS(CLOSE-LC111),M,1)*100;
ATR:=MA(MAX(MAX((RS1-RS1),ABS(REF(RS1,1)-RS1)),ABS(REF(RS1,1)-RS1)),15);
VM:=MA(RS1,N1);
DRAWTEXT(BARSTATUS=2 AND CCI>REF(CCI,1),VM, ‘▲’),COLORRED,LINETHICK2;
DRAWTEXT(BARSTATUS=2 AND CCI<REF(CCI,1),VM, ‘▼ ‘),COLOREEEE00,LINETHICK2;
{笑脸+哭脸【无未来函数】}
OBV:=CCI;
DRAWICON(D1,OBV{*1.05},2);{哭脸}
DRAWICON(D2,OBV,1);{笑脸}
{顶底柱【副图】无未来函数}
N11:=9;
M11:=3;
快线:(CLOSE- LLV(LOW,N11))/(HHV(HIGH,N11)-LLV(LOW,N11))*100,COLORRED,LINETHICK0;
慢线:SMA(快线,M11,1),LINETHICK0;
BB:=IF(BARSLAST(CROSS(慢线,快线))>=3 AND CROSS(快线,慢线) AND 慢线<30,20,0);
STICKLINE(BB,-30,-55,7,1),COLORYELLOW,LINETHICK3;{抄底–黄柱}
DRAWTEXT(BB>0,50,’B’),COLORF5F5F5,LINETHICK6;
AA:=IF(BARSLAST(CROSS(快线,慢线))>=4 AND CROSS(慢线,快线) AND 快线>50,20,0);
STICKLINE(AA,60,35,7,1),COLOR00FF00,LINETHICK3;{逃顶–綱柱};
DRAWTEXT(AA>0,45,’S’),COLORF5F5F5,LINETHICK6;


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址