• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

通达信多指标趋势指标公式

通达信公式 第一股票指标公式网 3周前 (03-19) 9次浏览 已收录 0个评论 扫描二维码

LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*400-200;
DRAWBAND(RSI1,RGB(180,140,10),-60,RGB(130,130,130));
RSI:SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100,NODRAW;
DI:=(EMA(CLOSE,12) – EMA(CLOSE,26))*100;
DE:=EMA(DI,9);
MACD:=2*(DI-DE);
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*400-200;
K1:=SMA(RSV,3,1),COLORMAGENTA,LINETHICK2;
D1:=SMA(K1,3,1),COLORGREEN,NODRAW;
J1:=3*K1-2*D1,COLORYELLOW,LINETHICK2;
DRAWBAND(K1,RGB(0,50,224),J1,RGB(225,50,240));
DRAWBAND(D1,RGB(0,224,224),K1,RGB(255,255,0));
DIFF:(EMA(CLOSE,12) – EMA(CLOSE,26)),COLORBB0000,NODRAW;
DEA:EMA(DIFF,9),COLORWHITE,NODRAW;
RSV1:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K:SMA(RSV1,3,1),COLOR330700,NODRAW;
D:SMA(K,3,1),COLORCYAN,NODRAW;
J:3*K-2*D,COLORMAGENTA,NODRAW;
{红柱}
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,3,0),COLOR0000AA;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,2.7,0),COLOR0000BB;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,2.3,0),COLOR0000CC;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,2,0),COLOR0000CC;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,1.6,0),COLOR0000DD;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,1.2,0),COLOR0000EE;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,0.8,0),COLOR0000FF;
{STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,0.5,0),COLORRED;}
{黄柱}
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,3,0),COLOR0090FF;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,2.7,0),COLOR009FFF;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,2.3,0),COLOR00A6FF;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,2,0),COLOR00B5FF;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,1.6,0),COLOR00C4FF;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,1.2,0),COLOR00D3FF;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,0.8,0),COLOR00E2FF;
{STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,0.5,0),COLOR00FFFF;}
{蓝柱}
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,3,0),COLORFF0000;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,2.7,0),COLORFF3300;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,2.3,0),COLORFF5500;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,2,0),COLORFF7700;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,1.6,0),COLORFF9900;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,1.2,0),COLORFFBB00;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,0.8,0),COLORFFDD00;
{STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,0.5,0),COLORFFFF00;}
{粉柱}
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,3,0),COLORFF00A9;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,2.7,0),COLORFF00A1;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,2.3,0),COLORFF00AA;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,2,0),COLORFF00BB;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,1.6,0),COLORFF00CC;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,1.2,0),COLORFF00DD;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,0.8,0),COLORFF00EE;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,0.5,0),COLORFF00FF;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),LINETHICK2,COLORGREEN;
DRAWICON(CROSS(K1,D1),D1,1);
DRAWICON(CROSS(D1,K1),D1,2);
IF(DI>=DE OR DI<DE,DI,DRAWNULL),COLORBB0000,LINETHICK2;
IF(DI>=DE OR DI<DE,DE,DRAWNULL),COLORWHITE,LINETHICK1;
200,COLORGREEN,POINTDOT;
150,COLORWHITE,POINTDOT;
100,COLORWHITE,POINTDOT;
0,COLORGRAY,LINETHICK2;
-100,COLORWHITE,POINTDOT;
-150,COLORWHITE,POINTDOT;
-200,COLORRED,POINTDOT;


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址