• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

诺相惜主图指标公式源码

通达信公式 第一股票指标公式网 3周前 (03-25) 89次浏览 已收录 0个评论 扫描二维码

诺相惜主图指标 源码 通达信 贴图
诺相惜主图:MA(CLOSE,20) LINETHICK2,NODRAW;
大压线:MA(REF(HHV(C,22),1),2),COLORBLUE,,LINETHICK3;
IF((大压线) > (REF(大压线,1)),大压线,DRAWNULL),COLORGREEN,LINETHICK3;
诺相惜:诺相惜主图-2*STD(CLOSE,20),COLORGREEN,LINETHICK3;
多: IF(诺相惜>=REF(诺相惜,1),诺相惜,DRAWNULL),COLORRED,LINETHICK3;
空:IF(REF(诺相惜,1)>诺相惜,诺相惜,DRAWNULL),COLORGREEN,LINETHICK3;
XZ_1:=ABS(((3.48*CLOSE+HIGH+LOW+OPEN)/5-EMA(CLOSE,20))/EMA(CLOSE,20));
XZ_2:=DMA((2.15*CLOSE+LOW+HIGH+OPEN)/5,XZ_1);
XZ_3:=EMA(XZ_2,200)*1.26;
XZ_4:=EMA(XZ_2,200)*1.18;
XZ_5:=MA((LOW+HIGH+CLOSE)/3,5);
XZ_6:=HHV(XZ_5,60);
XZ_7:=IF(XZ_6>REF(XZ_6,1),XZ_6,DRAWNULL);
XZ_8:=CLOSE*VOL;
XZ_9:=EMA((EXPMA(XZ_8,3)/EXPMA(VOL,3)+EXPMA(XZ_8,6)/EXPMA(VOL,6)+EXPMA(XZ_8,12)/EXPMA(VOL,12)+EXPMA(XZ_8,24)/EXPMA(VOL,24))/4,13);
XZ_10:=1.03*XZ_9;
XZ_11:=1.13*XZ_9;
XZ_12:=MIN(XZ_7,XZ_3);
XZ_13:=MIN(XZ_10,XZ_3);
XZ_14:=MIN(XZ_7,XZ_4);
XZ_15:=MIN(XZ_10,XZ_4);
XZ_16:=CLOSE/REF(CLOSE,1)>1.03 AND CLOSE=HIGH;
XZ_17:=CROSS(CLOSE,XZ_11) AND XZ_16;
DRAWICON(XZ_17,LOW*0.86,5);
{DRAWTEXT(XZ_17,LOW*0.86,’ 90%吃肉’),COLORYELLOW;}
XA_17:=IF(REF(CLOSE,1)*1.1-CLOSE<0.01,1,0);
STICKLINE(XA_17,OPEN,CLOSE,4,0),COLORRED;
STICKLINE(XA_17,OPEN,CLOSE,3,0),COLORYELLOW;
STICKLINE(XA_17,HIGH,LOW,0,0),COLORYELLOW;
XA_22:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,23))/EMA(CLOSE,23));
XA_123:=DMA((2.15*CLOSE+LOW+HIGH)/4,XA_22);
XA_124:=EMA(XA_123,200)*1.118;
XA_125:=EMA(XA_123,200)*1.118;
XA_26:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>8;
XA_27:=CROSS(CLOSE,XA_124) AND XA_26;
JJ:=CLOSE;J1:=MA(JJ,5);
J6:=MA(JJ,250);DRAWTEXT(ISLASTBAR,J1,’1′),COLORWHITE;
年线:J6,LINETHICK1,COLORWHITE,DOTLINE;
DRAWTEXT_FIX(1,0.9,0.98,0,EXTERNSTR(0,2)),COLORWHITE;
{K线九转序列数}
周期上数:=IF(PERIOD=5 OR PERIOD=6 OR PERIOD=7 OR PERIOD=8,1.015,IF(PERIOD=4,1.006,IF(PERIOD=3,1.004,IF(PERIOD=2,1.002,IF(PERIOD=1,1.001,IF(PERIOD=0,1.001,DRAWNULL))))));
周期下数:=IF(PERIOD=5 OR PERIOD=6 OR PERIOD=7 OR PERIOD=8,0.993,IF(PERIOD=4,0.994,IF(PERIOD=3,0.995,IF(PERIOD=2,0.996,IF(PERIOD=1,0.997,IF(PERIOD=0,0.998,DRAWNULL))))));
买入起点:=REF(CLOSE,1)>REF(CLOSE,5) AND CLOSE<REF(CLOSE,4) NODRAW;
卖出起点:=REF(CLOSE,1)<REF(CLOSE,5) AND CLOSE>REF(CLOSE,4) NODRAW;
买起至今:=BARSLAST(买入起点)+1 NODRAW;
卖起至今:=BARSLAST(卖出起点)+1 NODRAW;
后买终值:=CONST(买起至今) NODRAW;
后卖终值:=CONST(卖起至今) NODRAW;
{DRAWTEXT(买入起点 AND CURRBARSCOUNT=后买终值,HIGH*周期上数,’空’) COLORBLUE;
DRAWTEXT(卖出起点 AND CURRBARSCOUNT=后卖终值,LOW*周期下数,’多’) COLORRED;}
空前置:BACKSET(买入起点 AND CURRBARSCOUNT=后买终值,TOTALBARSCOUNT-CURRBARSCOUNT) NODRAW;
多前置:BACKSET(卖出起点 AND CURRBARSCOUNT=后卖终值,TOTALBARSCOUNT-CURRBARSCOUNT) NODRAW;
{///////////////////////////////////}
买入低四:=CLOSE<REF(CLOSE,4) NODRAW;
买低计数:=BARSLASTCOUNT(买入低四) NODRAW;
买十计数:=BARSLASTCOUNT(买低计数>=10) NODRAW;
买十九计数:=BARSLASTCOUNT(买低计数>=19) NODRAW;
买二八计数:=BARSLASTCOUNT(买低计数>=28) NODRAW;
买三轮回值:=IF(买低计数<=9 AND 买低计数>=1,买低计数,IF(买低计数<=18 AND 买低计数>=1,买十计数,IF(买低计数<=27 AND 买低计数>=1,买十九计数,IF(买低计数<=36 AND 买低计数>=1,买二八计数,-100)))) NODRAW;
买中断时:=BARSLAST(买低计数=0 AND REF(买低计数,1)>0) NODRAW;
STICKLINE(买中断时=0 AND CURRBARSCOUNT=后买终值,O,C,3,0) COLORYELLOW;
买断距今:=BARSNEXT(买中断时=0) NODRAW;
买九距今:=IF(买三轮回值>=1,BARSLAST(买三轮回值=9),DRAWNULL) NODRAW;
买九最大:=REFX(HHV(买三轮回值,买中断时),买断距今-1) NODRAW;
买断过滤:=BACKSET(买中断时=0,REF(买九距今,1)+1) NODRAW;
DRAWNUMBER(买低计数>=1 AND 买断过滤=0 AND (买九最大<=8)=0 AND 空前置=0,LOW*周期下数,买三轮回值) COLORBLUE;
DRAWNUMBER(买低计数>=1 AND 买断过滤=0 AND (REFX(空前置,1)=0 OR ISLASTBAR),LOW*周期下数,买三轮回值) COLORBLUE;
DRAWNUMBER(买三轮回值=9 AND 买断过滤=0,LOW*周期下数,买三轮回值) COLORGREEN;
{/////////////////////////////////}
卖出低四:=CLOSE>REF(CLOSE,4) NODRAW;
卖低计数:=BARSLASTCOUNT(卖出低四) NODRAW;
卖十计数:=BARSLASTCOUNT(卖低计数>=10) NODRAW;
卖十九计数:=BARSLASTCOUNT(卖低计数>=19) NODRAW;
卖三轮回值:=IF(卖低计数<=9 AND 卖低计数>=1,卖低计数,IF(卖低计数<=18 AND 卖低计数>=1,卖十计数,IF(卖低计数<=27 AND 卖低计数>=1,卖十九计数,-100))) NODRAW;
卖中断时:=BARSLAST(卖低计数=0 AND REF(卖低计数,1)>0) NODRAW;
STICKLINE(卖中断时=0 AND CURRBARSCOUNT=后卖终值,O,C,3,0) COLORBLUE;
卖断距今:=BARSNEXT(卖中断时=0) NODRAW;
卖九距今:=IF(卖三轮回值>=1,BARSLAST(卖三轮回值=9),DRAWNULL) NODRAW;
卖九最大:=REFX(HHV(卖三轮回值,卖中断时),卖断距今-1) NODRAW;
卖断过滤:=BACKSET(卖中断时=0,REF(卖九距今,1)+1) NODRAW;
DRAWNUMBER(卖低计数>=1 AND 卖断过滤=0 AND (卖九最大<=8)=0 AND 多前置=0,HIGH*周期上数,卖三轮回值) COLORMAGENTA;
DRAWNUMBER(卖低计数>=1 AND 卖断过滤=0 AND (REFX(多前置,1)=0 OR ISLASTBAR),HIGH*周期上数,卖三轮回值) COLORMAGENTA;
DRAWNUMBER(卖三轮回值=9 AND 卖断过滤=0,HIGH*周期上数,卖三轮回值) COLORRED;
{四前线:IF(CURRBARSCOUNT<=5,CONST(REF(CLOSE,4)),DRAWNULL) COLORBLUE LINETHICK3;
五前线:IF(CURRBARSCOUNT<=6,CONST(REF(CLOSE,5)),DRAWNULL) COLORMAGENTA LINETHICK3;}
{多头信号计算部分}
DRAWTEXT(空前置=0 AND 卖出起点 AND REF(买三轮回值,1)=9,LOW*周期下数,’9多’) COLORRED;
DRAWTEXT(空前置=0 AND 卖出起点 AND REF(买三轮回值,1)=8,LOW*周期下数,’8多’) COLORRED;
DRAWTEXT(空前置=0 AND 卖出起点 AND REF(买三轮回值,1)=7,LOW*周期下数,’7多’) COLORRED;
DRAWTEXT(空前置=0 AND 卖出起点 AND REF(买三轮回值,1)=6,LOW*周期下数,’6多’) COLORRED;
DRAWTEXT(空前置=0 AND 多前置=1 AND 卖出起点 AND REF(买三轮回值,1)=5,LOW*周期下数,’5多’) COLORRED;
DRAWTEXT(空前置=0 AND 卖出起点 AND REF(买三轮回值,1)=4,LOW*周期下数,’4多’) COLORRED;
DRAWTEXT(空前置=0 AND 卖出起点 AND REF(买三轮回值,1)=3,LOW*周期下数,’3多’) COLORRED;
DRAWTEXT(空前置=0 AND 卖出起点 AND REF(买三轮回值,1)=2,LOW*周期下数,’2多’) COLORRED;
DRAWTEXT(空前置=0 AND 卖出起点 AND REF(买三轮回值,1)=1,LOW*周期下数,’1多’) COLORRED;
{空头信号计算部分}
DRAWTEXT(多前置=0 AND 买入起点 AND REF(卖三轮回值,1)=9,HIGH*周期上数,’9空’) COLORBLUE;
DRAWTEXT(多前置=0 AND 买入起点 AND REF(卖三轮回值,1)=8,HIGH*周期上数,’8空’) COLORBLUE;
DRAWTEXT(多前置=0 AND 买入起点 AND REF(卖三轮回值,1)=7,HIGH*周期上数,’7空’) COLORBLUE;
DRAWTEXT(多前置=0 AND 买入起点 AND REF(卖三轮回值,1)=6,HIGH*周期上数,’6空’) COLORBLUE;
DRAWTEXT(多前置=0 AND 买入起点 AND REF(卖三轮回值,1)=5,HIGH*周期上数,’5空’) COLORBLUE;
DRAWTEXT(多前置=0 AND 买入起点 AND REF(卖三轮回值,1)=4,HIGH*周期上数,’4空’) COLORBLUE;
DRAWTEXT(多前置=0 AND 买入起点 AND REF(卖三轮回值,1)=3,HIGH*周期上数,’3空’) COLORBLUE;
DRAWTEXT(多前置=0 AND 买入起点 AND REF(卖三轮回值,1)=2,HIGH*周期上数,’2空’) COLORBLUE;
DRAWTEXT(多前置=0 AND 买入起点 AND REF(卖三轮回值,1)=1,HIGH*周期上数,’1空’) COLORBLUE;

M89:=MA(CLOSE,89),COLORMAGENTA,LINETHICK2;
M144:=MA(CLOSE,144),COLORBROWN,LINETHICK2;
M233:=MA(CLOSE,233),COLORYELLOW,LINETHICK2;
M377:=MA(CLOSE,377),COLORCYAN,LINETHICK2;
M450:=MA(CLOSE,450),COLORGREEN,LINETHICK2;
M610:=MA(CLOSE,610),COLORRED,LINETHICK2;
A90:=(MA(COST(90),6)),DOTLINE,COLOR808040;
A70:=(MA(COST(70),6)),DOTLINE,COLOR808040;
M20:=MA(CLOSE,20),COLORWHITE,LINETHICK2;T5:=REF(HHVBARS(HIGH,60),15)+15;
T60:=REF(HIGH,T5),COLORRED,NODRAW;
STICKLINE(BARSTATUS=2,T60,T60,2000,1),COLORBLUE;
DRAWTEXT(BARSTATUS=2,T60,’小美人’),COLORYELLOW;

STICKLINE(XA_27,CLOSE,OPEN,3.2,0),COLOR0077FF;
STICKLINE(XA_27,CLOSE,OPEN,2.5,0),COLOR0099FF;
STICKLINE(XA_27,CLOSE,OPEN,1.9,0),COLOR00BBFF;
STICKLINE(XA_27,CLOSE,OPEN,1.2,0),COLOR00DDFF;
STICKLINE(XA_27,CLOSE,OPEN,0.3,0),COLORYELLOW;
T1:=SMA(MAX(C-REF(C,1),0),24,1)/SMA(ABS(C-(REF(C,1))),24,1)*100>65 ;
VAR0:=((EMA(C,5))*7+(EMA(C,10))*3)/10;
VAR12:=MA(C,26)+2*(STD(C,26));
VAR18:=T1 AND VAR0>EMA(C,13) AND EMA(C,13)>EMA(C,55) AND VAR12>REF(VAR12,1) AND (C>(EMA((H+L+C)/3,13))) AND MA(C,5)>MA(C,10)
AND ((CROSS(HHV(C,5),(MA(H,10))*(1+5/(100)))) AND ((((C-(REF(C,1)))/(REF(C,1)))*(100))>(6.5)));
DRAWTEXT((VAR18)>0,L*0.98,’▲追击’),LINETHICK1,COLORYELLOW;
DRAWTEXT(((((C-(REF(C,1)))/(REF(C,1)))*(100))>(5.5)) AND (CROSS((L/((H+REF(C,1)+O)/3))*C,EMA((EMA(C,9))*(1.14),5))),EMA(L-(0.0),1),’★涨’),COLOR00FF00;
涨:=((C-REF(C,3))/REF(C,3)*100) >6.8;
STICKLINE(涨,O,C,0.5,0),COLORRED;
涨停:=((C-REF(C,1))/REF(C,1)*100) >9.7;
STICKLINE(涨停,O,(C-O)/2+O,3.1,0),COLOR660066;
STICKLINE(涨停,O,(C-O)/2+O,2.6,0),COLOR7D007D;
STICKLINE(涨停,O,(C-O)/2+O,2.1,0),COLOR990099;
STICKLINE(涨停,O,(C-O)/2+O,1.6,0),COLORBD00BD;
STICKLINE(涨停,O,(C-O)/2+O,1.0,0),COLORMAGENTA;
STICKLINE(涨停,O,(C-O)/2+O,0.5,0),COLORMAGENTA;
持股:IF(SAR(10,2,20)<=L,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORMAGENTA,LINETHICK3;
N:=20;
N1:=7;
N2:=69;
VAR5:=((REF(HIGH,1)+REF(LOW,1))/(2))*(T1);
VAR6:=MA(CLOSE,N)+((2)*(STD(CLOSE,N)))*(T1);
VAR7:=REF(CLOSE,1);
VAR8:=((SMA(MAX(CLOSE-VAR7,0),N1,1))/(SMA(ABS(CLOSE-VAR7),N1,1)))*(100);
VAR9:=CROSS(N2,VAR8);
VARA:=(FILTER(VAR9,4))*(T1);
VARB:=((2)*(CLOSE)+HIGH+LOW)/(4);
VARC:=LLV(LOW,34);
VARD:=HHV(HIGH,34);
MA18:=MA(C,18);
VAR1:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
VAR2:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);
VAR3:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
A:=(3*C+L+O+H)/6;
VAR4:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
CB:=EMA(VAR4,13);
JRH:=HHV(C,2);
JRL:=LLV(C,2);
VAR01:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR02:=(REF(VAR01,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR03:=(REF(VAR02,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR04:=(REF(VAR03,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR05:=(REF(VAR04,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR06:=(REF(VAR05,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR07:=(REF(VAR06,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR08:=(REF(VAR07,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR09:=(REF(VAR08,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA1:=(REF(VAR09,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB1:=(REF(VARA1,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC1:=(REF(VARB1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD1:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2)); {GUPIAOFF.COM}
VARE:=(REF(VARD1,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR010:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR011:=(REF(VAR010,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR012:=(REF(VAR011,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR013:=(REF(VAR012,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR014:=(REF(VAR013,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR015:=(REF(VAR014,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR016:=(REF(VAR015,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR017:=(REF(VAR016,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR018:=(REF(VAR017,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR019:=((REF(VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,1)) AND VAR01);
VAR1A:=((REF(VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,1)) AND VARD);
VV2:=REF(CLOSE,1);
VV3:=SMA((CLOSE-VV2),6,1)/SMA(ABS(CLOSE-VV2),6,1)*100;
DRAWICON(REF(VV3,1)>81 AND VV3<80,HIGH,2);
VF1:=MA(CLOSE,60)-MA(CLOSE,5)/3.2;
DRAWTEXT(IF(CLOSE<VF1 AND VOL/240>MA(VOL,5)/240 AND CLOSE>=REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW,’☆’),COLORRED;
VARA111:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
VARB111:=EMA(0.667*REF(VARA,1)+0.333*VARA,5);
DRAWTEXT(IF(VOL>=1.3*MA(VOL,5) AND COUNT(VARA>=VARB AND VARA<-17,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW,’★注意买入’);
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARR1),HIGH,2);
VAR1111:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VAR1112:=REF(VAR1,1);
VAR1113:=SMA(MAX(VAR1-VAR2,0),10,1)/SMA(ABS(VAR1-VAR2),10,1)*100;
HY3:=IF(COUNT(VAR3<20,5)>=1 AND COUNT(VAR1=LLV(VAR1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址