• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

时间窗变盘主图指标公式源码

通达信公式 第一股票指标公式网 2周前 (03-31) 18次浏览 已收录 0个评论 扫描二维码

MA5:MA(C,5);MA6:=MA(C,6);MA10:MA(C,10);
MA20:MA(C,20);A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);
MA30:MA(C,30);MA60:MA(C,60);MA120:MA(C,120);乖离2:=(MA20-MA30)/MA30*100;
VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);MAX1:=MAX(MA20,MA30);MAX2:=MAX(MAX1,MA60);
MIN11:=MIN(MA20,MA30);MIN2:=MIN(MIN11,MA60);K1:=(MAX2/MIN2-1)*100;{粘合度符合条件}
VAR2:=IF(K1<=8,1,0);
上火车轨:=MA20>MA30 AND MA20>REF(MA20,1) AND MA30>REF(MA30,1) AND MA20-MA30>REF((MA20-MA30),1) ;
STICKLINE(上火车轨,MA20,MA30,0,0),COLORRED;
神枪手:=DRAWTEXT(FILTER(上火车轨 AND "MACD.DIF"<0.15 AND "MACD.DIF">REF("MACD.DIF",1) AND
MA(V,60)>REF(MA(V,60),1) AND MA(V,5)>MA(V,10) AND J1>REF(J1,1) AND
( L<=MA20 AND C>MA20 OR (CROSS(MA5,MA20))),5),L*0.98,’←神枪手’);
神枪手选股:=FILTER(上火车轨 AND "MACD.DIF"<0.15 AND "MACD.DIF">REF("MACD.DIF",1) AND
MA(V,60)>REF(MA(V,60),1) AND MA(V,5)>MA(V,10) AND J1>REF(J1,1) AND
( L<=MA20 AND C>MA20 OR (CROSS(MA5,MA20)) ),5);
{44.40%15240}
短线暴涨:DRAWTEXT(FILTER( (VAR1 OR VAR2) AND MA10>REF(MA10,1) AND
COUNT(MA30>REF(MA30,1),3)=3 AND MA30>MA60 AND COUNT(CROSS(MA5,MA30),3) AND J1>MJ1 AND
MA(V,5)>MA(V,60)AND MA(V,60)>REF(MA(V,60),1),5),MA60*0.99,’短线暴涨’),COLORRED;
DRAWTEXT(CROSS("KDJ.K"(5,2,3),"KDJ.D"(5,2,3)) AND "KDJ.D"(5,2,3)<30 AND J1>MJ1 AND
MA60>REF(MA60,1) AND COUNT(J1<1,3)>=1 ,L*0.995,’←买入’),COLORYELLOW;
DRAWTEXT(CROSS("KDJ.D"(5,2,3),"KDJ.K"(5,2,3)) AND "KDJ.D"(5,2,3)>65 AND J1<MJ1 AND
COUNT(J1>1,3)>=1,H*1.005,’←卖出’),COLORGREEN;
DRAWTEXT(CROSS("KDJ.D"(18,9,6),"KDJ.K"(18,9,6)) AND "KDJ.D"(18,9,6)>60 AND
"KDJ.J"(45,15,15)>90,H*1.03,’←顶’),COLORRED;
DRAWTEXT(CROSS(MA5,MA6) AND "KDJ.K"(5,3,3)>=50 AND "KDJ.J"(5,3,3)<31 ,L*0.92,’←再买’),
COLORMAGENTA;
XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));
XL2:=(((CLOSE – EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);
XL3:=CROSS(XL2,(0 – 20));
DRAWTEXT(FILTER(((XL1 > 0) AND LOW),5),(LOW – 0.4),’●买点’);
DRAWTEXT((XL3 > 0),(LOW – 0.2),’●绝对底部’);X6:=REF(CLOSE,1);
X7:=((SMA(MAX((CLOSE – X6),0),7,1) / SMA(ABS((CLOSE – X6)),7,1)) * 100);
X8:=CROSS(79,X7);X9:=FILTER(X8,4);
DRAWTEXT(X9,(HIGH * 1.02),’●出货’),COLOR9000F5;STICKLINE(C>1.098*REF(C,1),C,O,0,0),COLORYELLOW;
AAA:=CONST(HHV(H,90));R1:=MA(CLOSE,1);R2:=MA(CLOSE,3);R3:=(MA(R2,1)*1);R4:=(MA(R2,3)*1);
DRAWTEXT(CROSS(R3,R4),(LOW-0.1),’进’),COLORYELLOW;LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE – LC),0),3,1) / SMA(ABS((CLOSE – LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),’出’),COLORGREEN;
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR12:=(HIGH+LOW+CLOSE)/3;VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));
VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));
VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);
VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND VAR14<=-150 AND VAR14>-200,-10,VAR15);
VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR18:=100-ABS(VAR17);VAR19:=IF(VAR18<90,VAR18,100);VAR1A:=IF(VARE>0,VARE,0);
VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;
VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;
DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,HIGH*1.02,’大笔出货’),LINETHICK1,COLORFFCC66;
AA1:=AMOUNT/V;BB1:=L<AA1*0.9;CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;老鼠仓:=BB1 AND CC1 AND DD1 AND EE1,LINETHICK0;
DRAWTEXT(老鼠仓,(LOW* 0.99),’老鼠仓’),COLOR40CCFF;A74:=MA(CLOSE,20);
A75:=(CLOSE > MA(CLOSE,5));A76:=(MA(CLOSE,5) > MA(CLOSE,10));A77:=(CLOSE > MA(CLOSE,10));
A78:=(MA(CLOSE,5) > MA(CLOSE,20));A79:=(CLOSE > MA(CLOSE,20));
A710:=REF(A74,1);A711:=(A74 > A710);
AVX:=(((((IF(A75,10,(0 – 10)) + IF(A76,10,(0 – 10))) + IF(A77,10,(0 – 10)))
+ IF(A78,10,(0 – 10))) + IF(A79,10,(0 – 10))) + IF(A711,10,(0 – 10)));
DSLX:=(CLOSE / INDEXC);DSLX1:=MA(DSLX,5);DSLX2:=MA(DSLX,10);
V1:=MA(VOL,5);V2:=MA(VOL,10);T1:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 >= V2))
AND (DSLX >= DSLX1)),1,0));
T2:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
T3:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)),1,0));
T4:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)),1,0));
T5:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
T6:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
T7:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
T8:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
T9:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
T10:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
T11:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
T12:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
T13:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
T14:=CONST(IF( C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
T15:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
T16:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
T17:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));
T18:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));
T19:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 < V2)),1,0));
T20:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 >= V2)),1,0));
T21:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 < V2)),1,0));
T22:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)),1,0));
T23:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)),1,0));
T24:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)),1,0));
T25:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)),1,0));
AA:=BARSCOUNT(C);AH:=HHV(H,200);AL:=LLV(L,200);A0:=(AH-AL)/40;B1:=L-A0;
STICKLINE((AA+0)/34=FLOOR((AA+0)/34),B1,B1-1.5*A0,2,0),COLORF00FF0;
DRAWTEXT((AA+0)/34=FLOOR((AA+0)/34),B1-1*A0,’时间窗,变盘’),COLORF00FF0;
VAR2S:=(2*CLOSE+HIGH+LOW)/4;VAR3S:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4S:=LLV(LOW,5); VAR5S:=HHV(HIGH,4);
散户:=EMA((VAR2S-VAR4S)/(VAR5S-VAR4S)*100,4)*VAR3S;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3S;
DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,’←吸’),COLORRED;
BBB1:=MA(C,1);B2:=SMA(SMA(SMA(BBB1,2,1),2,1),2,1),COLORRED;
SMA2:=MA(B2,2);
VARB1:=(100 – ((90 * (HHV(HIGH,21) – CLOSE)) / (HHV(HIGH,21) – LLV(LOW,21))));
VAR3:=(100 – MA(((100 * (HHV(HIGH,6) – CLOSE)) / (HHV(HIGH,6) – LLV(LOW,6))),34));
买:DRAWTEXT(CROSS(VARB1,VAR3) AND B2>SMA2,(LOW * 0.97),’←⊙买’),COLORRED;

XA_1:=MA(CLOSE,5);
XA_2:=MA(CLOSE,10);
XA_3:=MA(CLOSE,60);
XA_4:=MA(CLOSE,120);
XA_5:=REF(CLOSE,1)<REF(XA_1,1) AND OPEN<XA_1 AND XA_1>XA_4;
XA_6:=REF(XA_5,1)=0 AND XA_5;
XA_7:=EMA(HHV(HIGH,1),8);
XA_8:=EMA(CLOSE,8);
XA_9:=XA_8<REF(XA_8,1) AND CLOSE<XA_8;
XA_10:=IF(XA_7<REF(XA_7,1) OR XA_9,1,0);
XA_11:=(COUNT(XA_10=1,4)=3 AND XA_10=0)*89;
XA_12:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
XA_13:=IF(CLOSE>OPEN,XA_12*(HIGH-LOW),IF(CLOSE<OPEN,XA_12*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-XA_12*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-XA_12*(HIGH-LOW),0-VOL/2));
XA_14:=XA_13/20/1.15;
XA_15:=XA_14*0.55+REF(XA_14,1)*0.33+REF(XA_14,2)*0.22;
XA_16:=EMA(XA_15,3);
XA_17:=XA_16<100;
XA_18:=COUNT(XA_17,9)<2;
XA_19:=CLOSE/REF(CLOSE,1)>1.09;
XA_20:=CLOSE=HIGH;
XA_21:=REF(XA_19,1) AND REF(XA_20,1);
XA_22:=COUNT(XA_21,11)>0;
XA_23:=MA(CLOSE,3);
XA_24:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
XA_25:=(HIGH-REF(CLOSE,1))/REF(CLOSE,1)*100;
XA_26:=REF(HHV(VOL,10),1);
XA_27:=MA(CLOSE,20);
XA_28:=(XA_23+XA_1)/2;
XA_29:=COUNT(COUNT(XA_24>9.9 AND CLOSE=HIGH,1)>=1,30)>0;
XA_30:=COUNT(COUNT(XA_24>9.9 AND CLOSE=HIGH,1)>=1,60)>0;
XA_31:=XA_27>REF(XA_27,1) AND VOL<XA_26 AND XA_29 AND XA_25>3 AND OPEN<=XA_1 AND CLOSE>XA_1 AND (COUNT(XA_28>REF(XA_28,1),3)>=3 OR COUNT(XA_1>REF(XA_1,1),3)>=3) AND COUNT(XA_27>REF(XA_27,1),25)>=16;
XA_32:=(CLOSE-OPEN)/OPEN*100;
XA_33:=XA_30 AND VOL<1.3*REF(VOL,1) AND COUNT(XA_32>0.5,6)>=5 AND COUNT(XA_23>XA_1,5)>=5 AND COUNT(HIGH>REF(HIGH,1),6)>=5 AND XA_25>4.5 AND OPEN<=XA_23 AND CLOSE>XA_23 AND OPEN>XA_1;
XA_34:=XA_31 OR XA_33;
XA_35:=XA_34=1 AND COUNT(XA_34,15)=1;
XA_36:=AMOUNT/VOL/7;
XA_37:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
XA_38:=SUM(AMOUNT,10)/XA_36/7;
XA_39:=DMA(XA_37,VOL/XA_38);
XA_40:=(CLOSE-XA_39)/XA_39*100;
XA_41:=-XA_40;
XA_42:=XA_40>XA_41;
XA_43:=CROSS(XA_40,0.6) AND XA_42;
XA_44:=EMA(CLOSE/REF(CLOSE,1),5);
XA_45:=EMA(CLOSE/REF(CLOSE,1),10);
XA_46:=CROSS(XA_44,XA_45);
XA_47:=XA_43 AND XA_46;
XA_48:=XA_47 AND XA_35;
XA_49:=COUNT(XA_35,10)>0;
XA_50:=XA_47 AND XA_49 AND XA_22;
XA_51:=XA_47 AND XA_22 AND XA_11;
XA_52:=XA_48 AND XA_22;
XA_53:=XA_50 OR XA_52 OR XA_51;
XA_54:=(EMA(CLOSE,12)-EMA(CLOSE,26))/EMA(CLOSE,26)*100;
XA_55:=EMA(XA_54,9);
XA_56:=(XA_54-XA_55)*100;
XA_57:=XA_56-REF(XA_56,1);
XA_58:=CROSS(XA_57,50);
XA_59:=EMA(EMA(EMA(CLOSE,12),12),12);
XA_60:=(XA_59-REF(XA_59,1))/REF(XA_59,1)*100;
XA_61:=MA(XA_60,9);
XA_62:=XA_60>XA_61;
XA_63:=CLOSE/REF(CLOSE,1)>1.09;
XA_64:=CLOSE=HIGH;
XA_65:=REF(XA_63,1) AND REF(XA_64,1);
XA_66:=COUNT(XA_65,4)>0;
XA_67:=COUNT(XA_65,5)>0;
XA_68:=(3*CLOSE+LOW+OPEN+HIGH)/6;
XA_69:=(20*XA_68+19*REF(XA_68,1)+18*REF(XA_68,2)+17*REF(XA_68,3)+16*REF(XA_68,4)+15*REF(XA_68,5)+14*REF(XA_68,6)+13*REF(XA_68,7)+12*REF(XA_68,8)+11*REF(XA_68,9)+10*REF(XA_68,10)+9*REF(XA_68,11)+8*REF(XA_68,12)+7*REF(XA_68,13)+6*REF(XA_68,14)+5*REF(XA_68,15)+4*REF(XA_68,16)+3*REF(XA_68,17)+2*REF(XA_68,18)+REF(XA_68,20))/210;
XA_70:=MA(XA_69,6);
XA_71:=XA_69>XA_70;
XA_72:=CLOSE>1.02*REF(CLOSE,1);
XA_73:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100<(-6);
XA_74:=REF(CLOSE,1)>(REF(CLOSE,BARSLAST(XA_72))+REF(CLOSE,BARSLAST(XA_72)+1))/2 AND CLOSE<(REF(CLOSE,BARSLAST(XA_72))+REF(CLOSE,BARSLAST(XA_72)+1))/2;
XA_75:=REF(CLOSE,1)<(REF(CLOSE,BARSLAST(XA_73))+REF(CLOSE,BARSLAST(XA_73)+1))/2 AND CLOSE>(REF(CLOSE,BARSLAST(XA_73))+REF(CLOSE,BARSLAST(XA_73)+1))/2;
XA_76:=BARSLAST(XA_73)<=7 AND XA_72 AND XA_75 AND COUNT(XA_72,BARSLAST(XA_73))=1 AND NOT(HIGH=LOW) AND REF(NOT(HIGH=LOW),BARSLAST(XA_73))=1;
XA_77:=COUNT(XA_76,7)>0;
XA_78:=((CLOSE-REF(MA(CLOSE,6),1))/6+MA(CLOSE,6))*1.004;
XA_79:=CROSS(CLOSE,XA_78) AND XA_78>REF(XA_78,1);
XA_80:=((CLOSE-REF(MA(CLOSE,18),1))/18+MA(CLOSE,18))*1.004;
XA_81:=CROSS(CLOSE,XA_80) AND XA_80>REF(XA_80,1);
XA_82:=XA_79 AND XA_81 AND XA_76 AND XA_71 AND XA_62;
XA_83:=XA_66 AND XA_76 AND XA_71 AND XA_62;
XA_84:=XA_82 OR XA_83;
XA_85:=XA_18 AND XA_53;
XA_86:=XA_84 OR XA_85;


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (1)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址