• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

非常牛的波段神器主图指标压箱底货 无未来 集成型

通达信公式 第一股票指标公式网 4周前 (04-12) 45次浏览 已收录 0个评论 扫描二维码

票各类基本信息,自带9转,波段轨迹,以及一些不错的买点。分享给各位股友。
DRAWGBK(C>O,RGB(10,0,0),RGB(0,0,0),1,2,1);
DRAWKLINE(H,O,L,C);
安全:=MA(C,30),CIRCLEDOT,COLORFF00FF;
当日成本:=IF(C>REF(C,1),(3*H+4*C+3*OPEN+2*L)/12,(2*H+4*C+3*OPEN+3*L)/12);
{板块市值业绩}
所属板块:=STRCAT(‘【所属板块】’,STRCAT(STRCAT(STRCAT(‘ [行业]—’,HYBLOCK),STRCAT(‘ [地域]—’,DYBLOCK)),STRCAT(‘ [概念]—’,GNBLOCK)));
总股本:=STRCAT(STRCAT(‘ 总股本:’,CON2STR(TOTALCAPITAL/1000000,2)),’亿’);
流通盘:=STRCAT(STRCAT(‘ 流通盘:’,CON2STR(CAPITAL/1000000,2)),’亿’);
全流通:=STRCAT(STRCAT(‘ 流通比:’,CON2STR(CAPITAL/TOTALCAPITAL*100,2)),’%’);
市值:=STRCAT(STRCAT(‘ 流通市值:’,CON2STR((CAPITAL/1000000)*C,2)),’亿’);
上市日期:=STRCAT(‘ 上市日期: ‘,CON2STR(HHV((BARSCOUNT(C)=0)*(DATE+19000000),0),0));
股本市值:=STRCAT(‘【股本市值】’,STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),上市日期));
市盈率:=STRCAT(‘ 市盈率:’,CON2STR(C/FINANCE(33),2));
市销率:=STRCAT(‘ 市销率:’,CON2STR(C/(FINANCE(20)/FINANCE(1)),2));
市净率:=STRCAT(‘ 市净率:’,CON2STR(C/FINANCE(34),2));
净资收益率:=STRCAT(‘ 净资收益率:’,CON2STR(FINANCE(33)/FINANCE(34)*100,2));
毛利率:=STRCAT(‘ 毛利率:’,CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
净利润率:=STRCAT(‘ 净利率:’,CON2STR(FINANCE(30)/FINANCE(20)*100,2));
主营利润率:=STRCAT(‘ 主营利润率:’,CON2STR(FINANCE(23)/FINANCE(20)*100,2));
当前业绩:=STRCAT(‘【当前业绩】’,STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市盈率,市销率),市净率),净资收益率),毛利率),净利润率),主营利润率));
DRAWTEXT_FIX(ISLASTBAR,0.005,0.02,0,所属板块),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.07,0,股本市值),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.12,0,当前业绩),COLORMAGENTA;
DRAWTEXT_FIX(1,0.005,0.17,0,’莸利比例:’),COLORYELLOW;
DRAWNUMBER_FIX(1,0.06,0.17,0,CONST(WINNER(C )*100)),COLORYELLOW;
DRAWNUMBER_FIX(1,0.15,0.17,0,CONST(DYNAINFO(37)*100)),COLORYELLOW;
DRAWTEXT_FIX (1,0.12,0.17,0,’换手:’),COLORYELLOW;
DRAWNUMBER_FIX(1,0.25,0.17,0,CONST(DYNAINFO(17))),COLORYELLOW;
DRAWTEXT_FIX (1,0.22,0.17,0,’量比:’),COLORYELLOW;
DRAWTEXT_FIX (1,0.30,0.17,0,’涨幅:’),COLORYELLOW;
DRAWNUMBER_FIX(1,0.33,0.17,0,CONST(DYNAINFO(14)*100)),COLORYELLOW;
DRAWNUMBER_FIX(1,0.33,0.17,0,IF(CONST(DYNAINFO(14)*100)<0,CONST(DYNAINFO(14)*100),DRAWNULL)),COLORYELLOW;
X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};
X3:=FINANCE(23)/FINANCE(10)*3.3;
X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
X5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X1+X2+X3+X4+X5;
预警:=IF(Z值<1.2,’重警’,IF(Z值>=1.2 AND Z值<2.6,’轻警’,’无警’));
财务预警:=STRCAT(‘财务预警: ‘,STRCAT(预警,STRCAT(‘-Z值: ‘,CON2STR(Z值,3))));
优质资产率:=STRCAT(‘ 优质资产率: ‘,CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2));{理论上越大越好但不同行业有不同标准};
现金负债比:=STRCAT(‘ 现金负债比: ‘,CON2STR(FINANCE(25)/FINANCE(15),3));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};
财务系数:=STRCAT(‘风险系数: ‘,STRCAT(STRCAT(财务预警,优质资产率),现金负债比));
DRAWTEXT_FIX(ISLASTBAR,0.005,0.23,0,财务系数),COLORGREEN;
{双龙趋势}
龙一:EMA(H,55),COLORGREEN,LINETHICK1;
龙二:EMA(L,55),COLORGREEN,LINETHICK1;
NA1:=PLOYLINE(C>龙一,龙一);
IF(C>龙一,NA1,DRAWNULL),COLORMAGENTA,LINETHICK1;
NB1:=PLOYLINE(C>龙二,龙二);
IF(C>龙二,NB1,DRAWNULL),COLORMAGENTA,LINETHICK1;
{神龙顶底}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
DRAWICON(CROSS(J,0),L*0.999,34);
DRAWICON(CROSS(100,J),H*1.003,35);
{九转序列}
A1:=C>REF(C,4);
A2:=C<REF(C,4);
T1:=A2 AND REF(A1,1);
T2:=A2 AND REF(T1,1);
T3:=A2 AND REF(T2,1);
T4:=A2 AND REF(T3,1);
T5:=A2 AND REF(T4,1);
T6:=A2 AND REF(T5,1);
T7:=A2 AND REF(T6,1);
T8:=A2 AND REF(T7,1);
T9:=A2 AND REF(T8,1);
DRAWTEXT(T6,L*0.995,’6′),COLORGREEN;
DRAWTEXT(T7,L*0.995,’7′),COLORGREEN;
DRAWTEXT(T8,L*0.995,’8′),COLORGREEN;
DRAWTEXT(T9,L*0.995,’9′),COLORGREEN;
B1:=C<REF(C,4);
B2:=C>REF(C,4);
D1:=B2 AND REF(B1,1);
D2:=B2 AND REF(D1,1);
D3:=B2 AND REF(D2,1);
D4:=B2 AND REF(D3,1);
D5:=B2 AND REF(D4,1);
D6:=B2 AND REF(D5,1);
D7:=B2 AND REF(D6,1);
D8:=B2 AND REF(D7,1);
D9:=B2 AND REF(D8,1);
DRAWTEXT(D6,H*1.008,’6′),COLORYELLOW;
DRAWTEXT(D7,H*1.008,’7′),COLORYELLOW;
DRAWTEXT(D8,H*1.008,’8′),COLORYELLOW;
DRAWTEXT(D9,H*1.008,’9’),COLORYELLOW;
慢牛线:=EXPMEMA(当日成本,51),LINETHICK2,COLORMAGENTA;
波段高:(XMA(XMA(HIGH,30),30)-XMA(XMA(LOW,30),30))*2+XMA(XMA(HIGH,30),30),COLORWHITE,LINETHICK1;
波段低:XMA(XMA(LOW,30),30)-(XMA(XMA(HIGH,30),30)-XMA(XMA(LOW,30),30))*1.5,COLORWHITE,LINETHICK1;
波段中值:(波段高+波段低)/2,DOTLINE,COLOR909090;
IF(波段高>=REF(波段高,1),波段高,DRAWNULL),COLORRED,LINETHICK2;
IF(波段低>=REF(波段低,1),波段低,DRAWNULL),COLORRED,LINETHICK2;
IF(波段高<=REF(波段高,1),波段高,DRAWNULL),COLOR008800,LINETHICK3;
IF(波段低<=REF(波段低,1),波段低,DRAWNULL),COLOR008800,LINETHICK3;
STICKLINE(REF(LOW,1)<波段低 AND CLOSE>波段低 AND 波段高>=REF(波段高,1) AND CLOSE>OPEN,CLOSE,OPEN,(-1),0),COLORYELLOW;
STICKLINE(REF(HIGH,1)>=波段高 AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN,CLOSE,OPEN,(-1),0),COLORFF6600;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址