• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

强势主升低买+龙头副图/选股预警源码

通达信公式 第一股票指标公式网 1个月前 (04-14) 103次浏览 已收录 0个评论 扫描二维码

强势主升低买+龙头副图/选股预警 源码 通达信 贴图
清仓:=1.66*MA(FORCAST(CLOSE,2),40);
出货:=1.36*MA(FORCAST(CLOSE,2),40);
高抛:=1.16*MA(FORCAST(CLOSE,2),40);
低吸:=0.82*MA(FORCAST(CLOSE,2),40);
满仓:=0.72*MA(FORCAST(CLOSE,2),40);
强通1:=清仓>REF(清仓,1),;
强通2:=出货>REF(出货,1),;
强通3:=高抛>REF(高抛,1),;
强通4:=低吸>REF(低吸,1),;
强通5:=满仓>REF(满仓,1),;
上升通道:=强通1 AND 强通2 AND 强通3 AND 强通4 AND 强通5,;
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10),;
MA20:=MA(CLOSE,20);
MA30:=MA(CLOSE,30);
MA60:=MA(CLOSE,60);
五强:=MA5>REF(MA5,1),;
十强:=MA10>REF(MA10,1),;
二十强:=MA20>REF(MA20,1),;
三十强:=MA30>REF(MA30,1),;
六十强:=MA60>REF(MA60,1),;
小均强:=五强 AND 十强,;
均强:=十强 AND 二十强 AND 三十强,;
大均强:=十强 AND 二十强 AND 三十强 AND 六十强,;
JJD:=(H+L+C)/3;
强势线1:=HHV(MA((((LOW + HIGH) + CLOSE) / 3),8),60);
强势线2:=HHV(MA((((LOW + HIGH) + CLOSE) / 3.18),8),20);
强势线3:=HHV(MA((((LOW + HIGH) + CLOSE) / 3.258),8),10);
强势线4:=HHV(MA((((LOW + HIGH) + CLOSE) / 3.08),80),13);
开始走强1:=强势线1>REF(强势线1,1),;
开始走强2:=强势线2>REF(强势线2,1),;
开始走强3:=强势线3>REF(强势线3,1),;
开始走强4:=强势线4>REF(强势线3,1),;
双强1:=开始走强1 AND 开始走强2,;
双强2:=开始走强2 AND 开始走强3,;
双强3:=开始走强2 AND 开始走强3,;
双强4:=开始走强3 AND 开始走强4,;
三强:=开始走强1 AND 开始走强2 AND 开始走强3,;
四强:=开始走强1 AND 开始走强2 AND 开始走强3 AND 开始走强4,;
强势为王:=双强1 OR 双强2 OR 双强3 OR 双强4 OR 三强 OR 四强,;
VV:=(C+L+H)/3;
DSA:=SMA(MA(VV,15),2,1);
顶部1:=DSA*1.0888;
顶部2:=DSA*1.158;
顶部3:=DSA*1.218;
底部1:=DSA*0.9518;
底部2:=DSA*0.888;
底部3:=DSA*0.8;
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);
MA4:=MA(CLOSE,60);
五日走强:=MA1>REF(MA1,1),;
十日走强:=MA2>REF(MA2,1),;
二十日走强:=MA3>REF(MA3,1),;
六十日走强:=MA4>REF(MA4,1),;
低位主升:=五日走强 AND 十日走强 AND 六十日走强,;
主升浪:=五日走强 AND 十日走强 AND 二十日走强,;
大主升浪:=十日走强 AND 二十日走强 AND 六十日走强,;
大主升浪2:=五日走强 AND 十日走强 AND 二十日走强 AND 六十日走强,;
总主升:=主升浪 AND 大主升浪 AND 大主升浪2,;
总主升浪:=低位主升 OR 主升浪 OR 大主升浪 OR 大主升浪2 OR 总主升,;
强势主升低买:L<底部1 AND 总主升浪 AND 强势为王 AND C<DSA;
HJ_1:=DYNAINFO(4)>0 AND HHV(HIGH,10)/LLV(LOW,10)<1.25 AND REF(CLOSE,1)<LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85 AND CLOSE>OPEN AND CLOSE>=HHV(HIGH,10);
HJ_2:=IF(DATETODAY(DATE)<999999999,1,DRAWNULL);
HJ_3:=EMA(CLOSE,5);
HJ_4:=EMA(CLOSE,10);
HJ_5:=EMA(CLOSE,14);
HJ_6:=EMA(CLOSE,18);
HJ_7:=EMA(CLOSE,40);
HJ_8:=EMA(CLOSE,60);
HJ_9:=IF(DATE<999999999,1,DRAWNULL);
HJ_10:=MAX(HJ_7,HJ_8);
HJ_11:=CLOSE>HJ_10 AND HJ_1 AND (CLOSE>REF(HHV(HIGH,3),1)*HJ_2 AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.07);
HJ_12:=VOL;
HJ_13:=MA(HJ_12,5);
HJ_14:=HJ_13+HJ_13>HJ_12;
HJ_15:=DYNAINFO(4)>0 AND HHV(HIGH,10)/LLV(LOW,10)<1.25 AND REF(CLOSE,1)<(LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85)*HJ_2 AND CLOSE>OPEN AND CLOSE>=HHV(HIGH,10)*HJ_9;
HJ_16:=(CLOSE>REF(HHV(HIGH,3),1)*HJ_2 AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.07)*HJ_2 AND HJ_15 AND HJ_14;
HJ_17:=DYNAINFO(4)>0 AND HHV(HIGH,10)/LLV(LOW,10)<1.25 AND REF(CLOSE,1)*HJ_2<LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85 AND CLOSE>OPEN AND CLOSE>=HHV(HIGH,10);
HJ_18:=(CLOSE-REF(CLOSE,1)*HJ_2)/REF(CLOSE,1)*100>7;
HJ_19:=HJ_17 AND HJ_18;
HJ_20:=DATETODAY(DATE);
HJ_21:=HJ_20>9344 AND HJ_20<999999999;
HJ_22:=(HJ_11 AND HJ_19)*HJ_21;
HJ_23:=EMA(CLOSE,5);
HJ_24:=EMA(CLOSE,10);
HJ_25:=EMA(CLOSE,14);
HJ_26:=EMA(CLOSE,18);
HJ_27:=EMA(CLOSE,40);
HJ_28:=EMA(CLOSE,60);
HJ_29:=MAX(MAX(MAX(MAX(MAX(HJ_23,HJ_4),HJ_25),HJ_26),HJ_27),HJ_28)*HJ_9;
HJ_30:=MIN(MIN(MIN(MIN(MIN(HJ_23,HJ_4),HJ_25),HJ_26),HJ_27),HJ_28)*HJ_9;
HJ_31:=CLOSE>HJ_29 AND LOW<HJ_30 AND (CLOSE>REF(HHV(HIGH,3),1) AND (CLOSE-REF(CLOSE,1)*HJ_2)/REF(CLOSE,1)>0.09);
HJ_32:=FILTER(HJ_31>0,0)=1;
HJ_33:=DATETODAY(DATE);
HJ_34:=HJ_33>9350 AND HJ_33<999999999;
HJ_35:=HJ_32*HJ_34;
HJ_36:=MA(REF(HHV(CLOSE,26),1),2);
HJ_37:=MA(CLOSE,26);
HJ_38:=POW(CLOSE-HJ_37,2);
HJ_39:=MA(HJ_38,13);
HJ_40:=SQRT(HJ_39);
HJ_41:=HJ_37+2*HJ_40;
HJ_42:=REF(HJ_41,1);
HJ_43:=CROSS(CLOSE,HJ_36) AND HIGH>REF(HJ_41,1) OR (CLOSE>HJ_36 AND CROSS(CLOSE,REF(HJ_41,1))) AND CLOSE/OPEN>0.998;
HJ_44:=MACD.MACD;
HJ_45:=KD.K;
HJ_46:=KD.D;
HJ_47:=RSI.RSI1;
HJ_48:=RSI.RSI3;
HJ_49:=CLOSE-REF(CLOSE,1);
HJ_50:=IF(HJ_49>=0,HJ_49,0)*HJ_9;
HJ_51:=IF(HJ_49<0,-HJ_49,0)*HJ_9;
HJ_52:=MEMA(HJ_50,10);
HJ_53:=MEMA(HJ_51,10);
HJ_54:=MEMA(HJ_50,6);
HJ_55:=MEMA(HJ_51,6);
HJ_56:=MA(100*HJ_52/(HJ_52+HJ_53),10)*HJ_9;
HJ_57:=MA(100*HJ_54/(HJ_54+HJ_55),6)*HJ_9;
HJ_58:=MA(CLOSE,5)/MA(CLOSE,10)>0.999 AND MA(CLOSE,10)/MA(CLOSE,20)>0.9847 AND MA(CLOSE,20)>MA(CLOSE,60) AND REF(COUNT(MA(CLOSE,10)/MA(CLOSE,20)<1.017 OR MA(CLOSE,5)/MA(CLOSE,10)<1.017,8)>=1,1) AND MA(CLOSE,20)/MA(CLOSE,60)<1.121;
HJ_59:=(CLOSE-MA(CLOSE,60))/MA(CLOSE,60)*100;
HJ_60:=COUNT(HJ_59<35,100)>=95;
HJ_61:=HJ_43 AND HJ_58>0 AND NOT(DYNAINFO(4)=0) AND HJ_60 AND REF(COUNT(MA(CLOSE,20)>MA(CLOSE,30),4)=4 AND COUNT(CLOSE>MA(CLOSE,5),3)>=2,1) AND VOL>REF(VOL,1) AND (REF(COUNT(CLOSE>OPEN,10)>=6 OR COUNT(CLOSE>OPEN,5)>=4,1) OR CLOSE=HIGH) AND (CROSS(HJ_57,HJ_56) OR CROSS(HJ_44,0) OR REF(COUNT(CROSS(HJ_44,0),3)=1 AND HJ_44<0.15 AND CLOSE/OPEN>0.989 AND CLOSE/REF(CLOSE,1)<1.03,1) OR CROSS(HJ_45,HJ_46) OR CROSS(HJ_47,HJ_48)) AND REF(CLOSE/OPEN>0.988 AND (CLOSE>OPEN OR (CLOSE<=OPEN AND HIGH/LOW<1.049)),1) AND HIGH/CLOSE<1.013 AND CLOSE/OPEN>1.05;
HJ_62:=HJ_11+HJ_16+HJ_19+HJ_32+HJ_61>=2;
HJ_63:=MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,20)>MA(CLOSE,60) AND MA(CLOSE,60)>MA(CLOSE,120) AND MA(CLOSE,5)>REF(MA(CLOSE,5),1);
HJ_64:=CLOSE>REF(CLOSE,1)*1.1-0.01;
HJ_65:=HHV(HIGH,20)=HHV(CLOSE,1) AND VOL>0 AND BARSCOUNT(CLOSE)*HJ_2>=20;
HJ_66:=VOL/REF(VOL,1)*HJ_2>1.9;
HJ_67:=HJ_63 AND HJ_64 AND HJ_65 AND HJ_66;
HJ_68:=MA(CLOSE,5);
HJ_69:=MA(CLOSE,10);
HJ_70:=MA(CLOSE,20);
HJ_71:=MA(CLOSE,30);
HJ_72:=MA(CLOSE,60);
HJ_73:=CLOSE>HJ_68 AND HJ_68>HJ_69 AND HJ_69>HJ_70 AND CLOSE>HJ_72;
HJ_74:=CLOSE/REF(CLOSE,1)>1.05 AND REF(CLOSE,1)/REF(CLOSE,2)<1.05 AND CLOSE/LLV(CLOSE,10)<1.4;
HJ_75:=VOL/REF(VOL,1)>2 OR VOL=HHV(VOL,15);
HJ_76:=CAPITAL<10000000;
HJ_77:=ATAN((MA(CLOSE,5)/REF(MA(CLOSE,5),1)-1)*100)*57.299999>40;
HJ_78:=ATAN((MA(CLOSE,10)/REF(MA(CLOSE,10),1)-1)*100)*57.299999>30;
HJ_79:=ATAN((MA(CLOSE,20)/REF(MA(CLOSE,20),1)-1)*100)*57.299999>20;
HJ_80:=ATAN((MA(CLOSE,30)/REF(MA(CLOSE,30),1)-1)*100)*57.299999>10;
HJ_81:=HJ_77 AND HJ_78 AND HJ_79 AND HJ_80;
HJ_82:=KDJ.K>REF(KDJ.K,1)*HJ_2;
HJ_83:=KDJ.D>REF(KDJ.D,1)*HJ_2 AND KDJ.D<70;
HJ_84:=KDJ.J>REF(KDJ.J,1)*HJ_2;
HJ_85:=HJ_82 AND HJ_83 AND HJ_84;
HJ_86:=HJ_7 AND HJ_74 AND HJ_75 AND HJ_76 AND HJ_81 AND HJ_85;
HJ_87:=FILTER(HJ_86,15)*HJ_2;
HJ_88:=HJ_67 OR HJ_87;
龙头:DATE<999999999 AND ((HJ_88 AND HJ_62)*HJ_2 OR HJ_35 OR HJ_22);


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址