• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

风云MACD副图指标 精准提示信号轻松抓连板源码

通达信公式 第一股票指标公式网 2周前 (04-24) 39次浏览 已收录 0个评论 扫描二维码

有一句话说的好,无风不起浪,这个指标就是带风气浪的,主升浪随便拿。
大家好,今天给大家分享一个自用多年,且未曾失手的指标“风云MACD”副图预警指标
副图指标使用说明:
1:重点关注“二次金叉”粉色量柱,一般同时出现,说明后期拉升强度较高,作为最佳买进信号也不为过。
2:橙色量柱表示行情走好,放心持有,黄色量柱则表示行情走弱,可以逐渐减持。
3:粉色波段区域同理,行情走强,放心持有即可,绿色波段行情开始走弱(交叉的位置)出货即可。
主图指标详解:
重点关注“放心买”“笑脸”都是很好的入场信号点。顶部出现绿色量柱,则开始减持。

DIFF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIFF,9);
MACD:2*(DIFF-DEA),LINETHICK0;
DRAWBAND(DIFF,RGB(255,128,192),DEA,RGB(128,255,128));
STICKLINE(MACD>=0,MACD,0,2.5,1),COLORF00FF0;
STICKLINE(MACD<0,MACD,0,2.5,1),COLORWHITE;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2.5,0 ),COLOR00AAFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2.5,0 ),COLOR00BBFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR00CCFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1.5,0 ),COLOR00DDFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR00EEFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.5,0 ),COLOR00FFFF;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2.5,0 ),COLOR0000AA;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2.5,0 ),COLOR0011BB;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR0022CC;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.5,0 ),COLOR0033DD;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR0044EE;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,0.5,0 ),COLOR0055FF;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2.5,0 ),COLORAA00BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2.5,0 ),COLORBB11BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORCC22BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.5,0 ),COLORDD33BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.0,0 ),COLOREE44BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0.5,0 ),COLORFF55BB;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2.5,0 ),COLORFFAA00;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2.5,0 ),COLORFFBB11;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORFFCC22;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1.5,0 ),COLORFFDD33;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLORFFEE44;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.5,0 ),COLORFFFF55;
IF(DIFF<0,DIFF,0),COLORRED,LINETHICK2;
IF(DIFF<0,0,DIFF),COLORYELLOW,LINETHICK2;
IF(DIFF<DEA,DIFF,DEA),COLOR00FF00,LINETHICK2;
IF(DIFF>DEA,DEA,DEA),COLORBLUE,LINETHICK2;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
STICKLINE(低位金叉,0,-0.10,6,0),COLORYELLOW;
DRAWTEXT(低位金叉,-0.05,’ 低位金叉’),COLORYELLOW;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,-0.10,6,0),COLORFF00FF;
DRAWICON(二次金叉,DEA*1.04,13) ;
DRAWTEXT(二次金叉,-0.08,’ 二次金叉’),COLORFF00FF;
A11:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:=REF(CLOSE,A11+1)>CLOSE AND DIFF>REF(DIFF,A11+1) AND CROSS(DIFF,DEA);
STICKLINE(底背离,0,0.13,6,0),COLORRED;
DRAWTEXT(底背离,DEA,’ 底背离’),COLORRED;
A22:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A22+1)<CLOSE AND REF(DIFF,A22+1)>DIFF AND CROSS(DEA,DIFF);
DRAWTEXT(顶背离,DEA,’ 顶背离’),COLORGREEN;
A1:=DIFF<0 AND DEA<0;
A2:=A1>REF(A1,1);
A3:=BARSLAST(A2);
A4:=COUNT(DEA>0 AND DIFF>0,A3)=0;
A5:=CROSS(DIFF,DEA);{金叉}
A6:=BARSLAST(A5);
A7:=REF(A6,A6+1)+A6;
A8:=(DIFF+DEA)/2;
A9:=(HIGH+LOW)/2;
A10:=A5 AND A7<A3 AND A4 AND A8>REF(A8,A7) AND A9<REF(A9,A7) AND MACD>0;
DRAWTEXT(A10,DIFF*0.95,’★金叉介入’),COLORYELLOW;
连续走强:BARSLASTCOUNT(MACD>REF(MACD,1) AND MACD>0)NODRAW;{天}
强势回调:BARSLASTCOUNT(MACD<REF(MACD,1) AND MACD>0)NODRAW;{天}
连续走弱:BARSLASTCOUNT(MACD<REF(MACD,1) AND MACD<0)NODRAW;{天};
连续反弹:BARSLASTCOUNT(MACD>REF(MACD,1) AND MACD<0)NODRAW;{天};


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址