• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

多空操盘铁律主图指标

通达信公式 第一股票指标公式网 2周前 (04-27) 53次浏览 已收录 0个评论 扫描二维码

多空操盘铁律主图指标 源码 通达信 贴图
买线:=EMA(C,1);
卖线:=EMA(SLOPE(C,10)*10+C,20);
STICKLINE(买线>=卖线,REFDATE(HHV(H,0),DATE),REFDATE(LLV(L,0),DATE),6,0),COLOR001050;
STICKLINE(买线<卖线,REFDATE(HHV(H,0),DATE),REFDATE(LLV(L,0),DATE),6,0),COLOR404050;
DRAWKLINE(H,O,L,C);{波段红青K线}
STICKLINE(买线>=卖线,L,H,0,0),COLOR2F2FFF;
STICKLINE(买线>=卖线,C,O,3.1,0),COLOR000033;
STICKLINE(买线>=卖线,C,O,2.1,0),COLOR000099;
STICKLINE(买线>=卖线,C,O,1.5,0),COLOR0000CC;
STICKLINE(买线>=卖线,C,O,0.3,0),COLOR0000FF;{立体红颜色};
STICKLINE(买线<卖线,L,H,0,0 ),COLORFFFF00;
STICKLINE(买线<卖线,C,O,3.1,0 ),COLOR000000;
STICKLINE(买线<卖线,C,O,2.1,0 ),COLOR6A6A00;
STICKLINE(买线<卖线,C,O,1.5,0 ),COLORDDDD00;
STICKLINE(买线<卖线,C,O,0.3,0),COLORFFFF00;{立体青色};
ME2:=EMA(CLOSE,6);
五天:=EXPMA(CLOSE,5),COLORRED;
超短线:=EMA(ME2,11),COLORGREEN; LJL07:=(3*C+L+O+H)/6;
牛线:=(20*LJL07+19*REF(LJL07,1)+18*REF(LJL07,2)+17*REF(LJL07,3)+16*REF(LJL07,4)+15*REF(LJL07,5)+14*REF(LJL07,6)+13*REF(LJL07,7)+12*REF(LJL07,8)+11*REF(LJL07,9)+10*REF(LJL07,10)+9*REF(LJL07,11)+8*REF(LJL07,12)+7*REF(LJL07,13)+6*REF(LJL07,14)+5*REF(LJL07,15)+4*REF(LJL07,16)+3*REF(LJL07,17)+2*REF(LJL07,18)+REF(LJL07,20))/210,COLORRED;
熊线:=MA(牛线,5),COLORYELLOW,LINETHICK4,POINTDOT;
持股:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORWHITE;
{趋势}
赚了:=IF(EMA(CLOSE,3)>超短线,超短线,DRAWNULL),COLORRED;
持股角度:=ATAN((持股/REF(持股,1)-1)*100)*180/3.1416,COLORRED,NODRAW;
月线:=EMA(持股,30),COLORYELLOW,DOTLINE;
双月线:=EMA(持股,60),COLORCYAN,DOTLINE;
操作线20日:EMA(C,20),DOTLINE,COLOR0000FF;
红升:IF(操作线20日>REF(操作线20日,1),操作线20日,DRAWNULL),COLOR0000FF,LINETHICK3;
绿降:IF(操作线20日<REF(操作线20日,1),操作线20日,DRAWNULL),DOTLINE,COLOR0000FF;
趋势线:EXPMA(C,5),DOTLINE,COLORYELLOW;
KK1:=趋势线<REF(趋势线,1);
IF(KK1,趋势线,DRAWNULL),DOTLINE,COLORYELLOW;
DD1:=趋势线>REF(趋势线,1);
IF(DD1,趋势线,DRAWNULL),COLOR00FFFF,LINETHICK2;
均价:=(3*C+H+L+O)/6;
VAR1:=(8*均价+7*REF(均价,1)+6*REF(均价,2)+5*REF(均价,3)+
4*REF(均价,4)+3*REF(均价,5)+2*REF(均价,6)+REF(均价,8))/36;
VAR2:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
SZ1:=REF(VAR1,1)=REF(VAR2,1) AND VAR1>VAR2 AND CLOSE>VAR1;
SZ2:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>REF(VAR2,1)
AND H/VAR1<1.1 AND L>VAR2 AND CLOSE>VAR1;
SZ3:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>=REF(VAR2,1) AND H/VAR1>1.1;
SZ4:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>REF(VAR2,1)
AND CLOSE>VAR2 AND CLOSE<VAR1;
SZ5:=(VAR1>VAR2 AND VAR2>REF(VAR2,1) AND VAR1<>REF(VAR1,1)
AND CLOSE<VAR2) OR (VAR1>VAR2 AND VAR1<REF(VAR1,1)
AND VAR2<REF(VAR2,1) AND CLOSE<VAR2);
SZ6:=REF(VAR1,1)>REF(VAR2,1) AND VAR1=VAR2 AND CLOSE<VAR2;
XD1:=VAR1=VAR2 AND CLOSE<VAR2 OR (VAR1<REF(VAR1,1) AND VAR2<REF(VAR2,1)
AND REF(VAR1,1)=REF(VAR2,1) AND CLOSE<VAR2);
XD2:=VAR1=VAR2 AND CLOSE>VAR1;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和度:=IF(SAT>1,1,SAT)*100;
DRAWTEXT_FIX(BARSTATUS=2 AND SZ1,0.8,0.05,0,’调整结束短线介入’),COLOR00FFFF;
DRAWTEXT_FIX(BARSTATUS=2 AND SZ2,0.8,0.05,0,’上升通道走势良好’),COLOR00FFFF;
DRAWTEXT_FIX(BARSTATUS=2 AND SZ3,0.8,0.05,0,’股价偏离注意调整’),COLOR00FFFF;
DRAWTEXT_FIX(BARSTATUS=2 AND SZ4,0.8,0.05,0,’上升通道调整洗盘’),COLOR00FFFF;
DRAWTEXT_FIX(BARSTATUS=2 AND SZ5,0.8,0.05,0,’转向特征注意离场’),COLORFFFF00;
DRAWTEXT_FIX(BARSTATUS=2 AND SZ6,0.8,0.05,0,’通道改变坚决离场’),COLORFFFF00;
DRAWTEXT_FIX(BARSTATUS=2 AND XD1,0.8,0.05,0,’下跌通道只宜观望’),COLORFFFF00;
DRAWTEXT_FIX(BARSTATUS=2 AND XD2,0.8,0.05,0,’短期底部准备进入’),COLORYELLOW;
S:=C-REF(C,1);
DX:=100*EMA(EMA(S,6),6)/EMA(EMA(ABS(S),6),6);
DA:=(EMA(C,1)+EMA(C,2)+EMA(C,3)+EMA(C,4))/4;
DB:=(EMA(C,10)+EMA(C,20)+EMA(C,40)+EMA(C,80))/4;
JH:=SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100;
YC:=REF(CLOSE,1);
止损价位:=(YC*1.0035*97+0.2)/99.65;
DRAWTEXT_FIX(C!=0,0.02,0.05,0,’☆ ================== ☆’),COLORRED;
DRAWTEXT_FIX(C!=0,0.02,0.1,0,’操 ‘),COLORFFFF00;
DRAWTEXT_FIX(C!=0,0.02,0.15,0,’盘 ‘),COLORFFFF00;
DRAWTEXT_FIX(C!=0,0.02,0.2,0,’铁 ‘),COLORFFFF00;
DRAWTEXT_FIX(C!=0,0.02,0.25,0,’律 ‘),COLORFFFF00;
DRAWTEXT_FIX(C!=0,0.02,0.3,0,’☆ ================== ☆’),COLORRED;
DRAWTEXT_FIX(C!=0,0.05,0.1,0,’五二零线.波段操作’),COLOR00FFFF;
DRAWTEXT_FIX(C!=0,0.05,0.15,0,’买入条件 2:30以后’),COLOR00FFFF;
DRAWTEXT_FIX(C!=0,0.05,0.2,0,STRCAT(‘止损价位 ‘,STRCAT(CON2STR(止损价位,2),’ 元’))),COLOR00FFFF;
DRAWTEXT_FIX(C!=0,0.05,0.25,0,’线上工作. 线下休息’),COLOR00FFFF;
E:=(HIGH+LOW+OPEN+2*CLOSE)/5;
明日阻力:=2*E-LOW;
明日支撑:=2*E-HIGH;
明日突破:=E+(HIGH-LOW);
明日反转:=E-(HIGH-LOW);
今日阻力:=REF(明日阻力 , 1);
今日支撑:=REF(明日支撑 , 1);
DRAWTEXT_FIX(C!=0,0.02,0.35,0,STRCAT(‘今日阻力: ‘,STRCAT(CON2STR(今日阻力,2),’ 元’))),COLORFFFF00;
DRAWTEXT_FIX(C!=0,0.02,0.40,0,STRCAT(‘今日支撑: ‘,STRCAT(CON2STR(今日支撑,2),’ 元’))),COLOR8E8EFF;
DRAWTEXT_FIX(C!=0,0.02,0.45,0,STRCAT(‘明日突破: ‘,STRCAT(CON2STR(明日突破,2),’ 元’))),COLORFFFFFF;
DRAWTEXT_FIX(C!=0,0.02,0.50,0,STRCAT(‘明日阻力: ‘,STRCAT(CON2STR(明日阻力,2),’ 元’))),COLORFFFF00;
DRAWTEXT_FIX(C!=0,0.02,0.55,0,STRCAT(‘明日支撑: ‘,STRCAT(CON2STR(明日支撑,2),’ 元’))),COLOR8E8EFF;
DRAWTEXT_FIX(C!=0,0.02,0.60,0,STRCAT(‘明日反转: ‘,STRCAT(CON2STR(明日反转,2),’ 元’))),COLORYELLOW;
DRAWTEXT_FIX(C!=0,0.02,0.65,0,’☆ ================== ☆’),COLORRED;
J5:MA(C,5)NODRAW;
J10:MA(C,10)NODRAW;
J30:MA(C,30)NODRAW;
J60:MA(C,60)NODRAW;
J120:MA(C,120)NODRAW;
J250:MA(C,250)NODRAW;
JXDT:=J10>J30 AND J30>J60 AND J60>J250 AND J30>J120;
FGA:=O<MA(C,5) AND O<MA(C,10) AND C>MA(C,5) AND C>MA(C,10);
SL:=V<MA(V,40) AND V<MA(V,135);
DL:=L=LLV(V,10);
CS1:=JXDT AND COUNT(SL,4)>=1;
CS2:=JXDT AND COUNT(DL,4)>=1;
CS:=CS1 OR CS2;
JS:=CS AND FGA;
DRAWICON(JS,L*0.98,23);

ENTERLONG:DRAWICON(CROSS(买线,卖线),L,42);
EXITLONG:DRAWICON(CROSS(卖线,买线),H,43);


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址