• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

神奇的做T标尺主图源码

通达信公式 第一股票指标公式网 4周前 (05-26) 91次浏览 已收录 0个评论 扫描二维码

根据日线数据预测当日支撑买点和高抛卖点,此为日线指标,因不使用当日数据,所以当天的建议价格是不会变动的,相当于一个标尺吧,使用时,在相对低位挂单买入,结合分时指标在预测高点附近卖出,供大家参考,高手请略过。已取消密码,方便朋友们研究、修改。
ZJJ:=REF(AMOUNT/V/100,1);
STICKLINE(C>ZJJ,C,ZJJ,0.5,0),COLORYELLOW;
K:=(REF(H,1)-REF(L,1))/2;
买1:REF(C,1)-1.5*K,COLORWHITE;
买2:REF(C,1)-K,COLORWHITE;
买3:REF(C,1)-K/2,COLORWHITE;
昨均价:ZJJ,COLORRED,LINETHICK3;
昨收:REF(C,1),COLORYELLOW,LINETHICK2;
KK:=REF(H,1)-REF(L,1);
卖1:REF(C,1)+KK,COLORGREEN;
卖2:IF((REF(C,1)+KK*2)<1.1*REF(C,1),REF(C,1)+KK*2,卖1),COLORGREEN;
卖3:IF((REF(C,1)+KK*3)<1.1*REF(C,1),REF(C,1)+KK*3,卖2),COLORGREEN;
卖4:IF((REF(C,1)+KK*4)<1.1*REF(C,1),REF(C,1)+KK*4,卖3),COLORGREEN;
十赢概率:COUNT(C>ZJJ,10),NODRAW,COLORRED;
十叉概率:COUNT(H>卖1,10),NODRAW,COLORRED;
STICKLINE(C>=O,L,H,0,0),COLORRED;
STICKLINE(C<O,L,H,0,0),COLORCYAN;
DRAWTEXT(ISLASTBAR,卖1,’   卖1′),COLORWHITE;
DRAWTEXT(ISLASTBAR,卖2,’   卖2′),COLORWHITE;
DRAWTEXT(ISLASTBAR,卖3,’   卖3′),COLORWHITE;
DRAWTEXT(ISLASTBAR,卖4,’   卖4′),COLORWHITE;
{DRAWTEXT(ISLASTBAR,昨均价*1.006,’    昨均价’),COLORRED;
DRAWTEXT(ISLASTBAR,昨收*1.006,’    昨收’),COLORYELLOW;}
DRAWTEXT(ISLASTBAR,买1,’   买1′),COLORWHITE;
DRAWTEXT(ISLASTBAR,买2,’   买2′),COLORWHITE;
DRAWTEXT(ISLASTBAR,买3,’   买3′),COLORWHITE;
DRAWNUMBER(ISLASTBAR,卖1,卖1),COLORWHITE;
DRAWNUMBER(ISLASTBAR,卖2,卖2),COLORWHITE;
DRAWNUMBER(ISLASTBAR,卖3,卖3),COLORWHITE;
DRAWNUMBER(ISLASTBAR,卖4,卖4),COLORWHITE;
{DRAWNUMBER(ISLASTBAR,昨均价*1.01,昨均价),COLORGREEN;
DRAWNUMBER(ISLASTBAR,昨收*1.01,昨收),COLORGREEN;}
DRAWNUMBER(ISLASTBAR,买1,买1),COLORWHITE;
DRAWNUMBER(ISLASTBAR,买2,买2),COLORWHITE;
DRAWNUMBER(ISLASTBAR,买3,买3),COLORWHITE;

A1:=C>REF(C,4);
A2:=BARSLASTCOUNT(A1);
A3:=REF(A2,1)=8 AND A2>REF(A2,1);
A4:=REF(BETWEEN(A2,5,8),1) AND A2<REF(A2,1);
A5:=ISLASTBAR AND BETWEEN(A2,6,8);
A6:=(BACKSET(A3>0,9) OR BACKSET(A4>0,A2+1)*0 OR BACKSET(A5>0,A2))*A2;
DRAWTEXT(A6>0,H+H*0.02,VAR2STR(A6,0)),COLORFF00FF{COLOR00FFFF};
DRAWTEXT(A2=9,H+H*0.02,’9′),COLOR00FF00;
B1:=C<REF(C,4);
B2:=BARSLASTCOUNT(B1);
B3:=REF(B2,1)=8 AND B2>REF(B2,1);
B4:=REF(BETWEEN(B2,5,8),1) AND B2<REF(B2,1);
B5:=ISLASTBAR AND BETWEEN(B2,6,8);
B6:=(BACKSET(B3>0,9) OR BACKSET(B4>0,B2+1)*0 OR BACKSET(B5>0,B2))*B2;
DRAWTEXT(B6>0,L-L*0.02,VAR2STR(B6,0)),COLOR00FF00{COLORFFFFFF};
DRAWTEXT(B2=9,L-L*0.02,’9′),COLORFF00FF;


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址