• 欢迎访问第一股票公式网,是专业的股票公式网站,汇集目前最全、最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码并配以说明图片和下载 QQ群

红心版—大盘K线(大盘行情同步个股显示 源码)

大智慧公式 171415.com 4周前 (09-21) 9次浏览 未收录 0个评论 扫描二维码

红心版—大盘K线(大盘行情同步个股显示 源码)介绍

收盘价:indexc,linethick0;
成交额亿:INDEXA/100000000,linethick0;
涨跌幅:(indexC/REF(indexC,1)-1)*100,linethick0;
涨跌:indexC-REF(indexC,1),linethick0;
ma5:MA(INDEXC,5),colorwhite,layer2;
ma10:MA(INDEXC,10),coloryellow,layer2;
ma20:MA(INDEXC,20),colorcyan,layer2;
ma30:MA(INDEXC,30),colormagenta,layer2;
ma60:MA(INDEXC,60),colorblue,layer2;
{————————————————————————————————-}
STICKLINE(INDEXC>indexo or indexc=indexo and indexc>REF(indexc,1),indexl,indexh,0.1,0),colorred;
STICKLINE(indexc>indexo or indexc=indexo and indexc>REF(indexc,1),indexo,indexc,7,0),colorred;
STICKLINE(indexc<indexo or indexc=indexo and indexc<=REF(indexc,1),indexl,indexh,0.1,0),colorcyan;
STICKLINE(indexc<indexo or indexc=indexo and indexc<=REF(indexc,1),indexo,indexc,7,0),colorcyan;
STICKLINE(indexo>=indexc ,indexc ,indexo,0,0 ),COLOR00FF00;
STICKLINE(indexo>=indexc ,indexc ,indexo,8,0 ),COLOR008800;
STICKLINE(indexo>=indexc ,indexc ,indexo,7,0 ),COLOR009900;
STICKLINE(indexo>=indexc ,indexc ,indexo,6,0 ),COLOR00AA00;
STICKLINE(indexo>=indexc ,indexc ,indexo,5,0 ),COLOR00BB00;
STICKLINE(indexo>=indexc ,indexc ,indexo,4,0 ),COLOR00CC00;
STICKLINE(indexo>=indexc ,indexc ,indexo,3,0 ),COLOR00DD00;
STICKLINE(indexo>=indexc ,indexc ,indexo,2,0 ),COLOR00EE00;
STICKLINE(indexo>=indexc ,indexc ,indexo,1,0 ),COLOR00FF00;
STICKLINE(indexc>indexo,indexc,indexo,0,0) ,COLORFFBBFF;
STICKLINE(indexc>indexo,indexc,indexo,8,0) ,COLORFF00FF;
STICKLINE(indexc>indexo,indexc,indexo,7,0) ,COLORFF22FF;
STICKLINE(indexc>indexo,indexc,indexo,6,0) ,COLORFF44FF;
STICKLINE(indexc>indexo,indexc,indexo,5,0) ,COLORFF66FF;
STICKLINE(indexc>indexo,indexc,indexo,4,0) ,COLORFF88FF;
STICKLINE(indexc>indexo,indexc,indexo,3,0) ,COLORFF99FF;
STICKLINE(indexc>indexo,indexc,indexo,2,0) ,COLORFFAAFF;
STICKLINE(indexc>indexo,indexc,indexo,1,0) ,COLORFFBBFF;
{————————————————————–}
年:=YEAR;
月:=MONTH;
日:=DAY;
农历月:=LMONTH;
农历日:=LDAY;
星_期:=WEEKDAY;
当前:=CURRENTTIME;
时:=FLOOR(当前/10000);
分:=FLOOR((当前-FLOOR(当前/10000)*10000)/100);
秒:=FLOOR((当前-FLOOR(当前/100)*100));
DRAWRECTREL(0,0,180,1000,RGB(255,255,255)),colorwhite,layer1;
DRAWTEXTrel(10 ,30 ,NUMTOSTR( 年)+’年’+NUMTOSTR( 月)+’月’+NUMTOSTR( 日)+’日 农历:’+NUMTOSTR( 农历月)+’月’+NUMTOSTR( 农历日)+’日’),COLORblack;
DRAWTEXTrel(10 ,150 ,’当前北京时间 : ‘+NUMTOSTR( 时)+’时’+NUMTOSTR( 分)+’分’+STRRIGHT( NUMTOSTR( 秒),2 )+’秒’),COLOR000000;
DRAWTEXTrel(10,300,’★【现价】 :’+NUMTOSTR(indexc)+’点’),COLORred;
DRAWTEXTREL(10,420,’●【成交额】:’+NUMTOSTR(INDEXA/100000000)+’亿’),COLORblue;
DRAWTEXTREL(10,540,’●【涨跌】:’+NUMTOSTR(indexC-REF(indexC,1))+’点’),COLOrblue;
DRAWTEXTREL(10,660,’●【涨跌幅】:’+NUMTOSTR((indexC/REF(indexC,1)-1)*100)),COLORblue;
DRAWTEXTREL(10,780,’●【上涨家数】:’+NUMTOSTR(INDEXADV)+’家’),COLORblue;
DRAWTEXTREL(10,900,’●【下跌家数】:’+NUMTOSTR(INDEXDEC)+’家’),COLORblue;

公式为副图同步显示大盘行情,并加入了通用均线。这个公式的好处是:不用一遍遍的来回切换沪深K线图,最后交易日的大盘重要信息都会小黑板里同步显示(简便不简便?你知道)。唯一不足是,翻遍很多软件都没有大盘换手率的源码,所说,没法加换手率显示。
因通达信和飞狐版本实际转化过程中很多函数没有或图存在严重压缩现象,这里仅分享大智慧L2版本的,对通达信和飞狐用户表示歉意。

红心版---大盘K线(大盘行情同步个股显示 源码)


第一股票公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。版权投诉邮箱:313707241@qq.com 投放广告 QQ:313707241(验证:投放广告)
喜欢 (0)
[18566368118]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
红心版—大盘K线(大盘行情同步个股显示 源码)

密码 已复制

前往下载页面

低版本浏览器需手动复制密码再前往下载页面下载,谢谢