• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式等股票软件指标公式源码

通达信黄雀MACD指标公式

通达信公式 第一股票指标公式网 2周前 (01-06) 11次浏览 已收录 0个评论 扫描二维码

N1:=12;N2:=26;N3:=9;difF:=(ema(CLOSE,N1) – Ema(CLOSE,N2));DEA:=EMA(DIFF,N3);macd2:=(2 * (DIFF – DEA));DU0:=crOSS(DIFF,0);UD0:=CROSS(0,DIFF);TDU0:=BArslAst(DU0);TUD0:=BARSLAST(UD0);DU3:=REF(DU0,1);UD3:=REF(UD0,1);TDU3:=BARSLAST(DU3);TUD3:=BARSLAST(UD3);UDGLINE:=IF((TDU3 < TUD3),REF(HHV(HIGH,2),TDU3),REF(LLV(LOW,2),TUD3));JDU0:=(((REF(CLOSE,1) <= REF(UDGLINE,1)) AND (CLOSE > UDGLINE)) AND (TDU0 < TUD0));JUD0:=(((REF(CLOSE,1) >= REF(UDGLINE,1)) AND (CLOSE < UDGLINE)) AND (TUD0 < TDU0));JDU1:=(JDU0 AND (COUNT(JDU0,TDU0) = 1));JUD1:=(JUD0 AND (COUNT(JUD0,TUD0) = 1));JDU2:=(JDU1 AND (REF(BARSLAST(JUD1),1) < REF(BARSLAST(JDU1),1)));JUD2:=(JUD1 AND (REF(BARSLAST(JUD1),1) > REF(BARSLAST(JDU1),1)));JDU3:=(JDU1 AND (REF(BARSLAST(JUD1),1) > REF(BARSLAST(JDU1),1)));JUD3:=(JUD1 AND (REF(BARSLAST(JUD1),1) < REF(BARSLAST(JDU1),1)));bsLINE:=IF((BARSLAST(JDU2) < BARSLAST(JUD2)),IF(REF(CROSS(0,MacD2),1),LLV(LOW,2),REF(LLV(LOW,2),BARSLAST(REF(CROSS(0,MACD2),1)))),IF(REF(CROSS(MACD2,0),1),HHV(HIGH,2),REF(HHV(HIGH,2),BARSLAST(REF(CROSS(MACD2,0),1)))));STICKLINE((MACD2>=0),0,MACD2,2,0),COLORFF00FF;STICKLINE(((MACD2>=0) AND (MACD2 < REF(MACD2,1))),0,MACD2,2,1),COLORGREEN;STICKLINE((MACD2<0),0,MACD2,2,0),COLORFFFF00;STICKLINE(((MACD2<0) AND (MACD2 > REF(MACD2,1))),0,MACD2,2,0),COLORYELLOW;DEFUT:=BARSLAST(CROSS(MACD2,0));DEFDT:=BARSLAST(CROSS(0,MACD2));DEFUL:=IF((MACD2 >= 0),HHV(MACD2,(DEFUT + 1)),REF(HHV(MACD2,(DEFUT + 1)),(DEFDT + 1)));DEFDL:=IF((MACD2 < 0),LLV(MACD2,(DEFDT + 1)),REF(LLV(MACD2,(DEFDT + 1)),(DEFUT + 1)));DEFU2L:=REF(DEFUL,(DEFUT + 1));DEFD2L:=REF(DEFDL,(DEFDT + 1));A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);STICKLINE(底背离,0,0.03,4,0),COLOR00FF00;


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址